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1 Introduction

The enormous volume of system event logs generated daily is of growing importance to organizations
that must record information for forensic and compliance purposes. It is essential to perform real-
time network-wide event log monitoring, analysis and reporting to address any incidents or security
concerns and combat threats to business continuity.

GFI EventsManager assists with this monumental task by automatically and centrally monitoring and
managing event logs - supporting a wide range of event types generated both by applications and
devices from top vendors as well as for custom ones.

This chapter provides you with information about how events management is achieved using GFI
EventsManager.

Topics in this chapter:

1.1 About GFI EventsManager 21

1.2 How GFI EventsManager works 23

1.3 Conventions used in this guide 25

1.1 About GFI EventsManager

Screenshot 1: GFI EventsManagerintegrates into any existing IT infrastructure

GFI EventsManager is a results oriented event log management solution which integrates into any
existing IT infrastructure, automating and simplifying the tasks involved in network-wide events
management.

Through the features supported by GFI EventsManager, you are able to:
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Automatically monitor computers and network devices through GFI EventsManager's wide range of
event log support; such as Text Logs, Windows® Event Logs, Syslogs, SNMP Traps Messages, Active
Monitoring Events and even custom event logs

Monitor computers and services running on your network through active monitoring features such
as continuous checking of HTTP/HTTPS/FTP site availability, server roles queries, firewall quer-
ies and more

Optimize security and performance while tracking operational issues by auditing your critical
systems/devices; such as routers, firewall, sensors, servers and database engines

Create and maintain an automated network security system which detects intrusion attacks

Achieve compliance with various regulations and acts including SOX, PCI DSS, Code of Connection,
HIPAA, data protection laws and others

Proactively detect events which will lead to disaster such as hardware failure. When such events
are processed, GFI EventsManager provides an early warning to give you control and take cor-
rective action

Minimize the risk and business loss due to systems downtime and misconfiguration

Easily browse events from any number of databases through the extensive Events Browser; which
helps you carry out forensic investigations with minimal human input

Automatically processes and archives event logs, collecting and highlighting the information you
need to know about the most important events occurring in your network so you are never caught
off guard

Generate technical IT level and management level reports from the extensive list of reports and
also create new ones from existing reports or collected events

Protect your business by tracking the security events in your network. Find who is responsible for
security breaches and network threats

For a full list of features, refer to: http://www.gfi.com/eventsmanager#features

http://www.gfi.com/eventsmanager#features
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1.2 How GFI EventsManager works

Screenshot 2: The GFI EventsManager operational stages

The operational functionality of GFI EventsManager is divided in the following stages:

Stage 1: Event Collection

Stage 2: Event Processing
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1.2.1 Stage 1: Event Collection

During the Event Collection stage, GFI EventsManager collects logs from specific event sources. This is
achieved through the use of two event collection engines: The Event Retrieval Engine and the Event
Receiving Engine.

Engine Description

The Event
Retrieval Engine

Used to collect Windows® Event Logs and Text Logs from networked event sources. During the Event
Collection process this engine will:
1. Log-on to the event source(s)
2. Collect events from the source(s)
3. Send collected events to GFI EventsManager Server
4. Log-off from the event source(s).
The Event Retrieval Engine collects events at specific time intervals. The event collection interval
is configurable from the GFI EventsManager management console

The SQL Server®

Listener
The listener receives trace messages from the scanned Microsoft® SQL Server® in real time. On
receipt, GFI EventsManager processes the message immediately.

The Oracle
Retrieval Engine

The Oracle Retrieval Engine connects periodically to Oracle servers and collects audits from a
specific auditing table. Similar to the Microsoft® Windows® Event Retrieval Engine, GFI
EventsManager processes events generated by the Oracle server.

Log Receiving
Engine

The Event Receiving Engine acts as a Syslog and an SNMP Traps server; it listens and collects Syslog
and SNMP Trap events/messages sent by various sources on the network. As opposed to the Event
Retrieval Engine, the Event Receiving Engine receives messages directly from the event source;
therefore it does not require to remotely log-on to the event sources for event collection. Further
to this, Syslog and SNMP Trap events/messages are collected in real-time and therefore no
collection time intervals need to be configured.
By default, the Event Receiving Engine listens to Syslog messages on port 514 and to SNMP Trap
messages on port 162. Both port settings are however customizable via the GFI EventsManager
management console.

Table 1: GFI EventsManager engines

1.2.2 Stage 2: Event Processing

During this stage, GFI EventsManager will run a set of Event Processing Rules against collected events.
Event Processing rules are instructions that:

Analyze the collected logs and classify processed events as Critical, High, Medium, Low or Noise
(unwanted or repeated events)

Filter events that match specific conditions

Trigger email, SMS and network alerts on key events

Trigger remediation actions such as the execution of executable files or scripts on key events

Optionally archive collected events in the database backend.

GFI EventsManager can be configured to archive events without running events processing rules. In
such cases, even though no rules are applied against collected logs, archiving is still handled at the
Event Processing stage. For more information refer to Events Processing Rules.

Important

Some of the key modules in GFI EventsManager must run under administrative privileges.
For more information on these modules refer to the following article:
http://go.gfi.com/?pageid=esm_process_rights

http://go.gfi.com/?pageid=esm_process_rights
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1.3 Conventions used in this guide

The table below describes the common terms and conventions used in this Guide:

Term Description

Additional information and references essential for the operation of GFI EventsManager.

Important notifications and cautions regarding potential issues that are commonly encountered.

> Step by step navigational instructions to access a specific function.

Bold text Items to select such as nodes, menu options or command buttons.

Italics text Parameters and values that you must replace with the applicable value, such as custom paths and file-
names.

Code Indicates text values to key in, such as commands and addresses.

Table 2: Terms and conventions used in this manual
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2 Installing GFI EventsManager

This chapter describes the possible deployment scenarios supported by GFI EventsManager. It is
essential to review system requirements and computer settings prior to installing the product to
ensure full communication between GFI EventsManager and the network devices/computers that
must be monitored.

Topics in this chapter:

2.1 Deployment scenarios 26

2.2 System requirements 32

2.3 Upgrading GFI EventsManager 35

2.4 Installing a new instance of GFI EventsManager 44

2.5 Testing the installation 53

2.1 Deployment scenarios

GFI EventsManager can be installed on any computer which meets the minimum system requirements
irrespective of the location on your network. If you want to collect event logs from Microsoft®

Windows® Vista or later operating systems, GFI EventsManager must be installed on a machine
running Microsoft® Windows® Vista, 7, Server 2008 or Server 2012.

Use GFI EventsManager to manage event logs generated by:

The same computer where it is installed

All the servers, workstations and network devices that are reachable from the computer on which
it is installed on.
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Figure 1: GFI EventsManager deployment scenario

This section contains information about deploying GFI EventsManager in a:

Local Area Network (LAN) - Monitor activity of the main production network, servers and work-
stations

Demilitarized Zone (DMZ) - Monitor events generated by public service servers, such as mail serv-
ers, web servers and DNS servers

Wide Area Network (WAN) - Monitor events generated by computers and network devices spread
across different geographical locations.
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2.1.1 GFI EventsManager within in a Local Area Network (LAN)

GFI EventsManager can be deployed on Windows® based networks as well as on mixed environments
where Linux and Unix systems are being used as well.

Figure 2: Deployment of GFI EventsManager in LAN

When installed on a Local Area Network (LAN) GFI EventsManager can manage Windows® events, Text
Logs, Syslog messages, SNMP Trap and SQL Server® audit messages generated by any hardware or
software that is connected to the LAN, including:

Device Example

Workstations and laptops End-user computers and systems.

Servers Web servers, Mail servers, DNS servers and more.

Network devices Routers, switches and any other device that generates
performance logs.

Software Including GFI EndPointSecurity, GFI LanGuard and other
applications that generate logs.

Specialized Services Microsoft® Internet Information Server – IIS.

PABXs, Keyless Access Systems, Intrusion detec-
tions systems and more

GFI EventsManager enables you to monitor any device that is
attached to the network.

Table 3: Devices supported by GFI EventsManager
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2.1.2 GFI EventsManager within a Demilitarized Zone (DMZ)

GFI EventsManager is able to monitor events generated by machines in a DMZ, from being installed
within the LAN or by being installed directly in the DMZ. Since a firewall or a router usually protects
this zone with network traffic filtering capabilities, you must make sure that:

The communication ports used by GFI EventsManager are not blocked by the firewall. For more
information on the communication ports used by GFI EventsManager refer to: http://go.g-
fi.com/?pageid=esm_ports.

GFI EventsManager has administrative privileges over the computers that are running on the DMZ.

Important

GFI recommends to install GFI EventsManager directly in the DMZ as opposed to enabling
firewall ports and permissions to allow communication between LAN and DMZ
computers, servers and network devices.

Figure 3: The DMZ sits between the internal LAN and the Internet

A DMZ is the neutral network which sits between the “internal” corporate network and the “outside
world” (Internet). The deployment of GFI EventsManager in a DMZ helps you automate the
management of events generated by DMZ hardware and software systems; such as:

http://go.gfi.com/?pageid=esm_ports
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DMZ Automation Description

Automate
management of
Web and Mail
server events

DMZ networks are normally used for the running of hardware and software systems that have
Internet specific roles such as HTTP servers, FTP servers, and Mail servers.
Hence, you can deploy GFI EventsManager to automatically manage the events generated by:

Web-servers including the W3C web-logs generated by Apache web-servers on LAMP web plat-
forms

Windows® based web-servers including the W3C web-logs generated by Microsoft® Internet
Information Servers (IIS)

Linux/Unix and Windows® based mail-servers including the Syslog auditing services messages
generated by Sun Solaris v. 9 or later

Automate management of DNS server events

If you have a public DNS server, there’s a good chance that you are running a DNS server on the
DMZ. Hence you can useGFI EventsManager to automatically collect and process DNS server
events including those stored in your Windows® DNS Server logs.

Automate man-
agement of DNS
server events

If you have a public DNS server, there’s a good chance that you are running a DNS server on the DMZ.
Hence you can use GFI EventsManager to automatically collect and process DNS server events includ-
ing those stored in your Windows® DNS Server logs.

Automate
management of
network
appliance
events

Routers and firewalls are two network appliances commonly found in a DMZ. Specialized routers and
firewalls (example: Cisco IOS series routers) not only help protect your internal network, but
provide specialized features such as Port Address Translation (PAT) that can augment the
operational performance of your systems.
By deploying GFI EventsManager on your DMZ, you can collect the events generated by such
network appliances. For example, you can configure GFI EventsManager to act as a Syslog Server and
collect in real-time the Syslog messages generated by Cisco IOS routers.

Table 4: Benefits of installing GFI EventsManager in DMZ



GFI EventsManager 2 Installing GFI EventsManager | 31

2.1.3 GFI EventsManager within a Wide Area Network (WAN)

GFI EventsManager can be installed in environments that have multiple sites in different geographical
locations.

Screenshot 3: Export data from remote sites to the main instance of GFI EventsManager

This is achieved by installing an instance of GFI EventsManager at each location. Periodically (based
on a schedule), you can export events from the remote sites and import them into the central
database for complete consolidation of event logs.

Events for the remote site can then be viewed through the Events Browser. Reports with information
relevant to remote sites can also be generated using data from the central database. Use the Switch
Database option to view or report on information stored on remote databases.

Note

For more information refer to Switching File Storage Databases.

Note

For more information refer to Database Maintenance.
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2.2 System requirements

To install GFI EventsManager, the host computer must meet the system requirements specified
below. If you plan to manage a large number of event sources in a high traffic network, consider using
a computer with greater system specs. Refer to the following sections for information about:

Hardware requirements

Supported operating systems (32-bit and 64-bit)

Other software components

Storage requirements

Firewall ports and protocols

Firewall permissions

Event source settings

Antivirus exceptions

Computer identification considerations

Collecting event logs from computers running Microsoft® Vista or later

2.2.1 Hardware requirements

The following table contains hardware requirements for GFI EventsManager:

Hardware Component Specification

Processor 2.5 GHz dual core or higher.

RAM 3 GB.

Hard disk 10 GB free space.

Table 5: Hardware requirements

Note

Hard disk size depends on your environment, the size specified in the requirements is
the minimum required to install and archive events.

2.2.2 Supported operating systems (32-bit and 64-bit)

GFI EventsManager can be installed on a computer running any of the following operating systems:

Windows® Server 2012 - Foundation, Essentials, Standard or Datacenter

Windows® Server 2008 - Standard or Enterprise

Windows® Server 2008 R2 – Standard or Enterprise

Windows® Server 2003 SP2 - Standard or Enterprise

Windows® 8 - Standard, Professional or Enterprise

Windows® 7 - Enterprise, Professional or Ultimate

Windows® Vista SP1 - Enterprise, Business or Ultimate

Windows® XP Professional SP3
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Windows® SBS 2008

Windows® SBS 2003.

Note

GFI EventsManager cannot be installed on Server Core Installations.

2.2.3 Other software components

The additional software components below are recommended to be installed to ensure full
functionality of GFI EventsManager:

Microsoft® .NET framework 4.0

Microsoft® Data Access Components (MDAC) 2.8 or later

A mail server (when email alerting is required).

Note

Microsoft® Data Access Components (MDAC) 2.8 can be downloaded from
http://go.gfi.com/?pageid=esm_mdac

2.2.4 Storage requirements

The storage requirements below are based on the average size of an event log, being 535 bytes per
event. The following specifications indicate the required hard disk size, that caters for your
infrastructure's requests:

Hard Disk Space Number of Events

Events stored per 1 Gb of storage space 2,006,994

Events stored in 500 Gb of storage space 1,003,497,032

Table 6: Storage space requirements

2.2.5 Firewall ports and protocols

The following table contains ports and protocols that must be allowed by the firewall of the GFI
EventsManager host:

Port Protocols Description

135 UDP and
TCP

Target machines use this port to publish information regarding available dynamic ports. GFI
EventsManager uses this information to be able to communicate with the target machines.

139
and
445

UDP and
TCP

Used by GFI EventsManager to retrieve the event log descriptions from target machines.

162 UDP and
TCP

Used by GFI EventsManager to receive SNMP traps. Ensure that this port is open on the machine
where GFI EventsManager is installed.

514 UDP and
TCP

Used by GGFI EventsManager to receive SYSLOG messages.

1433 UDP and
TCP

Used by GFI EventsManager to communicate with the SQL Server® database backend. Ensure that
this port is enabled on Microsoft® SQL Server® and on the machine where GFI EventsManager is
installed.

Table 7: Firewall ports and protocols

http://go.gfi.com/?pageid=esm_mdac
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Port Protocols Description

1521 UDP and
TCP

Used to collect Oracle Server audit logs. Port 1521 is the default port for this connection. If the
port is changed manually in the Oracle Listener’s configuration, adjust firewall settings
accordingly.

49153 UDP and
TCP

Used by GFI EventsManager to collect events from event sources with Microsoft® Windows®Vista or
Microsoft® Windows® 7.

2.2.6 Firewall permissions

The following table contains permissions that must be allowed by the firewall of the GFI
EventsManager host:

Firewall
Permissions and
Audit Policies

Windows® Server
2008

Windows® Server
2003

Windows® XP Windows® 7 Windows® Vista

Remote Event
Log Management

Enable Not applicable Not applicable Enable Enable

File and Printer
sharing

Enable Enable Enable Enable Enable

Network
discovery

Enable Not applicable Not applicable Enable Enable

Audit policy:
Object access

Enable Not applicable Not applicable Enable Enable

Audit policy:
Process tracking

Enable Not applicable Not applicable Enable Enable

Audit policy:
Audit account
management

Enable Enable Enable Enable Enable

Audit policy:
Audit system
events

Enable Enable Enable Enable Enable

Table 8: Firewall permissions

Note

For more information, refer to Enabling permissions on events sources manually or
Enabling permissions on event sources automatically.

2.2.7 Event source settings

The following table contains settings that must be configured on your event sources. Event sources
are computers that you want to monitor by GFI EventsManager:

Log Type Description

Windows® event log pro-
cessing

Enable remote registry.

Text log processing The source folders must be accessible via Windows® shares.

Syslog and SNMP Traps pro-
cessing

Configure sources/senders to send messages to the computer/IP where GFI
EventsManageris installed.

Scanning machines with
Windows® Vista or later

Install GFI EventsManager on a computer running Windows® Vista or later.

System auditing Enable auditing on event sources. For information, refer to Enabling event source
permissions manually and Enabling event source permissions automatically.

Table 9: Event source settings
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2.2.8 Antivirus exceptions

If an antivirus application installed on the computer where GFI EventsManager is running, make sure
that:

Traffic is not blocked on the ports in use by GFI EventsManager

esmui.exe and esmproc.exe are allowed access through the firewall(s)

GFI EventsManager folders are excluded from real-time antivirus scanning.

2.2.9 Computer identification considerations

GFI EventsManager identifies computers via computer name or IP. If NETBIOS-compatible computer
names are used, ensure that your DNS service is properly configured for name resolution. Unreliable
name resolution downgrades overall system performance. If you disable NETBIOS over TCP/IP, you
can still use GFI EventsManager, however you must specify computer name by IP.

2.2.10 Collecting event logs from computers running Microsoft® Vista or later

GFI EventsManager cannot be installed on Microsoft® Windows® XP to monitor events of Microsoft®

Windows® Vista or later. Microsoft® Windows® Vista and Microsoft® Windows® 7 introduced extensive
structural changes in event logging and event log management. The most important of these changes
include:

A new XML-based format for event logs. This provides a more structured approach to reporting on
all system occurrences.

Event categorization in four distinct groups: Administrative, Operational, Analytic and Debug

A new file format (evtx) that replaces the old evt file format.

Due to these changes, to collect and process event logs from Microsoft® Windows® Vista or later, GFI
EventsManager must be installed on a system running:

Windows® Vista

Windows® 7

Windows® Server 2008.

Note

Windows® XP events can be collected when GFI EventsManager is installed on Windows®

Vista or later machines.

Note

When GFI EventsManager is using a non-domain account to collect events from
Windows® Vista machines or later, target machines must have User Account Control
(UAC) disabled. For more information refer to Disabling User Account Control (UAC).

2.3 Upgrading GFI EventsManager

Upgrading from versions older than GFI EventsManager 2011 is not fully supported. Some settings may
be lost due to the underlying technology changes. GFI EventsManager can be upgraded using any of
the following methods:
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Method Description

Automatically Launch the new setup and complete the wizard to upgrade and retain data. For more information refer
to Upgrading from a previous version.

Manually Export settings and events from an older version of GFI EventsManager and import them in the new one
using Database Operations and Import/Export tools. For more information refer to Creating Maintenance
Jobs and Importing and Exporting Settings.

Table 10: Upgrading GFI EventsManager

2.3.1 Upgrading from a previous version

Note

Before starting the upgrade, disable any anti-virus software running on the system.

To upgrade to a new version:

1. Double-click EventsManager.exe.

Screenshot 4: Upgrade prerequisite check

2. The installer displays a list of system components that must be installed prior to installing the
product. Click Install to start the installation of missing system components (if necessary).
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Screenshot 5: DLib Database Server

3. The DLib Database Server install wizards opens automatically after system components are
installed. Click Next at the wizard welcome screen.

Screenshot 6: DLib Database Server EULA

4. Carefully read the license agreement. Select I accept the terms in the License Agreement and
click Next.
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Screenshot 7: DLib install folder

5. Click Next to install the database server in the default folder or click Change... to select an
alternate folder where it is installed.

Screenshot 8: Start installing DLib Database Server

6. Click Install to start installing DLib Database Server. Click Finish when prompted.
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Note

After the database server is installed, the installer automatically opens the install
wizard of GFI EventsManager Management Console.

7. Click Yes to uninstall the previous version of GFI EventsManager and continue installing the new
one. Click No to stop the installation.

Note

Running two instances of the Management Console on the same computer is not
supported.

Screenshot 9: Delete old version files

8. Click Yes to confirm the deletion of files from the older version of GFI EventsManager or click No to
stop the installation.

Screenshot 10: GFI EventsManager setup wizard welcome screen

9. Click Next at the welcome screen of the GFI EventsManager setup wizard.
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Screenshot 11: GFI EventsManager EULA

10. Carefully read the license agreement. Select I accept the terms in the License Agreement and
click Next.

Screenshot 12: GFI EventsManager registration details

11. Key in your user name and license key in the User Name and License Key fields. To register for a
free 30 day evaluation license key, click Register. Click Next.
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Screenshot 13: Remote logon credentials for event log monitoring

12. Key in the logon credentials that GFI EventsManager uses to log onto remote computers.

Note

It is recommended to use a domain administrator or an account with administrative
rights over all the remote computers managed by GFI EventsManager.
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Screenshot 14: GFI EventsManager install folder

13. Click Next to install the Management Console in the default folder or click Change... to select an
alternate folder where it is installed.

Screenshot 15: GFI EventsManager installation completed

14. Click Install to start the installation.

15. When the installation is complete, click Finish.
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Screenshot 16: Auto updates check

16. If GFI EventsManager detects an Internet connection, it automatically attempts to download
product updates from GFI updates servers. Click Details to expand the information section of the Auto
Update dialog and view the updates that are being downloaded.

Screenshot 17: Set the database backend

Note

After product updates are applied, the Switch Database Server dialog opens. This dialog
is used to link the Management Console to a database server. You can switch database
servers from the Management Console. For more information refer to Switching
between file storage databases.

17. Specify the computer that has D-Lib Database Server installed on it. If the database you want to
use is on:

The localhost - key in localhost (default)

A remote computer - key in the computer name or IP address.

Click OK.

Note

Once the installation is complete, the Management Console opens automatically. To
launch it manually, click Start > All Programs > GFI EventsManager > Management
Console.
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Note

Configuration data of GFI EventsManager 2012 is not deleted. Data is copied to the new
install folder (%install folder%\Data_Old). Data in this folder is used to retain previous
configurations.

Note

Test the installation to ensure that all the components were successfully installed. For
more information refer to Testing the installation.

2.4 Installing a new instance of GFI EventsManager

The components listed in the following table can be installed using EventsManager.exe:

Component Description

System com-
ponents

The following system components are required by GFI EventsManager for complete functionality:
Visual C++ 2010 redistributable

Microsoft® .NET Framework 2.0

Microsoft® .NET Framework 4.0

Microsoft® SQL Server® Compact 3.5 SP2

MSXML6

Microsoft® SQL Server® Native Client

Microsoft® SQL Server® Management Objects Collection.

DLib Database
Server

DLib Database Server is the component where GFI EventsManager stores processed logs. The database
server can be installed on the same computer that is running GFI EventsManager as well as on a
separate remote computer or network drive.

GFI Event-
sManager

The actual product from where you can manage and monitor events generated by computers and
devices in your network.

Table 11: Components installed using EventsManager.exe

2.4.1 Installation procedure

To install GFI EventsManager:

1. Double-click EventsManager.exe.
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Screenshot 18: Upgrade prerequisite check

2. The installer displays a list of system components that must be installed prior to installing the
product. Click Install to start the installation of missing system components (if necessary).
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Screenshot 19: DLib Database Server

3. The DLib Database Server install wizards opens automatically after system components are
installed. Click Next at the wizard welcome screen.

Screenshot 20: DLib Database Server EULA

4. Carefully read the license agreement. Select I accept the terms in the License Agreement and
click Next.
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Screenshot 21: DLib install folder

5. Click Next to install the database server in the default folder or click Change... to select an
alternate folder where it is installed.

Screenshot 22: Start installing DLib Database Server

6. Click Install to start installing DLib Database Server. Click Finish when prompted.
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Note

After the database server is installed, the installer automatically opens the install
wizard of GFI EventsManager Management Console.

Screenshot 23: GFI EventsManager setup wizard welcome screen

7. Click Next at the wizard welcome screen.
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Screenshot 24: GFI EventsManager EULA

8. Carefully read the license agreement. Select I accept the terms in the License Agreement and
click Next.

Screenshot 25: GFI EventsManager registration details

9. Key in your user name and license key in the User Name and License Key fields. To register for a
free 30 day evaluation license key, click Register. Click Next.
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Screenshot 26: Remote logon credentials for event log monitoring

10. Key in the logon credentials that GFI EventsManager uses to log onto remote computers.

Note

It is recommended to use a domain administrator or an account with administrative
rights over all the remote computers managed by GFI EventsManager.
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Screenshot 27: GFI EventsManager install folder

11. Click Next to install the Management Console in the default folder or click Change... to select an
alternate folder where it is installed.

Screenshot 28: GFI EventsManager installation completed

12. Click Install to start the installation.

13. When the installation is complete, click Finish.
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Screenshot 29: Auto updates check

14. If GFI EventsManager detects an Internet connection, it automatically attempts to download
product updates from GFI updates servers. Click Details to expand the information section of the Auto
Update dialog and view the updates that are being downloaded.

Screenshot 30: Set the database backend

Note

After product updates are applied, the Switch Database Server dialog opens. This dialog
is used to link the management console to a database server. You can switch database
servers from the Management Console. For more information refer to Switching
between file storage databases.

15. Specify the computer that has D-Lib Database Server installed on it. If the database you want to
use is on:

A remote computer - key in the computer name or IP address

The localhost - key in localhost (default).

Click OK.

Note

Once the installation is complete, the Management Console opens automatically. To
launch it manually, click Start > All Programs > GFI EventsManager > Management
Console.
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Note

Test the installation to ensure that all the components were successfully installed. For
more information refer to Testing the installation.

2.5 Testing the installation

After all the required components are installed, the Management Console opens automatically. By
default, it is configured to launch the Quick Launch Console on startup.

Screenshot 31: Running GFI EventsManager for the first time

Select an option from the Quick Launch Console to process events or customize default settings:

Option Description

Process events - Local
computer

Start processing logs generated by the GFI EventsManager host.

Note
For more information refer to Process events - Local computer.

Process events - Local
domain

Start processing logs generated by computers and network devices within the same
domain as the GFI EventsManager host.

Note
For more information refer to Process events - Local domain.

Process events - Selected
machines

Start processing logs generated by specific computer(s).

Note
For more information refer to Process events - Selected machines.

Table 12: Quick Launch Console options



GFI EventsManager 2 Installing GFI EventsManager | 54

Option Description

Customize... Customize default settings, such as:
Event sources and log types

Events processing rules

Database operations

Alert recipients

Alerting options

Active monitoring.

2.5.1 Process events - Local computer

This option enables you to automatically add the localhost as an event source and start processing
logs generated by it.

To process events from the local computer:

Screenshot 32: Process events - Local computer

1. Click Process events - Local computer.
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Screenshot 33: Console main actions

2. After the localhost logs start processing, you can:

Icon Description

Browse events
Access the built-in events and forensic tools that will help you to locate, analyze and filter key events. For
more information refer to Browsing Stored Events.

Generate reports
Access reporting features including instant/scheduled report generations and automated report
distribution. For more information refer to Reporting.

View dashboard
Access GFI EventsManager status dashboard. This enables you to view graphical representations of the most
important events collected and processed by GFI EventsManager. For more information refer to Activity
Monitoring.

Customize
Customize GFI EventsManager settings, such as enabling Syslog, SNMP Trap processing, system checks, key
events notifications, and more. For more information, refer to:

Managing event sources

Configuring events processing rules

Configuring database maintenance options

Configuring alerts and default actions

Configuring active monitoring

Table 13: Quick Launch Console options
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Note

To confirm that logs are successfully processed, go to Status tab > Job Activity and
check that there are activity logs under the Operational History section.

2.5.2 Process events - Local domain

This option enables you add one or more computers that are on the same domain or workgroup as GFI
EventsManager. The Automatic Network Discovery wizard enables you to select the type of event
sources you want to add and then lists the sources that are detected.

To process event from computers on the same domain/workgroup:

Screenshot 34: Process events - Local domain

1. Click Process events - Local domain. This opens the Automatic Network Discovery wizard.

Note

The wizard can also be launched from Configuration tab > Event Sources. From the left
pane, right-click All event sources and select Scan local domain.
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Screenshot 35: Automatic discovery wizard

2. Click Next at the wizard welcome screen.

Screenshot 36: Select event source types to detect on your network

3. Select the type of event sources that the wizard will attempt to detect on your network. Click
Next.
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Screenshot 37: Search network progress

Note

If GFI EventsManager detects computers that cannot be logged onto using the supplied
credentials, it enables you to specify alternate logon credentials for each computer you
select.

4. Select a computer from the list and key in the username and password. Click OK to close the
Alternative Credentials dialog.

Note

Repeat this step until all the required sources are added.

5. Click Next and Finish.

Note

To automatically add new computers that are joined to the same domain/workgroup as
GFI EventsManager, you must configure Synchronization Options. For more information
refer to Adding event sources automatically.
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2.5.3 Process events - Selected machines

This option enables you to add specific computers manually, by:

Keying in computer names and IPs

Selecting computers from reachable domains and workgroups

Importing computers from a text file containing a single computer name per line.

To process events of selected machines:

Screenshot 38: Process events - Selected machines

1. Click Process events - Selected machines.

2. This opens the Add New Event Source dialog.
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Screenshot 39: Add new event source wizard

3. The following table describes the available options:

Option Description

Add Key in the computer name or IP address in the Add the following computers field. Click Add to add the
specified computer to the Computer list.

Note
Repeat this step until you add all the event sources to the selected group.

Note
Since Syslog and SNMP traps use IP addresses to determine the source of an event, it is recommended
to use the source IP address instead of the computer name when adding Syslog and SNMP Traps
sources.

Remove Select one or more computers from the Computer list and click Remove to delete them from the list.

Select... Click Select... to launch the Select Computers... dialog:
1. From the Domain drop-down menu, select the domain you want to scan for available sources and click
Search.
2. From the search results list, select the computers you want to add.
3. Click OK to close the Select Computers... dialog and return to the Add New Event Sources... dialog.

Import... Click Import... to import computers from a text file. Ensure that the text file contains only one computer
name or IP address per line.

Table 14: Adding new event sources manually

4. Click Finish to finalize your settings. GFI EventsManager immediately attempts to scan the added
event sources, using the default logon credentials. For more information refer to Configuring event
source logon credentials.
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Note

If synchronization is not enabled, you can use the Network Discovery Wizard to
automatically search and add events sources. To launch Network Discovery Wizard,
right-click All event sources from the event sources tree and select Scan local domain.
For more information refer to Adding event sources automatically.

Note

To confirm that logs are successfully processed, go to Status tab > Job Activity and
check that there are activity logs under the Operational History section.
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3 Achieving Results

This chapter provides information on how to use GFI EventsManager to achieve results. The
information provided helps you conduct positive forensic investigations and system monitoring. It also
enables you to achieve positive legal compliance results, while ensuring network security at all times.

Topics in this chapter:

3.1 Achieving Network Security 62

3.2 Effective System Health Monitoring 64

3.3 Achieving PCI DSS Compliance 66

3.1 Achieving Network Security

Many companies mistakenly assume that unauthorized access is an external threat only. The majority
of corporate security threats actually stem from internal sources, against which a firewall offers no
protection. A good security strategy includes real-time monitoring for critical security events and
periodic analysis of your systems' security logs so that you can detect and respond quickly to attacks.

Network security is defined as a set of rules and policies adopted by a network administrator to
monitor and prevent misuse and unauthorized access of a network. For an effective secure network
strategy follow the steps described below:

1. Add Management Console Users and Groups
GFI EventsManager can be managed by multiple users. You can link console activity to different
users by creating a user for each person who is accessing the console and making changes to
configurations.

Create users to be able to audit individual activity. For more information refer to Managing
user accounts.

Create user groups so that multiple users can be managed at once. For more information refer
to Managing user groups.

2. Configure console security options
GFI EventsManager enables you to configure console security options to facilitate securing
sensitive information.

Enable GFI EventsManager login system so that users can be tracked individually. For more
information refer to Enabling the login system.

Configure anonymization options so that unauthorized users are not able to view sensitive
information within the management console. For more information refer to Anonymization.

Enable user auditing so that an activity log can be created for each user who changes system
configurations. For more information refer to Auditing console activity.
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3. Configure Alerts and Default Actions
GFI EventsManager enables you to keep track of network activity in real-time by triggering alerts,
execute scripts and perform other operations when certain event logs are collected.

Configure alert recipients and notification settings for SMS, Email, Network and SNMP mes-
sages. For more information refer to Configuring Alerting Options.

Configure operations that are performed on detection of specific attributes of an event log.
For more information refer to Configuring Default Classification Actions.

4. Add event sources
If you haven't done already, add the event sources that you want to secure.

Add event sources manually by specifying IP addresses and/or computer names. For more
information refer to Adding event sources manually.

Add event sources automatically, as soon as they are joined to the domain or network. For
more information refer to Adding event sources automatically.

5. Enable event source auditing permissions
In order to audit event sources, Auditing options must be enabled from the source operating
system.

Manually enable auditing options for single computers. For more information refer to Enabling
event source permissions manually.

Automatically enable auditing options for larger groups of computers. For more information
refer to Enabling event source permissions automatically.

6. Collect event logs
Start collecting event logs generated by the sources added in the previous step. Event logs can be
collected as soon as the source is added, however, you can further customize event source settings
to retrieve specific information.

Configure event source properties such as logon credentials, licensing type and more. For
more information refer to Configuring event source properties.

Configure event sources to collect and process Windows Event Logs, SNMP Traps Messages,
Text Logs and more. For more information refer to Collecting Event Logs.

7. Analyze the collected event logs and monitor activity
After collecting the required event logs, you are able to analyze them from Events Browser.
Events Browser allows you to create custom rules from the collected logs. This enables you to
trigger alerts or actions when events of the same type are collected.

Create rules based on collected events. Events processing rules check an event log and per-
form actions based on the settings configured in Step 3. For more information refer to Creat-
ing new rules from existing events.

Monitor events management activity from the extensive dashboard views. For more inform-
ation refer to Activity Monitoring.
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3.2 Effective System Health Monitoring

GFI EventsManager is able to perform thorough system checks on your servers and workstations. It
uses Active Monitoring to help you detect and proactively fix system errors and hardware defects, to
prevent network disasters.

System checks are able to monitor mission-critical servers including Microsoft® ISA Server®, Exchange
Server®, SQL Server® and IIS®. They can even be configured to delve deeper into systems and monitor
email queues, SMTP gateways, MAPI availability, bad hard disk blocks, disk space, and more.

Monitoring the effectiveness of rules and policies enforced on your systems helps determine how well
plans and actions are working in practice.

1. Add event sources
After GFI EventsManager is installed, it automatically adds the localhost to the list of event
sources. Add other sources manually or automatically, according to your preferences.

Add computers manually by specifying computer names, IP addresses. For more inform-
ation refer to Adding event sources manually.

Computers can also be added automatically as soon as they are discovered by GFI Event-
sManager. For more information refer to Adding event sources automatically.

2. Configure event sources
Configure event source properties to enable active monitoring and events processing. Refer to
the following sections for information about:

Configuring event source properties

Configuring event source monitoring

Collecting event logs.

3. Configure alerts and default actions
One of the key features of GFI EventsManager is the ability to send notifications and perform
pre-defined actions when certain event logs are collected.
Plan how notifications are sent and configure mail server, SMS gateway or network settings
accordingly. Add recipients in GFI EventsManager to which notifications are sent.
Once complete, configure the default actions to perform when specific events are processed.
Refer to the following section for information about:

Configuring the administrator account

Managing user accounts

Configuring alerting options

Configuring default classification actions.
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4. Configure Active Monitoring
Active Monitoring Checks are conditional parameters, run against event sources on based a
schedule. Whether the parameter conditions are being met or not, monitoring checks generate
event logs.
The generated event log can be combined with events processing rules to further analyze the
issue that generated the log, send notifications, execute scripts and perform remedial actions.
GFI EventsManager contains a few generic Active Monitoring that you can use out of the box.
You can also create new ones and configure granular settings to acquire accurate and
meaningful information. Refer to the following sections for information about:

Active Monitoring

Creating and configuring root folders

Creating and configuring Active Monitoring

Applying Active Monitoring

Analyzing Active Monitoring activity.

5. Configure events processing rules
Events processing rules are conditional checks that are run against collected event logs. Based
on the information found in the event log (such as Log Type, Timestamp and Classification)
GFI EventsManager determines the action that has to be performed.
Create new rules from event logs generated by active monitoring checks to trigger automatic
remedial operations when a system error is detected.
Optionally, configure event sources to run System Health rules against collected event logs.
Refer to the following sections for information about:

Events processing rules

About events processing rules

Managing rules-set folders

Creating new rules from existing events

Configuring rule conditions

Configuring event sources to process logs with System Health rules.

6. Generate reports
GFI EventsManager enables you to generate reports for technical IT staff as well as executive
summary reports for management personnel. Reports help you visualize your network
information, through graphs and charts, as well as statistical information provided in your
reports.
GFI EndPointSecurity ships with variety of pre-defined reports and also allows you to create
new reports or modify existing ones.

Available reports

Generating reports

Managing Reports

Creating custom reports

Configuring report filtering conditions.
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3.3 Achieving PCI DSS Compliance

The Payment Card Industry (PCI) Data Security Standard (DSS) is a standard defining a list of
requirements for security management, policies, network architecture and other measures that helps
protect a customer's account and credit card information details.

Full compliance with PCI DSS requires complete event log management coupled with extensive
reporting, GFI EventsManager is therefore an essential solution to assist with your PCI compliance
program. To learn more about how to be compliant with PCI DSS, use the following links:

Whitepaper on PCI DSS Compliance and GFI Software Products
Review GFI white papers on PCI DSS Compliance:

http://go.gfi.com/?pageid=EM_PCIDSS

How GFI EventsManagercan assist in PCI DSS compliance
Regularly monitor events management activities. For more information refer to Activity
Monitoring.

Apply event processing rules based on PCI DSS requirements list. For more information
refer to Events Processing Rules.

Generate reports regularly to monitor events. For more information refer to Reporting.

http://go.gfi.com/?pageid=LAN_PCIDSS_Compliance_Whitepaper
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4 Managing Event Sources

This chapter provides you with information about adding and managing your event sources. Event
sources are networked computers and devices that are accessed and processed by GFI
EventsManager. The Events Sources sub-tab, enables you to organize your event sources into specific
groups. You can create new groups or use the default ones to distinctively configure and organize
event sources.

Topics in this chapter:

4.1 Adding event sources manually 67

4.2 Adding event sources automatically 68

4.3 Creating a new event source group 71

4.4 Configuring event source properties 73

4.5 Database sources 81

4.1 Adding event sources manually

To manually add a new event sources to a computer group:

1. Click Configuration tab > Event Sources and from Group Type, select Event Sources Groups.

2. Right-click a computer group of your choice and select Add new event source…

Screenshot 40: Add new event source wizard

3. The following table describes the available options:
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Option Description

Add Key in the computer name or IP address in the Add the following computers field. Click Add to add the
specified computer to the Computer list.

Note
Repeat this step until you add all the event sources to the selected group.

Note
Since Syslog and SNMP traps use IP addresses to determine the source of an event, it is recommended
to use the source IP address instead of the computer name when adding Syslog and SNMP Traps
sources.

Remove Select one or more computers from the Computer list and click Remove to delete them from the list.

Select... Click Select... to launch the Select Computers... dialog:
1. From the Domain drop-down menu, select the domain you want to scan for available sources and click
Search.
2. From the search results list, select the computers you want to add.
3. Click OK to close the Select Computers... dialog and return to the Add New Event Sources... dialog.

Import... Click Import... to import computers from a text file. Ensure that the text file contains only one computer
name or IP address per line.

Table 15: Adding new event sources manually

4. Click Finish to finalize your settings. GFI EventsManager immediately attempts to scan the added
event sources, using the default logon credentials. For more information refer to Configuring event
source logon credentials.

Note

If synchronization is not enabled, you can use the Network Discovery Wizard to
automatically search and add events sources. To launch Network Discovery Wizard,
right-click All event sources from the event sources tree and select Scan local domain.
For more information refer to Adding event sources automatically.

4.2 Adding event sources automatically

GFI EventsManager enables you to automatically synchronize domains with event sources groups.
When synchronization is configured, every new domain member is automatically added to GFI
EventsManager's event source list.

To enable auto synchronization:

1. Click Configuration tab > Event Sources and from Group Type, select Event Sources Groups.

2. Right-click All event sources and select Edit synchronization options.
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Screenshot 41: Synchronization properties - General tab

3. Select General tab and configure the options described below:

Option Description

Domain Select the domain name from the list or key in a valid domain name.

Group Select the GFI EventsManager group name where to add the discovered event sources.

Source type Select the type of event sources that GFI EventsManager scans for, in the specified domain.

Table 16: Synchronization properties - General tab

4. To include the synchronization click Add.

5. Repeat steps 3 to 4 for each domain you want to synchronize.
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Screenshot 42: Excluding computers from automatic synchronization

6. (Optional) Select Exclusions tab to configure the list of computers that will be excluded from
synchronization. Click Add and key in a computer name to exclude.

Note

Event sources that are already part of an event source group will be automatically
excluded from synchronization.

7. Select Schedule tab to configure when the synchronization should be performed.
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Screenshot 43: Synchronization properties -Schedule tab

8. Key in a valid interval in hours or days.

9. (Optional) Select Send an email to the… to send an email notification when event sources are
changed after synchronization.

10. (Optional) Click Synchronize now to synchronize event sources immediately.

11. Click Apply and OK.

Note

Adding event sources manually to a synchronized group is not allowed in GFI
EventsManager.

4.3 Creating a new event source group

Grouping event sources into Event Source Groups improves the speed at which you configure event
sources. Once an event source group is configured, every member of that particular group inherits the
same settings.

To create a new event source group:

1. Click Configuration tab > Event Sources and from Group Type, select Event Sources Groups.

2. Right-click All event sources and select Create group…

3. Select the license type. Choose between Complete or Active Monitoring license. For more
information refer to Configuring event source license type.



GFI EventsManager 4Managing Event Sources | 72

Screenshot 44: Add new event source group

4. Key in a unique name and an optional description. Select the tabs described below, and configure
the available options:

Tab Name Description

General Enable collection of events and schedule the scanning process. For more information refer to Configuring
general event source properties.

Logon
credentials

Configure the username and password used to login target machines and collect information. For more
information refer to Configuring event source logon credentials.

Licensing
type

Select the type of license to use. Select between Active Monitoring or Complete. For more information
refer to Configuring event source license type.

Operational
time

Configure the operational time that computers are normally used. For more information refer to
Configuring event source operational time.

Monitoring Enable GFI EventsManager active monitoring on target computers and configure the audits to perform.
Monitoring checks enable administrators to identify system problems at the very early stages to prevent
system down-time. For more information refer to Configuring event source monitoring.

Windows
Event Log

Specify the logs to collect and configure archive settings for Windows® event logs. For more information
refer to Collecting Windows® events.

Text Logs Specify the logs to collect and configure settings for W3C/HTTP/CSV logs. This tab is only available when
creating a server group. For more information refer to Collecting Text logs.

Syslog Specify the logs to collect and configure archive settings for Syslogs. This tab is only available when
creating a server group. For more information refer to Collecting Syslogs.

SNMP Traps Specify the logs to collect and configure archive settings for SNMP Traps. This tab is only available when
creating a server group. For more information refer to Collecting SNMP Traps Messages.

Table 17: Event source group options

5. Click Apply and OK.
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4.4 Configuring event source properties

GFI EventsManager allows you to customize the event source parameters to suit the operational
requirements of your infrastructure. You can configure these parameters on single event sources or
at event source group. Any member of a configured group inherits the same configuration,
automatically.

This section contains information about:

Configuring general event source properties

Configuring event source logon credentials

Configuring event source license type

Configuring event source operational time

Configuring event source monitoring

Configuring event processing parameters

4.4.1 Configuring general event source properties

Use the General tab in the properties dialog to:

Change the name of a computer group

Enable/disable log collection and processing for the computers in a group

Configure log collection and processing frequency.

To configure event source properties:

1. From Configuration tab > Event Sources > Group Type, select Event Sources Groups.

2. To configure settings of a:

Computer group - right-click on the computer group to configure, and select Properties

Single event source - right-click on the source to configure, and select Properties.
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Screenshot 45: Event sources properties dialog

3. From the General tab, configuring the options described below:

Option Description

Group Name Key in a unique name for the computer group.

Description (Optional) Key in a description.

Enable collection of logs from
this computer group

Select/unselect this option to enable/disable event log collection from the group.

Real-Time i.e. once every 5
seconds

Select this option to check for new event logs every 5 seconds.

Note
This is not recommended if members of this group generate high volumes of
event logs because it may disrupt your network performance.

Once every Specify a custom schedule for when GFI EventsManager checks for new event logs.

Table 18: Event source properties - General options

4. Click Apply and OK.

4.4.2 Configuring event source logon credentials

Use the Logon Credentials tab in the properties dialog to:

View logon credentials settings

Edit logon credentials settings.

During event processing, GFI EventsManager must remotely log-on to the target computers. This is
required in order to collect log data that is currently stored on the target computers and to pass this
data on to the event processing engine(s).
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To collect and process logs,GFI EventsManager must have administrative privileges over the target
computers. By default, GFI EventsManager will log-on to target computers using the credentials of the
account under which it is currently running; however, certain network environments are configured
to use different credentials to log on to workstations and servers with administrative privileges.

As an example, for security purposes, you might want to create an administrator account that has
administrative privileges over workstations only and a different account that has administrative
privileges over servers only.

To configure event source properties:

1. From Configuration tab > Event Sources > Group Type, select Event Sources Groups.

2. To configure settings of a:

Computer group - right-click on the computer group to configure, and select Properties

Single event source - right-click on the source to configure, and select Properties.

Screenshot 46: Configuring alternative logon credentials

3. Click Logon Credentials tab.

4. Select/unselect Logon using credentials below to use/stop using alternate logon credentials. Key
in a username and password.
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Note

Alternate logon credentials enable you to use different usernames and passwords to log
into remote computers. You can set alternate credentials for a group of event sources
or for each event source.

Members of an event source group can be configured to inherit credentials from the
parent group.

5. Select/unselect SSH authentication to use/stop using SSH authentication.

Note

SSH uses public-key cryptography to authenticate the remote computer and allow it to
authenticate the user, if necessary. This is a security protocol for Linux and Unix based
computers.

6. Click Browse... to select the Private key file.

7. Key in the key passphrase and reenter it for confirmation.

8. Click Apply and OK.

4.4.3 Configuring event source license type

The Licensing type tab is used to configure the licensing mode of an event source or event group.
This determines the type of logs that must be collected from the configured source/group. The
following table describes the available license types:

License Type Description

Active Mon-
itoring license

This license enables you to collect and process:
Microsoft® Windows® Event Logs

Text logs, such as W3C, CSV, XML, DHCP, SAP Logs, SKIDATA Logs and Custom logs from Windows®

and non-Windows® workstations

Active Monitoring event logs

If Windows® Server is detected on a source using this license, event log processing is disabled.

Complete
license

Enables full functionality and support for Windows® and non-Windows® based servers, workstations
and network devices. Use this license to collect and process:

Microsoft® Windows® Event Logs

Text logs, such as W3C, CSV, XML, DHCP, SAP Logs, SKIDATA Logs and Custom logs from Windows®

and non-Windows® workstations

Active Monitoring event logs

SNMP Traps Messages

Syslogs

Custom Logs

SQL Server® Audits

Oracle Server Audits.

Table 19: License types
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To configure event source properties:

1. From Configuration tab > Event Sources > Group Type, select Event Sources Groups.

2. To configure settings of a:

Computer group - right-click on the computer group to configure, and select Properties

Single event source - right-click on the source to configure, and select Properties.

Screenshot 47: Configuring event source license type

3. Click Licensing type tab and select the license you want to use for the event source or group that
is being configured.

4. Click Apply and OK.

4.4.4 Configuring event source operational time

GFI EventsManager includes an Operational Time option through which you specify the normal
working hours of your event source groups. This is required so that GFI EventsManager can keep track
of the events that occur both during and outside working hours.

Use the operational time information for forensic analysis; to identify unauthorized user access, illicit
transactions carried outside normal working hours and other potential security breaches that might
be taking place on your network.

Operational time is configurable on computer group basis. This is achieved by marking the normal
working hours on a graphical operational time scale which is divided into one hour segments.

To configure event source properties:

1. From Configuration tab > Event Sources > Group Type, select Event Sources Groups.
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2. To configure settings of a:

Computer group - right-click on the computer group to configure, and select Properties

Single event source - right-click on the source to configure, and select Properties.

Screenshot 48: Specify operational time

3. From Operational Time tab, mark the time intervals of your normal working hours.

Note

Cells marked blue represent your normal working hours.

4. Click Apply and OK.

4.4.5 Configuring event source monitoring

GFI EventsManager is able to collect additional information about your event sources through Active
Monitoring. These checks generate specific events which in turn, trigger real-time notifications or
execute an action.

For example, when monitoring CPU usage checks, GFI EventsManager queries that event source and
detects whether the target machine is performing at the specified CPU usage levels.

Note

For more information refer to Active Monitoring.
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To configure event source properties:

1. From Configuration tab > Event Sources > Group Type, select Event Sources Groups.

2. To configure settings of a:

Computer group - right-click on the computer group to configure, and select Properties

Single event source - right-click on the source to configure, and select Properties.

Screenshot 49: Event source properties - Monitoring tab

3. From Monitoring tab, configure the options described below:

Option Description

Inherit event
log collection
and processing
from parent
group

This option is available when enabling monitoring on a single event source. If you enabled monitoring
on the group containing the event source, leave this option selected to obtain the same settings.

Enable GFI
EventsManager
monitoring

Select/unselect this option to enable/disable Active Monitoring processing.

Perform the
following
checks

Expand the list of checks and select the ones which you want to apply to your event source/event
source group. For information about creating monitoring checks, refer to Creating a new monitoring
check.

Table 20: Event source monitoring options
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Option Description

Archive all
logs without
any further
processing

Select this option to store events without applying any further checks (from Events Processing Rules).

Process the
logs with the
rules selected
below before
archiving

Expand the list of rules which are applied to the collected logs. GFI EventsManager enables you to
create custom rules and configure them to trigger when one of the active monitoring check generates
an event. Then, through the configuration of the selected Event Processing Rule, actions are
executed and/or alerts are generated. Once a monitoring check is enabled, browse for the event that
it generates and create a rule based on that event. For more information refer to Creating new rules
from existing events.

4. Click Apply and OK.

4.4.6 Configuring event processing parameters

Event processing parameters are enabled only for event sources/groups licensed as Servers. Server
event sources posses more settings than normal workstations, in order to collect Windows® event
logs, Text logs, Syslogs and SNMP Traps.

To configure event source properties:

1. From Configuration tab > Event Sources > Group Type, select Event Sources Groups.

2. To configure settings of a:

Computer group - right-click on the computer group to configure, and select Properties

Single event source - right-click on the source to configure, and select Properties.

Screenshot 50: Event processing configuration tabs
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3. Use the Windows Event Log, Text Logs, Syslog and SNMP Traps tabs configure the required event
processing parameters.

4. Click Apply and OK.

Note

For more information, refer to:

Collecting Windows® Event Logs

Collecting Text logs

Collecting Syslogs

Collecting SNMP Traps.

4.5 Database sources

GFI EventsManager can monitor and process events from database servers. Database event sources
require specific configuration settings to collect and process events generated by database activity.
GFI EventsManager is able to audit and monitor activity from the following database servers:

Microsoft® SQL Server®

Oracle Server

4.5.1 Microsoft® SQL Server® Sources

This section contains information about:

Creating a new Microsoft® SQL Server® group

Adding a new Microsoft® SQL Server® event source

Creating a new Microsoft® SQL Server® group

To create a Microsoft® SQL Server® group:

1. Click Configuration tab > Event Sources.

2. From Group Type, select Database Servers Groups.

Screenshot 51: Database Servers Groups

3. From Groups, right-click Microsoft® SQL Server® and select Create group...

4. Select Microsoft® SQL Server® as the server type and from General tab configure the options
described in below:

Option Description

Group Name Key in a group name to identify the Microsoft® SQL Server®

group.

Table 21: Microsoft® SQL Database group: General tab
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Option Description

Description (Optional) Key in a description.

Collects logs from the database servers included in
this group

Enable option to collect database events from all servers in
this group.

Screenshot 52: Configure logon settings from the Logon Credentials tab

4. Select Logon Credentials tab and configure the options described below:

Option Description

Use Windows authen-
tication

Connect to the Microsoft® SQL Database using windows authentication.

Use SQL Server®

authentication
Connect to Microsoft® SQL Database using a Microsoft® SQL Database user account. Key in a
username and password.

Table 22: Microsoft® SQL Database group: Logon Credentials
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Screenshot 53: Configure the normal working hours from Operational Time tab

5. Select Operational Time and configure the operational time when the database is normally used.
Marked time intervals are considered normal working hours.
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Screenshot 54: Configure SQL Server Auditing from SQL Server Audit tab

6. Select SQL Server® Audit tab and configure the options described below:

Option Description

Archive all logs without further processing Archive events in GFI EventsManager database backend without
applying processing rules.

Process the logs with the rules selected below
before archiving

Specify the rules to perform before archiving events in GFI Event-
sManager database backend.

Table 23: Microsoft® SQL Database group -SQL Server® Audit
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7. Select Settings tab and configure the options described in below:

Option Description

Scan all the events for all databases All Microsoft® SQL Server® events are collected and processed by GFI
EventsManager.

Scan only security events for all data-
bases

Only security events are collected and processed by GFI EventsManager.

Table 24: Microsoft® SQL Database group - Settings

8. Click Apply and OK.

Adding a new Microsoft® SQL Server® event source

To add a new Microsoft® SQL Server® source:

1. Right-click a database group and select Add new SQL Server®...
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Screenshot 55: Add new Microsoft® SQL server

2. Key in the server name or IP and click Add.

Note

Use Select and Import to search the network for SQL Server® or import list of SQL
servers from a text file respectively.

3. Click Finish and the Add New SQL Servers dialog closes.

4. From Groups, select SQL Servers and from the right pane, double-click the new Microsoft® SQL
Database instance.
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Screenshot 56: Microsoft® SQL Database properties: General tab

5. From General tab, configure the options described below:

Option Description

Inherit SQL Server post collecting processing
from parent group

Inherits all settings from the parent group.

Archive events in database Archive events in GFI EventsManager database backend without
applying processing rules.

Process using these rule sets Specify the rules to perform before archiving events in GFI Event-
sManager database backend.

Table 25: Microsoft® SQL Database - General tab options
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Screenshot 57: Microsoft® SQL Database properties: Connection Settings tab

6. Select Connection Settings and configure the options described below:

Option Description

Inherit the logon credentials from
the parent group

Select this option to inherit login settings from the parent group.

Use Windows authentication Connect to Microsoft® SQL Database using windows authentication.

Use SQL Server credentials Connect to Microsoft® SQL Database using a Microsoft® SQL Database user
account. Key in a username and password.

Table 26: Microsoft® SQL Database - Connection Settings tab
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Screenshot 58: Microsoft® SQL Database properties: Settings tab

7. Select Settings tab and configure the options described below:

Option Description

Inherit the settings from the parent group Inherits settings from the parent group.

Scan all the events for all databases Scan all databases and collect all events from the Microsoft® SQL
Server®.

Scan only the security events for all data-
bases

Scan all databases and collect only security events from the
Microsoft® SQL Server®.

Scan all the events that are related to the
following databases only

Collect all events from the selected databases. Use Add, Edit and
Remove to manage database sources.

Table 27: Microsoft® SQL Database - Settings tab options

8. Click Apply and OK.

4.5.2 Oracle server sources

GFI EventsManager enables you to collect and process events generated by Oracle Relational
database management systems. The following audits are collected and processed by GFI
EventsManager:

Audit Description

Session auditing Audit user sessions and database access.

Statement auditing Audit processed SQL statements.

Object auditing Audit queries and statements related to specific objects.

Table 28: Oracle Server supported audits
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The following Oracle Database versions are supported:

Oracle Database 9i

Oracle Database 10g

Oracle Database 11g

This section contains information about:

Pre-configuration settings for Oracle Servers event sources

Creating a new Oracle Server group

Adding a new Oracle Server event source

Pre-configuration settings for Oracle Servers event sources

Before adding Oracle Server event sources, follow the steps below on each Oracle Server instance you
want to monitor:

Pre-con-
figuration Step

Description

Step 1 Ensure the logon credentials used to connect, set audits and access the audit table has the neces-
sary permissions.

Step 2 Enable auditing on the Oracle Server by changing startup parameters. To enable auditing:
1. Startup parameters for the Oracle servers are stored in:

<Oracle Home Directory>\admin\<Oracle SID>\pfile\init.ora.

2. Locate and open the parameters file using a text editor.
3. Locate AUDIT_TRAIL parameter and change the default value to ‘db’ or ‘db_extended’
(‘db,extended’ on latest versions of Oracle).
4. Save and restart the Oracle server.

Table 29: Oracle Server configuration stages

Adding a new Oracle Server group

To add a new Oracle Database group:

1. Click Configuration tab > Event Sources.

2. From Group Type, select Database Servers Groups.

Screenshot 59: Database Servers Groups

3. From Groups, right-click Oracle Servers and select Create group…
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Screenshot 60: Oracle Database group - General tab

4. From General tab, configure the options described in below:

Option Description

Group Name Key in a group name to identify the Oracle Database group.

Description Optionally, key in a description.

Collects logs from the
database servers
included in this group

Collects events from the event sources in the Oracle group. Once this option is enabled,
configure the Schedule scanning and Maintenance options.

Schedule scanning Specify the frequency to collect events on a pre-defined schedule.

Maintenance Oracle audit events are stored in a specific audit table on the Oracle server. To prevent
excessive audit table growth, configure the options in this section to delete audit logs and
old entries on a pre-defined time.

Table 30: Oracle Database group - General tab
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Screenshot 61: Oracle Database group - Logon Credentials tab

5. Select Logon Credentials tab and key in a valid username and password to connect to the Oracle
server.
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Screenshot 62: Oracle Database group - Operational Time tab

6. Select Operational Time tab and configure the normal operational time of the Oracle Database
servers in this group.
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Screenshot 63: Oracle Database group - Oracle Audit tab

7. Select Oracle Audit and configure the options described below:

Option Description

Archive all logs without further processing Archive events in GFI EventsManager database backend without
applying processing rules.

Process the logs with the rules selected below
before archiving

Specify the rules to perform before archiving events in GFI Event-
sManager database backend.

Table 31: Oracle Database group - Oracle Audit

8. Click Apply and OK.

Adding a new Oracle Server event source

To add a new Oracle Database to a database group:

1. Right-click an Oracle Server group and select Add new Oracle Server...
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Screenshot 64: Add new Oracle server

2. Key in the server name or IP and click Add.

3. Click Finish and the Add New Oracle Servers dialog closes.

Note

Use Select and Import to search the network for SQL Server® or import list of SQL
Server® from a text file respectively.



GFI EventsManager 4Managing Event Sources | 96

Screenshot 65: Oracle Server properties - General tab

4. From the right pane, double-click the new oracle server event source and configure the options
described below:

Option Description

Inherit Oracle Server post collecting processing
from parent group

Select to inherit all settings from the parent group.

Archive events in database Archive events in GFI EventsManager database backend without
applying processing rules.

Process using these rule sets Specify the rules to perform before archiving events in GFI Event-
sManager database backend.

Table 32: Oracle Server properties - General tab
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Screenshot 66: Oracle Server properties - Connection Settings tab

5. Select Connection Settings and configure the options described below:

Option Description

Inherit the logon credentials from
the parent group

Select to inherit login settings from the parent group.

Port Key in the port to use to connect to the Oracle Database.

SID The SID is a unique name to identify an Oracle Database instance. Key in the SID
of the database to audit.

Service Name The Service name is the alias used to identify the Oracle Database. Key in the
Service name of the database to audit.

Test Test the connection with the Oracle Database server.

Table 33: Oracle Server properties - Connection Settings tab
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Screenshot 67: Oracle Server properties - Audit by Objects tab

6. Select Audit by Objects and configure the options described below:

Option Description

Object Click Browse to launch a list of available Oracle objects. Select the object to audit and click OK.
NOTE: Amongst others, Oracle objects can be procedures, views, functions and tables.

Operations Operations are actions that modify or query an object. Click Browse to launch a list of available
operations. Select the operations to audit and click OK.

Options Select the audit options:
By Access - Creates an audit log per object operation execution.

By Session - Creates an audit log per operation and per schema object. A session is the time
between a connection and a disconnection to/from the database.

Success - Select to process only successful audits.

Failure - Select to process only failed audits. Oracle will create an audit log if an audit fails
to complete.

Both - Select to process all audit logs.

Audit Choose this option to instruct the Oracle server to start auditing the server activities
corresponding to the selected parameters (like users, statements, etc.)

Stop Audit Choose this option to instruct the Oracle server to stop auditing the server activities cor-
responding to the selected parameters (such as users, statements, etc.)

Current audited
schema objects

A list that displays all current Oracle audited schema.

Table 34: Oracle Server properties - Audit by Objects tab
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Screenshot 68: Oracle Server properties - Audit by Statements tab

7. Select Audit by Statements and configure the options described below:

Option Description

Statements Click Browseto launch a list of available Oracle statements. Select the Oracle statements to audit and
click OK.
NOTE: Amongst others, Oracle statements can be ALTER, CREATE and SELECT .

User Oracle enables you to audit statements for a specific user. Click browse button to launch a list of
available users. Select the user and click OK.

Options Select audit options:
By Access - Creates one audit log for each statement execution.

By Session - Creates one audit log per user and per schema object. A session is the time between
a connection and a disconnection to/from the database.

Success - Processes only successful audits.

Failure - Select option to process only failed audits. Oracle will create an audit log if an audit
fails to complete.

Both - Select option to process all audit logs.

Audit Choose this option to instruct the Oracle server to start auditing the server activities corresponding to
the selected parameters (such as users, statements, etc.)

Stop Audit Choose this option to instruct the Oracle server to stop auditing the server activities corresponding to
the selected parameters (such as users, statements, etc.)

Current
audited state-
ments

A list that displays all current Oracle audited statements.

Table 35: Oracle Server properties - Audit by Statements tab

8. Click Apply and OK.
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5 Collecting Event Logs

This chapter provides you with information about how to configure your event sources to apply events
processing rules to collected events. Assign existing or custom events processing rules to precisely
process the events wanted only.

Topics in this chapter:

5.1 Collecting Windows® event logs 100

5.2 Collecting Text logs 103

5.3 Collecting Syslogs 106

5.4 Collecting SNMP Traps Messages 110

5.5 Collecting custom logs 114

5.6 Collecting GFI LanGuard event logs 116

5.7 Collecting GFI EndPointSecurity events 121

5.1 Collecting Windows® event logs

Windows® events are organized into specific log categories; by default computers running on
Windows® NT or higher, record errors, warnings and information events in three logs namely
Security, Application and System logs.

Computers that have more specialized roles on the network such as Domain Controllers, and DNS
Servers have additional event log categories.

As a minimum, Windows® Operating Systems record events in the following logs:

Log Type Description

Security
event log

This log contains security related events through which you can audit successful or attempted security
breaches. Typical events found in the Security Events log include valid and invalid logon attempts.

Application
event log

This log contains events recorded by software applications/programs such as file errors.

System event
log

This log contains events logged by operating system components such as failures to load device drivers.

Directory ser-
vice log

This log contains events generated by the Active Directory including successful or failed attempts to
make to update the Active Directory database.

File Rep-
lication ser-
vice log

This log contains events recorded by the Windows® File Replication service. These including file rep-
lication failures and events that occur while domain controllers are being updated with information
about Sysvol.

DNS server
log

This log contains events associated with the process of resolving DNS names to IP addresses.

Application
and Services
Logs

These logs contain events associated with Windows® VISTA and the relative services/functionality it
offers.

Table 36: Windows® Event Logs collected by GFI EventsManager
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Screenshot 69: Computer group properties: Configuring Windows® Event Logs parameters

To configure Windows® Event Log collection and processing parameters:

1. From Configuration tab > Event Sources, right-click an event source or group and select
Properties.
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Screenshot 70: Selecting event logs to collect

2. Click Windows Event Log tab > Add... to select the logs you want to collect. Expand Windows Logs
and/or Applications and Services Logs and select from the list of available logs.

3. (Optional) Click Add custom log... and key in a unique name for the unlisted event log.
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Screenshot 71: Configuring Windows Event Log Processing parameters

4. Select Clear collected events after completion to clear the collected events from the respective
event source.

5. Select Archive events in database to archive collected events without applying events processing
rules.

6. Select Process using these rule sets and select the rule sets you want to run against the collected
events.

7. Select Add generic fields to add extended fields to the database. Extended fields contain data
from event descriptions and are added by a common name (example: "Field01", "Custom field name").

8. Click Apply and OK.

Important

Deleting event logs without archiving may lead to legal compliance penalties.

5.2 Collecting Text logs

Text Logs are other log formats supported by GFI EventsManager. W3C logs are text-based flat files
containing various event details delimited by special characters.

The W3C log format is most commonly used by hardware systems (Example: servers and appliances)
which have Internet specific roles. Microsoft® Internet Information Server (IIS) service and Apache
web servers for example, can collect web related events such as web logs, in the form of W3C
formatted text files.
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In GFI EventsManager, the configuration process of W3C log parameters is identical to that performed
for Windows® event processing, with one exception. Unlike Windows® Event Logs, there is no
standard which dictates a specific or centralized folder location where W3C log files are stored on
disk. Therefore, in order to collect W3C logs, you must specify the complete path to these text-based
log files.

Screenshot 72: Text logs options

To collect Text logs:

1. From Configuration tab > Event Sources, right-click an event source or group and select
Properties.
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Screenshot 73: Adding folders containing Text Logs

2. Click Text Logs tab > Add... to add folder paths containing Text Logs.

3. From the Select text logs folder... dialog, key in the path to the folder containing the text logs files
and Click OK.

4. Select Clear collected events after completion to clear the collected events from the respective
event source.

5. Select Process subdirectories to recursively scan the specified path that contains the text logs.

6. From Parsing schema drop-down menu, select the schema in which Text Logs are interpreted.
Select from:

W3C

CSV

DHCP

XML

SAP Logs

ESM Logs

SKI Data Car Park Payments.

7. Select Archive events in database to archive collected events without applying events processing
rules.
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8. Select Process using these rule sets and select the rule sets you want to run against the collected
events.

9. Click Apply and OK.

Important

Deleting event logs without archiving may lead to legal compliance penalties.

5.3 Collecting Syslogs

Syslog is a data logging service that is most commonly used by Linux and UNIX based systems. The
concept behind Syslogs is that the logging of events and information is entirely handled by a dedicated
server called ‘Syslog Server’.

Unlike Windows® and Text log based systems, Syslog enabled devices send events in the form of data
messages (technically known as ‘Syslog Messages’) to a Syslog server that interprets and manages
message and saves the data in a log file.

In order to process Syslog messages, GFI EventsManager ships with a built-in Syslog Server. This Syslog
server will automatically collect, in real-time, all Syslog messages/events sent by Syslog sources and
pass them on to the event processing engine. Out-of-the-box, GFI EventsManager supports events
generated by various network devices manufactured by leading providers including Cisco and Juniper.

Note

For more information about supported devices visit the following KBASE article:
http://go.gfi.com/?pageid=esm_syslog_snmp_support

Note

A built-in buffer allows the Syslog server to collect, queue and forward up to 30 Syslog
messages at a time. Buffered logs are by default passed on to the event processing
engine as soon as the buffer fills up or at one minute intervals; whichever comes first.

http://go.gfi.com/?pageid=esm_syslog_snmp_support
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Screenshot 74: Syslog messages must be directed to the computer running GFI EventsManager

Important

Before you start collecting Syslogs, every Syslog event source (workstations, servers
and/or network devices) must be configured to send their Syslog Messages to the
computer name or IP where GFI EventsManager is installed.

To collect Syslogs:

1. From Configuration tab > Event Sources, right-click an event source or group and select
Properties.
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Screenshot 75: Collecting Syslogs - Syslogs options

2. Click Syslog tab and select Accept Syslog messages to EventsManager to enable the collection of
Syslogs from that event source/event source group.

3. From the Syslog parsing schema drop-down, select the method that GFI EventsManager Syslog
Server interprets Syslog Messages from network devices. Select from:

Simple Syslog message

Standard Linux message

Juniper Network Firewall

Cisco ASA.

4. Click Advanced… to use custom windows code page. Specify the code and click OK.

Note

Windows® code page is used to encode international characters to ASCII strings. Since
Syslog is not Unicode compliant, GFI EventsManager uses a code page to decode the
events. This is only applicable if GFI EventsManager is installed on a machine using a
different language than the monitored machines. For more information, refer to:
http://go.gfi.com/?pageid=esm_code_page

5. Select Archive events in database to archive collected events without applying events processing
rules.

http://go.gfi.com/?pageid=esm_code_page
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6. Select Process using these rule sets and select the rule sets you want to run against the collected
events.

7. Click Apply and OK.

Note

The GFI EventsManager Syslog server is by default configured to listen for Syslog
messages on port 514. For more information refer to Configuring the Syslog server
communications port.

Important

Deleting event logs without archiving may lead to legal compliance penalties.

5.3.1 Configuring the Syslog server communications port

Screenshot 76: Configuring Syslog Server communication port

To change the default Syslog ports settings:

1. Click Configuration tab > Options.

2. Right-click Syslog Server Options and select Edit Syslog options…
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Screenshot 77: Syslog server options

4. Select Enable in-built Syslog server on TCP port: and specify the TCP port on which GFI
EventsManager will receive/listen for Syslog messages.

5. Select Enable in-built Syslog server on UDP port: and specify the UDP port on which GFI
EventsManager will receive/listen for Syslog messages.

6. Click Apply and OK.

Note

When configuring Syslog server port settings, make sure that the configured port is not
already in use by other installed applications. This may affect the delivery of Syslog
messages to GFI EventsManager.

5.4 Collecting SNMP Traps Messages

SNMP is a data logging service that enables networked devices to log events and information through
data messages (technically known as SNMP Traps). SNMP messaging technology is similar in concept to
Syslogs - where unlike Windows® and Text logs based environments, devices that generate SNMP
messages do not record events data in local logs. Instead events information is sent in the form of
data messages to an SNMP Trap Server which manages and saves SNMP message data in a local
(centralized) log file.
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Screenshot 78: SNMP Trap messages must be directed to the computer running GFI EventsManager

Note

GFI EventsManager natively supports an extensive list of SNMP devices and Management
Information Bases (MIBs). For a full list of supported devices, view the following KBASE
article: http://go.gfi.com/?pageid=esm_syslog_snmp_support

GFI EventsManager includes a dedicated SNMP Trap Server through which SNMP Traps are handled. A
built-in buffer allows the SNMP Trap Server to collect, queue and forward up to 30 SNMP Trap at a
time. Buffered logs are by default passed on to the event processing engine as soon as the buffer fills
up or at one minute intervals; whichever comes first.

Important

Before you start collecting SNMP Traps messages, every SNMP event source
(workstations, servers and/or network devices) must be configured to send their SNMP
Traps Messages to the computer name or IP where GFI EventsManager is installed.

To collect SNMP Traps:

1. From Configuration tab > Event Sources, right-click an event source or group and select
Properties.

http://go.gfi.com/?pageid=esm_syslog_snmp_support
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Screenshot 79: Collecting SNMP Traps

2. Click SNMP Traps tab and select Accept SNMP Traps messages from this event source to enable
the collection of SNMP Traps.

3. Select Decrypt incoming SNMP Traps 3 messages and specify the security key in the Host key text
box.

4. Select Archive events in database to archive collected events without applying events processing
rules.

5. Select Process using these rule sets and select the rule sets you want to run against the collected
events.

6. Click Apply and OK.

Note

The GFI EventsManager SNMP Trap Server is by default configured to listen for SNMP
Trap messages on port 162. For more information refer to Configuring the SNMP Traps
server.
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Note

The built in SNMP Trap Server supports SNMP version 3 Traps with encryption. For
encrypted SNMP messages the encryption host key must be provided in the decrypt
incoming SNMP Traps 3 message field.

Important

Deleting event logs without archiving may lead to legal compliance penalties.

5.4.1 Configuring the SNMP Trap server

Screenshot 80: Configuring SNMP Traps

To change the default SNMP Trap Server settings:

1. Click Configuration tab > Options.

2. Right-click SNMP Traps Options and select Edit SNMP Traps options…
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Screenshot 81: SNMP Traps options

3. Enable the required TCP/UDP SNMP server. Specify the TCP/UDP port on which GFI EventsManager
will listen for SNMP messages.

4. Click Advanced tab to add, edit or remove SNMP Trap object identifiers (OIDs).

5. Click Specific Trap Type tab to add, edit or remove trap types.

6. Click Apply and OK.

Note

When configuring SNMP Trap Server port settings, make sure that the configured TCP or
UDP port is not already in use by other installed applications. This may affect the
delivery of SNMP Trap messages to GFI EventsManager.

5.5 Collecting custom logs

GFI EventsManager is configured to collect and process standard event logs. However, GFI
EventsManager can also be configured to manage events recorded in third party application logs such
as anti-virus logs, software firewall logs and other security software.

To configure custom events:

1. Click Configuration tab > Options.
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Screenshot 82: Custom event logs setup

2. From Configurations, right-click Custom Event Logs and select Edit custom logs…
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Screenshot 83: Custom event logs dialog

3. Click Add… button and specify the name of your custom event log.

4. Click OK.

5. (Optional) Click Edit to rename the selected custom event, or click Remove to delete the selected
custom event.

6. Click Apply and OK.

5.6 Collecting GFI LanGuard event logs

GFI EventsManager enables you to monitor events generated by GFI LanGuard. GFI LanGuard is a
network vulnerability scanner that audits your network for weaknesses that can be exploited by users
for malicious purposes. During network audits, GFI LanGuard creates events in the ‘Application Log’
of the machine where it is installed.

For each machine scanned by GFI LanGuard, an ‘Application log’ entry having ‘Event ID: 0’ and
‘Source’ set as GFI LanGuard will be generated. These events denote network vulnerability
information extracted from scanned computers including:

Gathered Inform-
ation

Description

Threat level Gather information about the overall network threat level. This rating is generated through an
extensive algorithm after GFI LanGuard audits the network.

Missing patches and
service packs

Find out which machines have missing updates and which updates need to be installed to
strengthen the security level.

Open ports Discover any unwanted open TCP and/or UDP ports.

Table 37: Information gathered by GFI LanGuard
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Gathered Inform-
ation

Description

Antivirus oper-
ational and malware
definition status

GFI LanGuard is able to check if your virus database definitions are up to date. If it is not, you
will be alerted and GFI LanGuard will attempt to update it.

Applications detec-
ted on scanned tar-
gets

GFI LanGuard enumerates applications installed on scan targets. You can create an inventory of
wanted and/or unwanted applications and configure GFI LanGuard to automatically uninstall
applications categorized as unwanted.

Note

For more information about GFI LanGuard, refer to http://www.gfi.com/network-
security-vulnerability-scanner.

Note

GFI EventsManager can process events generated by GFI LanGuard version 9.5 or later.

5.6.1 How to enable GFI LanGuard event logging?

There are two key steps needed to enable event log integration between GFI LanGuard and GFI
EventsManager:

Step 1: Enable logging

Step 2: Configure GFI EventsManager to collect Application Logs

Step 1: Enable GFI LanGuard logging

To enable GFI LanGuard to output event logs on completion of system audits:

1. Add the machine where GFI LanGuard is installed as an event source.

2. Click Start > Run and key in regedit. Press Enter.

http://www.gfi.com/network-security-vulnerability-scanner


GFI EventsManager 5 Collecting Event Logs | 118

Screenshot 84: Enabling GFI LanGuard logging through the registry

3. Go to the following registry key and edit the value to enable event logging:

Windows® x86 platforms:

HKEY_LOCAL_MACHINE\SOFTWARE\GFI\LNSS[n]\Config

Set value of REG_DWORD EventLog to 1

Windows® x64 platforms:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GFI\LNSS[n]\Config

Set value of REG_DWORD EventLog to 1

Important

[n] is the major version number of GFI LanGuard.

Example: HKEY_LOCAL_MACHINE\SOFTWARE\GFI\LNSS9\Config\EventLog = 1(dword)

Note

To stop GFI LanGuard from generating ‘Application Log’ entries, remove the registry
value described above or change the registry value to 0.

Step 2: Configure GFI EventsManager to collect Application logs

GFI LanGuard outputs windows event logs to the ‘Application Log’ category. Ensure that the
collection of Application logs is enabled on the GFI LanGuard event source.

To enable processing of GFI LanGuard events:

1. Open GFI EventsManager Management Console.

2. Click Configuration tab > Event Sources.
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3. Right-click on the GFI LanGuard event source and select Properties.

Screenshot 85: Add Windows® Application logs

4. From Windows® Event Log tab, click Add and select Windows® Logs. Click OK.
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Screenshot 86: Add GFI LanGuard rules

5. Select Process using these rule sets. Expand Windows Events > GFI Rules node and select GFI
LanGuard rules.

6. Click OK.

Note

GFI EventsManager has built-in processing rules for GFI LanGuardevents that are
enabled by default. To monitor events generated by GFI LanGuard, select Status tab >
General and locate the Critical and High Importance Events section.

Note

To configure GFI LanGuard event processing rules, click Configuration tab > Event
Processing Rules. From the left pane select GFI Rules > GFI LanGuardrules. For more
information refer to Events Processing Rules.

Testing and troubleshooting

To check if GFI LanGuard events are being generated:

1. Open GFI LanGuard and run a security audit scan on the localhost.

2. When the scan finishes, open Event Viewer from Start > Run and key in eventvwr. Press Enter.

3. Go to Event Viewer (local) Windows Logs Application.
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4. Once the stored events are loaded, search for an entry with:

Source: GFI LanGuard

Event ID: 0.

In case the event log is not created, typically the GFI LanGuard scan was already initiated once the
registry key to output event logs was modified. Re-run the scan. Alternatively ensure that the registry
value was created in the right location as the location for x86 platforms is different from that of x64
platforms.

5.7 Collecting GFI EndPointSecurity events

GFI EndPointSecurity enables you to maintain data integrity by preventing unauthorized access, and,
the transfer of content to and from the following devices or connection ports:

Device Example

USB Ports Flash/Memory card readers and pen drives.

Firewire ports Digital cameras and Fire-wire card readers.

Wireless devices Bluetooth and Infrared dongles

Floppy disk drives Internal and external (USB) floppy drives.

Optical drives CD, DVD and Blu-ray discs.

Magneto Optical drives Internal and external (USB) drives.

Removable storage USB hard-disk drives.

Other drives such as Zip drives and tape drives Internal or External (USB/Serial/Parallel) drives.

Table 38: GFI EndPointSecurity supported devices

Note

For more information about GFI EndPointSecurity, refer to
http://www.gfi.com/endpointsecurity.

Enable GFI EndPointSecurity logging

By default, GFI EndPointSecurity generates logs with information about:

The GFI EndPointSecurity service

Devices connected and disconnected on your network

Access allowed or denied by GFI EndPointSecurity to users.

To configure logging options in GFI EndPointSecurity:

1. From the machine running GFI EndPointSecurity machine, launch GFI EndPointSecurity Management
Console.

2. Click Configuration tab > Protection Policies.

3. From the left pane, select the protection policy and click Set Logging Options.

4. Customize the settings available in Logging Option dialog.

http://www.gfi.com/endpointsecurity
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Note

For more information on how to configure GFI EndPointSecurity logging options, refer to
the GFI EndPointSecurity documentation available from
http://www.gfi.com/products/gfi-endpointsecurity/manual.

Monitor GFI EndPointSecurity Events

GFI EventsManager has built-in processing rules for GFI EndPointSecurity events that are enabled by
default. To monitor events generated by GFI EndPointSecurity, select Status tab > General and
locate the Critical and High Importance Events section.

To configure GFI EndPointSecurity event processing rules, click Configuration tab > Event Processing
Rules. For more information refer to Events Processing Rules.

http://www.gfi.com/products/gfi-endpointsecurity/manual
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6 Browsing Stored Events

This chapter provides you with information about using the Events Browser. The Events Browser is
equipped with tools for event analysis and forensic investigation. It also enables you to easily browse
through multiple events databases as well as export events to encrypted databases for legal
compliance purposes.

Topics in this chapter:

6.1 Navigating the Events Browser 123

6.2 Using the Events Browser 124

6.3 Managing Events Browser views 127

6.4 Customizing Events Browser layout 130

6.5 Browsing events from different databases 132

6.1 Navigating the Events Browser

Screenshot 87: Events Browser

The Events Browser is made up of the following sections:
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Section Description

Views The Views section includes a wide range of predefined views. Use this section to view specific
logs such as Windows® Event Logs, Text Logs, SQL Server® audits and more.

Common
Tasks

Common Tasks enable you to customize the look of the Events Browser and switch database to
view exported and/or archived event logs.

Actions Use the Actions section to run common functions related to analyzing event logs. This enables
you create or edit custom views, export events for further analysis and more.

Events The Events section is used to browse through the events categorized under the selected view
(from section 1).

Navigation
controls

Use the navigation controls to browse through collected events.

Reporting The Report from view option enables you to generate graphical and statistical reports based on
the selected view (from section 1).

Event
Description
Pane

The Events Description Pane provides an extensive breakdown of the selected event (from
section 4). Use this section to analyze the event details and find out when the event was
generated, what was the cause and by whom it was generated. The header color coding enables
you to quickly identify the severity of the event.
The description section enables you to switch between two views:

General - Contains event information in the legacy format that was standard for pre-
Microsoft® Windows® Vista event logs.

Fields – Contains a list of event information categorized by fields.

The link provided in the event description gives you access to:
A more detailed description of the event

Information and links that explain what causes this type of event

Hints and tips on how to possibly solve any existing issues.

Table 39: Navigating the Events Browser

6.2 Using the Events Browser

Event analysis is a demanding task; GFI EventsManager is equipped with specialized tools that simplify
this process. Use the Events Browser for forensic analysis of events. All events accessible through the
Events Browser are organized by log type in the Views section. The following sections describe how to
use the Events Browser to manage your events:

Exporting events to CSV

Creating reports from events browser views

Deleting events

Searching stored events

Identifying rules using the rule finder tool

6.2.1 Exporting events to CSV

GFI EventsManager enables you to export event data to CSV files directly from Events Browser. This is
extremely convenient especially when further processing of event data is required. This includes:
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Distribution of key event data via email

Running automated scripts that convert CSV exported events data to HTML for upload on web/-
company intranet

Generation of graphical management reports and statistical data using native tools such as
Microsoft® Excel®

Generation of custom reports using third party applications

Interfacing events data with applications and scripts built in-house.

To export events to CSV:

1. From Events Browser > Views, right-click a view and select Export events.

Screenshot 88: Export events tool

2. Specify or browse to the location where exported events are saved. Click OK.

6.2.2 Creating reports from views

GFI EventsManager enables you to build your own custom reports (with graphs and statistics) based on
a selected View from Events Browser.

Note

GFI EventsManager ships a selection of predefined reports. We recommend that you
check the available reports prior to creating new ones to avoid having duplicate reports.

To generate a report from a view:

1. From Events Browser > Views, select a view.

Screenshot 89: Report from view button

2. From the top-right corner of the Events Browser, click Report from view.

3. From the Create Report dialog, configure the options from the tabs described below:
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Tab Description

General Specify the new report name and add conditions.

Layout Select the columns that you want to be visible in the report. You can also customize the order of
appearance.

Chart Select Use graphical charts to generate a report showing information in a chart. The available chart types
are:

Pie chart

Bar chart

Line graph.

Schedule Select Use schedule to enable report scheduling. Configure the generation date and frequency for the new
report.

Table 40: Event Browser: Create new report

Note

For more information refer to Creating custom reports.

6.2.3 Deleting events

When collecting and processing event logs from a significantly large number of event sources, a
number of unwanted logs are collected. To help you remove such event logs, GFI EventsManager
includes a delete option. When events are deleted, they are:

Removed from events browser

No longer included in export/import jobs

No longer included in reports.

After deleting an event, every other event of the same type, category and containing view are
deleted as well.

Important

Before you delete event logs, ensure that you are abiding by legal compliance
regulations. Deleting event logs may lead to legal penalties.

To delete events:

1. From Events Browser tab > Views, select a view.

2. Select an event that you want to delete. From Actions, click Mark events as deleted.

3. Click Yes to confirm delete or click No to cancel.

Viewing deleted events

Deleted event logs are stored in a separate database and can be viewed from the Events Browser.

To view deleted event logs:

1. Click Events Browser tab.

2. From the top-right pane, click View deleted events. The Events Browser automatically switches
the database.
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Note

To completely remove event logs from GFI EventsManager, you must run a Commit
Deletion job on the selected database. For more information refer to Commit deletions.

6.2.4 Searching stored events

Use the event finder tool to search and locate specific events using simple customizable filters. To
search for a particular event:

1. Click Events Browser > Actions > Find events.

Screenshot 90: Event finder tool

2. Configure the event search parameters through the options provided on top of the right pane. To
trigger a case sensitive search, click Options and select Match whole word.

3. Click Find to start searching.

6.2.5 Identifying rules using the rule finder tool

GFI EventsManager enables you to identify the event processing rule which triggered the selected
event log.

To identify the rule(s) used for a specific event:

1. From Events Browser, right-click an event log.

2. Click Find Rule. Doing so will take you to Configuration tab > Event Processing Rules. For more
information refer to Events Processing Rules.

6.3 Managing Events Browser views

Event logs are automatically categorized in different folders, according to the event log type and the
source from which it was generated. In GFI EventsManager, these folders are referred to as Views.

GFI EventsManager includes a comprehensive list of views that enable you to start categorizing
processed event logs upon installation. New views can be created and the existing ones can be
modified. The following sections provide with information about managing the Events Browser views:

Creating Root Views and Views

Editing a view

Deleting a view

6.3.1 Creating Root Views and Views

In Events Browser, GFI EventsManager enables you to create the two different types of views
described below:
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View Description

Create
root
view…

Enables you to create top-level views which may contain a number of sub-views. This creates a new set of
views beneath the ones that ship with the product (Example: All Events view).

Create
view…

Create views within root views. Custom views can be added to the default root views and views.

Table 41: Event Browser: Create new view

To create a Root view/View:

1. From Events Browser > Actions, click Create root view…/Create view…

Note

Both options launch the same Create view dialog and are both configured in the same
way. The difference is the positioning of the new custom view.

Screenshot 91: Custom view builder

2. Key in a name and description for the new view.

3. Click Add to add filtering conditions to your view. If no conditions are specified, the view will
display information from every event that is generated.
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Screenshot 92: Edit view restriction

4. Select a field from the list of available fields and specify the Field operator and Field value.
Repeat this step until all required conditions are specified. Click OK. For more information, refer to
Defining Restrictions.

Screenshot 93: Customize View tab

4. Click Customize view tab to select the columns to show in the new custom view. You can also
arrange their order of appearance using the Up and Down arrow buttons.
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5. (Optional) Click Apply to subviews to apply the selected columns to all subviews of the root view.

6. Click Apply and OK.

Screenshot 94: Sample: New Root Views and Views

6.3.2 Editing a view

1. From Events Browser > Views, select the view to edit.

2. From Actions click Edit view…

3. From the View Properties dialog, add, edit or delete conditions according to your requirements.

6.3.3 Deleting a view

1. From Events Browser > Views, select the view to delete.

2. From Actions, click Delete view. Alternatively, right-click on the view you want to delete and
select Delete view.

6.4 Customizing Events Browser layout

GFI EventsManager enables you to customize the Events Browser according to your preferences. You
can reposition the description pane as well as modify event log color-coding options, used to facilitate
identification of important events. The following sections provide you with information about
customizing the Events Browser:

Customizing description position

Event color-coding options

6.4.1 Customizing description position

To change the position of the event description pane:

1. From Events Browser > Common Tasks, click Customize browser layout > Description.

Screenshot 95: Customize browser description

2. Select one of the options described below:
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Option Description

Description on the right Places the description pane to the right of the events list.

Description on bottom Places the description pane at the bottom of the events list.

No description Removes description pane.

Table 42: Description pane positions

6.4.2 Event color-coding options

Use the event color-coding tool to tint key events in a particular color. This way the required events
are easier to locate during event browsing.

Screenshot 96: Color coding configuration

To assign a color code to a specific event:

1. From Events Browser > Common Tasks select Customize browser layout > Colors.

2. Specify event filtering parameters including the color to be applied to the sifted events.

3. Click Apply Color.

Note

Use the Clear color option to clear all color settings.

To assign different color-codes to multiple events:

1. From Events Browser > Common Tasks select Customize view > Colors > Advanced…
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Screenshot 97: Advanced Color Filter

2. Click Add button. Specify filter name and configure event filter parameters.

3. Click OK.

4. Repeat until all required event filter conditions have been configured. Click OK.

6.5 Browsing events from different databases

GFI EventsManager enables you to switch between different databases. Use this feature to browse
events that have been exported or archived for further analysis or stored in different databases.

To switch databases:

1. Click Events Browser > Common Tasks > Switch database.
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Screenshot 98: Switch database dialog

2. Select the database from the list of databases and click OK.

Note

You can click Add… to specify a path and a unique name to create a new database. Click
Edit… to edit the specified information.
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7 Activity Monitoring

This chapter provides you with information about monitoring the events collection processes. The
Status tab is a dashboard that shows the status of GFI EventsManager as well as statistical
information related to the events collected, processed and archived. The status monitor consists of
three different dashboard views: General view, Job Activity view and Statistics view.

Topics in this chapter:

7.1 General Status view 134

7.2 Job Activity view 138

7.3 Statistics view 139

7.1 General Status view

This General Status view is used to:

View the status of the GFI EventsManager event processing engine

Access statistical information such as the number of logon events, critical events and service
status events.

To access the General view, go to Status tab > General.
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Screenshot 99: GFI EventsManager Status: General view

The General view consists of the sections described below:

Section Description

Use this section to select the chart type for top events.

The Top Important Log Events section provides statistical information about:
Top 10 successful Logon events outside working hours

Top 10 important Logon events during working hours

Top 10 failed Logon events.

Events in this section are filtered by:
Machine: Select a machine or key in a machine name in the drop down list

Period: The time period when the events occurred (Last hour, Last 24 hours, Last 7 days or a specific
date).

Table 43: Status monitoring: General view sections
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Section Description

The Critical and High Importance Events section provides statistical/graphical information about critical
events collected from all event sources. This graph shows the event processing rules that collected and
processed the events for a particular period.
From the drop down lists, select the type of information to display. Select from:

Grouping: Determines how events are grouped; such as Events, Computers, Computer groups, Event-
s/Computers or Events/Computer groups

Event type: Select the type of data to display (Windows®, Text Logs, Syslog, SNMP, Active Monitoring
Logs, SQL and Oracle audit)

Alert type: Specify the alert severity; such as All alerts, Critical or High

Period: Specify the time period when the events occurred (Last hour, Last 24 hours, Last 7 days or a spe-
cific date).

NOTE
This section also displays the vulnerability results monitored by GFI LanGuard.

NOTE
For detailed information about the different types of important events shown in this view, download the
Microsoft® Security Monitoring and Attack Detection Planning Guide from
http://go.gfi.com/?pageid=esm_smad_plan.

The Top Service Status Events displays the top 10 services that caused the selected event. A service can
generate events when:

Terminated with an error

Failed to load

Failed to start

Timed out

Stopped

Started.

The graph shows the frequency of these events sorted by service type and/or by computer generating the
event. Select a machine or service from the drop down lists or key in the required criteria to customize the
graph results.

Note
To collect services information, event sources must have Audit system events policy enabled. For more
information, refer to Enabling event source permissions manually (page 327).

http://go.gfi.com/?pageid=esm_smad_plan
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Section Description

The Top Network Activity Events section displays details of the top 10 network activities (inbound and
outbound). Network activity consists of all type of traffic that is generated by various protocols including
SMTP, HTTP, FTP and MSN traffic. The network activities displayed can be filtered by:

Applications

Source Addresses

Destination Addresses

Computers

Ports

Users.

Select parameters from the drop down lists or key in the values to filter the type of chart displayed.

Note
The network activity shown in the chart applies only to computers running Microsoft® Windows® Vista or
later.

Note
To collect network activities, event sources must have Object auditing and Process tracking enabled. For
more information refer to Enabling event source permissions manually.

The Monitoring Statistics section displays status information about active Active Monitoring you are running
on event sources. The information displayed in this section is refreshed every 20 seconds and you provides
the:

Check name

Success/Fail count

Number of generated events

Check date and time

Check type.

Select a row and click View Events to view the pertaining logs that were generated when the check
failed/succeeded.

Click the Arrange Window icon to automatically fit all graphs in the management console.

The GFI EventsManager Service Status is used to view:
The operational status of GFI EventsManager service/event processing engine

The operational status of the Syslog server

The operational status of the SNMP Traps server

The operational status of the database server currently in use by GFI EventsManager.

Note
Click the service name to edit the service settings.

Note
Click Database server is running to switch between different databases. For more information refer to
Switching between file storage databases.
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Section Description

The Events Count By Database Fill-Up displays:
The horizontal bars represent the number of events stored in the database backend, sorted by event
log type

The date and time of the last backup

The date and time of the next scheduled backup.

The bar color turns from green to red as the database is populated with events.

Note

Double-click the graph to open the graph in a new window. When a 3D graph is selected,
the new window allows you to rotate, zoom or resize the graph. Use the Export to
image button to export the graph.

7.2 Job Activity view

This view displays your current event collection and processing activity. This includes active event
collection jobs as well as server messaging history on a machine by machine basis.

To access the Job Activity view, go to Status tab > Job Activity.

Screenshot 100: GFI EventsManager Status: Job Activity view
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The information provided in this view is divided into the following dedicated sections:

Section Description

The Active Jobs section provides a list of all event collection jobs currently taking place on every event
source/machine. The information provided includes the job progress as well as the Log Source from which
events are being collected.

The Operational History section shows an audit trail of the event collection operations performed by GFI
EventsManager. The information provided includes errors and information messages generated during the
event collection process as well as the name of the log file that was being processed on the event source.

NOTE
Operational history logs can be exported using the Export data button. For more information refer to
Generating reports.

The Queued Jobs section provides a list of all pending event collection jobs on a machine by machine basis.
The information provided includes the event source from which events will be collected as well as the
queuing time and type of log to collect.

The Server Message History section displays a list of all server messages (SNMP Traps and Syslog) that were
received by GFI EventsManager. The information provided includes the total number of messages sent by
every event source, message count and the date/time when the last message was received.

Click Export data to generate Operational History reports.

Table 44: Status monitoring: Job activity view

7.3 Statistics view

The Statistics view is used to display the daily event activity trends and statistics of a particular
computer or entire network.

To access the Statistics view, go to Status tab > Statistics.
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Screenshot 101: GFI EventsManager Status: Statistics view

The information provided in this view is divided into the following dedicated sections:

Section Description

Use this drop-down menu to select what information is displayed. Select between All sources or select
specific sources to view their information accordingly.

The Today’s Events Count graphically represents the daily event collection trend on a machine by machine
basis as well as on a network by network basis. A color scheme is used to differentiate between Windows®,
Text Logs, Active Monitoring Logs, Syslog and SNMP Traps events.

The Events Count By Log Type represents the number of Windows®, Text Logs, Syslog and SNMP Traps
events collected by GFI EventsManager from a particular machine or network.

The Activity Overview section provides information about:
The total number of Windows®, Text Logs, Active Monitoring Logs, Syslog and SNMP Traps events pro-
cessed on a machine by machine basis

The date/time of the last event collection performed from every machine.

Click Export data to generate Activity Overview reports.

Table 45: Status monitoring: Statistics view
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8 Reporting

This chapter provides information about the fully-fledged reporting engine of GFI EventsManager. It
ships with a number of reports including technical and executive level reports showing graphical and
statistical information based on hardware and software managed by GFI EventsManager.

Topics in this chapter:

8.1 Navigating the Reports tab 142

8.2 Available reports 143

8.3 Managing reports 144

8.4 Creating a root report 146

8.5 Creating custom reports 151

8.6 Generating reports 158

8.7 Analyzing reports 168

8.8 Defining column headings 169

8.9 Customizing HTML reports 170
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8.1 Navigating the Reports tab

Screenshot 102: Navigating the Reporting UI

The Reporting tab consists of the sections described below:

Section Description

The Reports section contains all the predefined reports that ship with the product. Use this section to
organize and generate various reports from technical to executive type.

Find reports rapidly, using the available filtering options. Through Filter Reports options, you are able to
search for reports that contain charts and are generated based on a schedule.

The Common Tasks section enables you to quickly launch typical operations such as creating folder and
report views to organize reports and generating reports.

From Actions, create, edit or delete reports according to your needs.

Use the Generated Reports section to view the history of a selected report (from Section 1). This enables you
to regenerate and export the report to HTML and/or PDF.

The Preview Report section provides a view of a selected, generated report. Use the control buttons to
Print, Open, Export or Delete reports directly from this section.

Table 46: Navigating the Reporting tab
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8.2 Available reports

GFI EventsManager's extensive report list contains reports for various requirements designed to
facilitate reporting as much as possible. The following report categories are included in GFI
EventsManager by default. GFI EventsManager allows you to use the existing reports as templates to
create your own ones. Each category in the table below contains a number of reports that can be
used out of the box or customized to fit your requirements:

Category Description

Account Usage Use the reports in this category to identify user logon issues. The event details shown in
these reports include successful/failed user logons and locked user accounts.

Account Management Use the reports in this category to generate a graphical overview of important events
that took place across your entire network. The event details shown in these reports
include changes in user and computer accounts as well as changes in security group
policies.

Policy Changes Use the reports in this category to identify policy changes effected on your network.

Object Access Use the reports in this category to identify object access issues. The event details shown
in these reports include successful/failed object access and objects that have been
deleted.

Application Management Use the reports in this category to identify faulty applications and application
installation and removal issues. The event details shown in these reports include
applications that have been installed or removed as well as applications, which are
crashing and hanging.

Print Server Use the reports in this category to display details related to printing events. Details
provided in these reports include documents that have been printed, the users that
triggered the printing event and the date/time when the printing operation took place.

Windows Event Log System Use the reports in this category to identify audit failures and important Windows® event
log issues. Details provided in these reports include the starting and stopping of event
log services, clear log operations as well as errors generated during event logging.

Events Trend Use the reports in this category to display statistical information related to event
generation. Charts provided enumerate the 10 computers and users with most events.
Other reports provide event counts on a network-wide basis as well as on a computer-by-
computer basis. Reports in this category can be generated for each main time – by hour,
day, week or month.

All Critical Use the reports in this category to display information related to critical Windows®

events, Syslog, Text Logs, Custom Events, SNMP Traps and SQL Server® Audit events.
The charts provided enumerate the 10 most critical events.

Miscellaneous, Cus-
tomizable

Use the reports in this category to generate reports that offer broad customization.
These can be used to generate reports based on any Windows® event log, using filtering
conditions and grouping modes that are not covered by the other default reports.

PCI DSS Compliance / GCSx
Code of Connection
Requirements / SOX Com-
pliance / HIPAA Compliance
/ GLBA Compliance

Use the reports in these categories to generate legal compliance regulations reports.

General and Security
Requirements

Use the reports in this category to generate various reports required by several GCSx
Code of Connection memos.

LOGbinder SP reports Use the reports in this category to generate reports related to Microsoft® SharePoint®

audit events.

Table 47: Available reports
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8.3 Managing reports

Reports are organized in a tree structure enabling you to easily find and generate the required
report. GFI EventsManager includes various options that allow you to easily maintain the reports
structure as the number of reports increase by time.

This section contains information about:

Creating a root folder

Creating a folder

Creating a root report

Creating custom reports

Defining column headings

8.3.1 Creating a root folder

Root folders are top-level folders which may contain one or more sub-folders or reports.

To create a root folder:

1. From Reporting tab > Common Tasks, click Create Root Folder.
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Screenshot 103: Create Report Folder dialog

2. From the General tab, specify a name and a description (optional) for the new folder.

3. Click Schedule tab and select Use schedule to configure a schedule for the reports included in this
new folder. Configure the options described below:

Option Description

Inherit from Par-
ent

Select when the new folder is part of a root folder that already has scheduling configured.

Use schedule Select Use Schedule to enable scheduling of the reports contained in the new folder.

Generation time Specify the time when reports are generated.

Recurrence pat-
tern

Specify the report generation frequency. Select from Daily, Weekly or Monthly pattern and
configure the respective parameters.

Send report by
email to

Select this option to enable email notifications. Click Configure to select the users from the Select
users and groups… dialog.

NOTE
Configure alerting options before using this feature.

Table 48: Create report folder: Schedule options
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4. Click Apply and OK.

8.3.2 Creating a folder

GFI EventsManager allows you to create as many recurring folders as required.

To create a folder:

1. From Reporting tab > Reports, right-click a root or sub-folder and select Create Folder.

2. From the General tab, specify the name and description (optional) for the new group.

3. Click Schedule tab and configure the required schedule settings.

4. Click Apply and OK.

8.4 Creating a root report

Root reports behave in the same way as root folders. These are created at the top level and may
contain a number of sub reports. For example, you can create a root report that generates on
monthly basis, and contains information about successful logons, failed logons and account lockouts.
It's sub-reports would only contain information about specific parts of the root report, such as failed
logons only, generated on daily basis.

To create a root report:

1. From Reporting tab > Common Tasks, click Create Root Report.

Screenshot 104: Creating a root report
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2. From the General tab, specify a name and description (optional) for the new root report.

3. Click Add to select a field on which to base the query condition. For the selected field, specify the
Field Operator and Field Value. Click OK.

Note

Repeat this step until all the required fields are selected. For more information refer to
Building query restrictions.

Screenshot 105: Configuring new root report layout options

4. Click Layout tab and add the column headings that you want to be visible in the report. If you have
a saved report template, click Open location to browse and load your template. For more
information refer to Defining column headings.
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Screenshot 106: Inserting a chart in a new root report

5. (Optional) Click Chart tab and select Use graphical charts to include graphs in your report.

6. From the Place chart at drop-down menu, specify the location of the chart. Select from:

Beginning of Report

End of Report.

7. From Properties > X axis and Y axis, configure the X and Y Axis properties. I.e. select the data
represented in the chart.

8. Select Top 10 to view the Top 10 records only.



GFI EventsManager 8 Reporting | 149

Screenshot 107: Configuring the schedule for when the report is generated

9. (Optional) Click Schedule tab and configure schedule settings.

10. Select Send report by email to and click Configure to select the recipients of this report.
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Screenshot 108: Create new report Options

11. Click Options tab and specify the path to where the report generates to in the Target path area.

12. From the Range pattern drop-down menu, select the options described in the table below:

Pattern Description

All Time Select All Time to generate the report based on information from all the related logs.

Relative Generate the report based on events from:
Today

Yesterday

Last 7 Days

This Month

Last Month.

Day Specify a single day that you want to base your report on.

Month Specify a month and year that you want to base your report on.

Date Range Specify a From and To date to base report information on events collected in the specified time period.

Table 49: Range pattern options
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Screenshot 109: Record limit settings

13. Click Other tab to configure report record limits. Available options are described in the table
below:

Option Description

Split report if it contains
more than {X} records

Select the checkbox to enable record limit per report. GFI EventsManager automatically
creates a new report for every number of records you specify.
Example: if you key in 50, 000 and the report contains 150, 000 records, GFI
EventsManager generates three reports.

Max number of records per
page

Specify the number of records that are displayed in a single page.

Limit records to Specify the maximum number of records that are included in the report. Records that
exceed the limit are ignored.

Table 50: Report record settings

14. Click Apply and OK.

8.5 Creating custom reports

Creating custom reports requires planning while setting up conditions. Conditions are set to
determine what is filtered and presented in the report. Failing to configure conditions properly
generates unwanted noise and inaccurate information.

To create a new custom report:
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1. From Reporting tab > Reports, right-click a root folder/folder/root report and select Create
Report.

Screenshot 110: Creating a root report

2. From the General tab, specify a name and description (optional) for the new root report.

3. Click Add to select a field on which to base the query condition. For the selected field, specify the
Field Operator and Field Value. Click OK.

Note

Repeat this step until all the required fields are selected. For more information refer to
Building query restrictions.
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Screenshot 111: Configuring new root report layout options

4. Click Layout tab and add the column headings that you want to be visible in the report. If you have
a saved report template, click Open location to browse and load your template. For more
information refer to Defining column headings.
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Screenshot 112: Inserting a chart in a new root report

5. (Optional) Click Chart tab and select Use graphical charts to include graphs in your report.

6. From the Place chart at drop-down menu, specify the location of the chart. Select from:

Beginning of Report

End of Report.

7. From Properties > X axis and Y axis, configure the X and Y Axis properties. I.e. select the data
represented in the chart.

8. Select Top 10 to view the Top 10 records only.
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Screenshot 113: Configuring the schedule for when the report is generated

9. (Optional) Click Schedule tab and configure schedule settings.

10. Select Send report by email to and click Configure to select the recipients of this report.
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Screenshot 114: Create new report Options

11. Click Options tab and specify the path to where the report generates to in the Target path area.

12. From the Range pattern drop-down menu, select the options described in the table below:

Pattern Description

All Time Select All Time to generate the report based on information from all the related logs.

Relative Generate the report based on events from:
Today

Yesterday

Last 7 Days

This Month

Last Month.

Day Specify a single day that you want to base your report on.

Month Specify a month and year that you want to base your report on.

Date Range Specify a From and To date to base report information on events collected in the specified time period.

Table 51: Range pattern options
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Screenshot 115: Record limit settings

13. Click Other tab to configure report record limits. Available options are described in the table
below:

Option Description

Split report if it contains
more than {X} records

Select the checkbox to enable record limit per report. GFI EventsManager automatically
creates a new report for every number of records you specify.
Example: if you key in 50, 000 and the report contains 150, 000 records, GFI
EventsManager generates three reports.

Max number of records per
page

Specify the number of records that are displayed in a single page.

Limit records to Specify the maximum number of records that are included in the report. Records that
exceed the limit are ignored.

Table 52: Report record settings

14. Click Apply and OK.
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8.6 Generating reports

GFI EventsManager enables you to generate a number of different reports, containing information
about GFI EventsManager configuration settings, network activity and product activity.

This section contains information about:

Generating a report

Generating daily digest reports

Generating settings reports

Generating rules reports

Generating operational history reports

Generating activity overview reports

8.6.1 Generating a report

To generate a report:

1. From Reporting tab > Reports, right-click a report and select Generate Report.

Screenshot 116: Generating a report

2. Wait for the report to generate and view results in Preview Report section.
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Note

Reports can also be generated by selecting a report from the list and clicking Generate
Report at the top of the reporting page.

Screenshot 117: Report sample

8.6.2 Generating daily digest reports

GFI EventsManager can be configured to send a summary report by email on a daily basis. The report
contains a summary of the most important events collected and processed during the last 24 hours.
To configure a user to receive Daily Digest emails:

1. From Configuration tab > Options. Expand Users and Groups and select Users.

2. Right-click a user from the right pane and select Properties.

3. From the General tab, ensure that a valid email address is configured.

4. From the Alerts tab, select Send daily report via email.
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Screenshot 118: Daily Digest email settings

5. Configure the time when the Daily Digest email is sent.

6. Click Apply and OK.
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Screenshot 119: Daily digest email

Section Description

The start and end date of the report. The report displays the most important events collected by GFI Event-
sManager between the start and end date.

The number of Critical and High events collected in the last 24 hours.

This graph provides statistical information about critical events collected from all event sources in the last 24
hours.

Table 53: Daily digest email description

8.6.3 Generating settings reports

GFI EventsManager enables you to generate settings reports on event source groups. The provided
information is described below:

Heading Description

Group name The name of the group the report is based on.

Computer
name

A list of every event source in the selected group.

Scan intervals Scanning interval for every event source in the selected group; shown in Days : Hours : Minutes :
Seconds.

Table 54: Settings report heading information
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Heading Description

Rules folder Provides a list of rule categories applied to the selected group, such as:
Noise reduction

Security

System health

PCI DSS requirements.

Rule sets A granular list of rules applied on the selected group.

To generate settings report:

1. Click Configuration tab > Event Sources.

Screenshot 120: Generate configuration report

2. Right-click an event source group and select Report on settings.
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Screenshot 121: Settings report sample

8.6.4 Generating rules reports

Rules repots provide a detailed view of applied rules on event sources. The information provided in
rules reports are described below:

Heading Description

Rule name Name of the applied rule.

Importance The classified importance level of the collect event log, such as:
Critical

High

Medium

Low

Noise event.

Logfile monitored Provides the category name of the collected event log, such as:
Security

System Health

Application

System.

Conditions The processing condition(s) for the selected rule. This includes:
Event IDs

Source

Category

User

Type

Advanced.

Table 55: Rules report heading information
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Heading Description

Actions Describes the actions taken when the event is processed, including:
Archiving settings

Mail to settings

Threshold settings.

To generate rules report:

1. Click Configuration tab > Event Sources.

Screenshot 122: Generate configuration report

2. Right-click an event source and select Report on rules.

8.6.5 Generating operational history reports

GFI EventsManager's operational history can be exported for further analysis and archiving purposes.
Operational history messages provide administrators with information as described below:

Date/Time Date and time when the message was generated.

Machine Event source that generated the message.

Source Source operation that cause the message to be generated. Amongst others these include:
EvtCollector – message generated while collecting event logs

SNMP TrapsServer – message generated while collecting SNMP Traps Messages

EnetrpriseMaintenance – message generated during database maintenance jobs.

Job ID An internal ID associated with the job.

Table 56: Operational History report description
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Log file/name Type of logs collected. Amongst others:
Application
Security
Logs generated by other applications such as GFI LanGuard and GFI EndPointSecurity.

Message The actual message generated while performing the job.

To generate Operational History reports:

1. Click Status tab > Job Activity.

Screenshot 123: Operational History report

2. Click Export data.

Screenshot 124: Operational History dialog

3. Specify the options described below and click Export.

Option Description

Format Select the report output format. Available formats are HTML and CSV.

Current messages Export all messages displayed in Job Activity tab.

Errors from a spe-
cific date

Specify a date and export all the messages generated on that date.

Save file to Select checkbox to specify output location. If not selected, reports are saved in the default loc-
ation within the GFI EventsManager directory.

Table 57: Operational History export options
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Screenshot 125: Operational History report sample

8.6.6 Generating activity overview reports

GFI EventsManager enables you to export Activity Overview data. Activity overview reports provide
the information described below:

Heading Description

Date/Time Date and time when the message was generated.

Machine Event source that generated the message.

Source Source operation that cause the message to be generated. Amongst others these include:
EvtCollector – message generated while collecting event logs

SNMP Traps Server – message generated while collecting SNMP Traps Messages

EnetrpriseMaintenance – message generated during database maintenance jobs.

Job ID An internal ID associated with the job.

Log file/name Type of logs collected. Amongst others:
Application

Security

Logs generated by other applications such as GFI LanGuard and GFI EndPointSecurity

Message The actual message generated while performing the job.

Table 58: Activity overview report headings

To export Activity Overview:

1. Click Status > Statistics.

Screenshot 126: Activity overview : Export button

2. Click Export data.
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Screenshot 127: Activity overview dialog

3. Configure the options described in and click Export.

Option Description

Format The report output format. Available formats are HTML and CSV.

All time Export all messages displayed Activity Overview.

From a specific date Specify a date to export all messages generated on that date.

Only computers with errors/not scanned Export only data of computers with scanning issues.

Include error messages Select this option to include the generated error message.

Save files to Displays the default export location.

Table 59: Export Operational History options

Screenshot 128: Activity overview report sample
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8.7 Analyzing reports

Screenshot 129: Analyzing reports

The reporting system of GFI EventsManager comes with dedicated tools to help you analyze and
export reports. Once a report is generated, select it from the list of Generated Reports and use the
common controls which help you run common report analysis commands. The available tools are
described below:

Option Description

Print Use the Print option to view a print preview, configure printer settings and print the selected report.

Open Use the Open button to open the selected report in a browser. GFI EventsManager uses your default
browser to view reports in HTML.

Open File
Location

Open File Location enables you access the folder containing the report for backup or archiving pur-
poses.

Export to PDF Use Export to PDF to export the selected report to Portable Document Format.

Delete Click Delete to remove a generated report from the list.

Table 60: Analyzing reports: Tools
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8.8 Defining column headings

GFI EventsManager enables you to create custom columns through the Add Custom Columns dialog.
This dialog allows you specify conditions, create a new field and add them to your report(s). Also
based on conditions, this dialog enables you to further customize existing or new reports.

To add custom columns:

1. From Reporting tab > Actions, click Create Report.

2. Click Layout tab > Add Existing Column, to add default columns.

3. Click Add Custom Column to launch the Add Custom Columns dialog.

Screenshot 130: Define custom column conditions

4. From the Add Custom Column dialog click Add.

5. From the Add Definition… dialog, configure the options described below:

Option Description

Field Name Specify a name for the new field.

Table 61: Add Column Definition options



GFI EventsManager 8 Reporting | 170

Option Description

Fixed
Value

Select Fixed Value if the value of the new field is going to be fixed. Specify a value as a field name. For
example, to check that events always occur after 5pm, specify 5 as the fixed value instead of defining a
time field and assign a value of 5.

Special
Column

Special columns are predefined columns that may be used in your condition.

Edit restric-
tions

This section enables you to add, edit or delete field restrictions.

6. Click Apply and OK.

8.8.1 Reporting on events from different databases

For reporting purposes, GFI EventsManager enables you to switch between different databases. Use
this feature to report on events that have been exported/archived for further analysis or stored in
different databases.

To switch database:

1. From Reports tab > Common Tasks, click Switch database.

Screenshot 131: Switch database dialog

2. Select the database from the list of databases and click OK. Click Add… to specify a new database
name and it's relevant path. Click Edit… to edit the specified information.

8.9 Customizing HTML reports

HTML report templates are customizable, enabling you to further tweak GFI EventsManager to suit
your daily requirements. To edit the available templates, knowledge of HTML and CSS is required.
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Important

Before editing the default report template, save a copy of the original so that you can
easily revert to default for troubleshooting.

To edit the layout of HTML reports:

1. Go to GFI EventsManager install directory:

%Program Files\GFI\EventsManager2012\Data\Templates\DefaultReportLayout

Screenshot 132: Editing HTML report templates

2. From DefaultReportLayout folder, edit the templates described below:

Template Description

template_group_
new.html

This template is used when generating reports which contain data about grouped sources.
Grouping can be by users, sources, event data and more.

template_
new.html

Use this template to generate statistical and graphical reports which do not organize data into
groups.

Table 62: Default HTML templates
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3. Using an HTML editor, edit the following elements of the templates:

Section Description

Report logo Replace GFI EventsManager logo with a logo of your choice. Add more logos or completely remove them
from your reports.

Labels and
text

Rename and reposition labels according to your needs.

Placeholders Although you are able to move placeholders around the report, renaming them will cause GFI Event-
sManager reporting engine to fail to return the respective data.

Table 63: HTML template: Editable sections

Available placeholders include:

Placeholder Description

{title} Title of report.

{subtitle} Subtitle of report.

{description} Description of report.

{creator} User who generated report.

{currentDate} Date when report is generated.

{sortBy} Sort field.

{dateRange} Report data is gathered from the specified time period.

{fullFilter} List of Restrictions set for the Report.

{startGroupHeaderBlock} Beginning of Header section of the repetitive block.

{headerLabel} Name of grouping header.

{headerValue} Value of grouping header.

{endGroupHeaderBlock} Ending of Header section of the repetitive block.

{startRepeatBlock} Beginning of the Body section of the repetitive block.

{tableHeaderCells} The Header section of the table data.

{tableRows} The Body section of the table data.

{tableTotal} For charts. Contains the Sum or Count value of the computed field.

{chartTop} Places the chart at the beginning of the report.

{chartBottom} Places the chart at the end of the report.

{endRepeateBlock} Ending of the Body section of the repetitive block.

Table 64: HTML report template placeholders

4. Save the HTML template and generate a report using the new layout. For more information, refer
to Generating reports (page 158).

Note

Using the same HTML/CSS conventions of the HTML templates, you are also able to
create your own customized templates. Copy the template, rename it and reuse the
same placeholders.
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9 Events Processing Rules

During events processing, GFI EventsManager runs a configurable set of rules against the collected
logs in order to classify events and trigger alerts/actions accordingly. By default, GFI EventsManager
ships with a pre-configured set of events processing rules that allow you to gain network-wide control
over computer logs - with negligible configuration effort. You can also customize these default rules
or create tailored ones for your organization’s requirements.

Topics in this chapter:

9.1 About events processing rules 173

9.2 Managing rules-set folders 175

9.3 Creating new events processing rules 178

9.4 Creating new rules from existing events 183

9.5 Advanced event filtering parameters 188

9.6 Prioritizing events processing rules 189

9.1 About events processing rules

Events processing rules are checks that are run against event logs when they are collected. Based on
the conditions configured in a rule, events processing rules help you:

Classify processed events - assign a severity rating to collected logs. This enables you to trigger
actions or notifications if a certain severity log is processed. By default, events are classified
using five main ratings, however, more ratings can be added

Filter out noise (repeated events) or unwanted events - remove duplicate logs or logs that are
not important for you and archive important event data only. This reduces database growth and
saves storage space

Trigger Email, SMS and Network alerts on key events - send notifications to configured recipients
upon detection of certain events. You can configure an event processing rule to send notifications
to recipients when the rule conditions are met

Attempt remedial actions - run executable files, commands and scripts upon detection of specific
events. This enables you to automatically perform remedial actions to mitigate or completely
eliminate a detected problem

Filter events that match specific criteria - remove event logs that are not important for you.
Example, you can run a rule which filters out low severity or duplicate events

Archive filtered events - event archiving is based on the severity of the event and on the con-
figuration settings of the event processing rules. Example: you can configure GFI EventsManager
to archive only events that are classified as critical or high in severity and discard all the rest.
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The flowchart chart below illustrates the event processing stages performed by GFI EventsManager:

Screenshot 133: How Events Processing Rules work

9.1.1 Event classification

Event classification is based on the configuration of the rules that are executed against the collected
logs. Events that don’t satisfy any event classification conditions are tagged as unclassified.
Unclassified events may also be used to trigger the same alerts and actions available for classified
events.
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GFI EventsManager classifies events in the standard importance levels such as Critical, High, Medium,
Low and Noise (unwanted or repeated log entries).

9.2 Managing rules-set folders

In GFI EventsManager, event processing rules are organized into rule-sets and every rule-set can
contain one or more specialized rules which can be run against collected logs.

Screenshot 134: Rule-sets folder and Rule-sets

Rule-sets are further organized into Rule-set Folders. This way you can group rule-sets according to
the functions and actions that the respective rules perform. By default, GFI EventsManager ships with
pre-configured folders, rule-sets and event processing rules that can be further customized to suite
your event processing requirements.

This topic contains information about:

Available rule-sets

Adding a rule-set folder

Renaming and Deleting rule-set folders

9.2.1 Available rule-sets

The following table provides you with the available rules-set folders available when you install GFI
EventsManager. Each rule-set folder contains multiple rule-sets and/or events processing rules:
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Rule-Set
Folder

Description

Windows
Events

Contains rules tailored for Windows® servers and workstations; These include:
Noise reduction rules

PCI DSS Requirements rules

Security rules

System Health rules

Security Application rules

Infrastructure Server rules

Database Server rules

Web Server rules

Print Server rules

GFI rules

Terminal Services rules

Email Server rules

File Replication rules

Directory Service rules

Custom rules

Reporting rules

SharePoint Audit rules.

Text Logs Contains rules tailored for the processing of web transfer protocols. These include:
HTTP rules

FTP rules

SMTP rules.

Syslog Mes-
sages

Contains rules tailored for the processing LINUX and UNIX system logs. These include:
Linux\Unix hosts rules

Juniper Networks rules

Cisco PIX and ISA rules

Rules by severity

IBM iSeries rules.

SNMP
Traps

Contains rules tailored for SNMP Traps Messaging. These include:
Cisco IOS release 12.1 (11) MIBs rules

Cisco IOS release 12.1 (14) MIBs rules

Cisco IOS release 12.2 (20) MIBs rules

Cisco IOS release 12.2 (25) MIBs rules

Allied Telesis AT-AR-700 Family rules.

Table 65: Common available rule-set folders
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Rule-Set
Folder

Description

SQL
Server®

Audits

Contains rules tailored for SQL Server® Audit monitoring. These include:
Noise reduction rules

Database changes rules

Server changes rules

Logon/Logoff rules

SQL Server® rules

Database access rules.

Oracle
Audits

Contains rules tailored for Oracle Server Audit monitoring. Amongst others, these include:
Noise reduction rules

Database changes rules

Server changes rules

Logon/Logoff rules

Security changes rules.

Monitoring
Checks

Contains rules that enable you to monitor active monitoring messages. These include rules pertaining to
the default set of monitoring checks. Monitoring checks generate event logs. These event logs can be pro-
cessed by events processing rules to trigger an action or notification when a fault is detected.

9.2.2 Adding a rule-set folder

To create a new rule-set folder:

1. Click Configuration tab and select Event Processing Rules.

2. From Common Tasks, select Create folder.

3. Specify a unique name for the new rule-set folder.

Note

To create sub rule-set folders, right-click on the parent folder and select Create new
folder…

9.2.3 Renaming and Deleting a rule-set folder

To rename or delete existing rule-set folders, right-click on the target rule-set folder and select
Rename or Delete accordingly.

Important

Deleting a rule-set folder will lead to the deletion of all the rules and rule-sets
contained within the deleted folder.
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9.3 Creating new events processing rules

To create a new event processing rule:

1. Click Configuration tab > Event Processing Rules.

Screenshot 135: Creating a new rule

2. Right-click the rule-set where the new rule will be created and click Create new rule…

3. Specify the name and description (optional) for the new rule. Click Next.
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Screenshot 136: Select the logs which the rule will be applied to

4. Select the event logs to which the rule applies.

5. (Optional) Click Add custom log… to insert an event log which you pre-configured. Click Next. For
more information refer to Collecting custom events.

Note

For SQL Audit, Oracle Audit, Syslogs, Text Logs and SNMP Traps messages, specify the
full path of the object’s log folder; example: “C:\W3C\logs”.
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Screenshot 137: Configure the rule conditions

6. Click Add to select a field on which to base the query condition. For the selected field, specify the
Field Operator and Field Value. Click OK.

Note

Repeat this step until all the required fields are selected. For more information refer to
Building query restrictions.

Note

To filter events that refer to an administrator user (events having the security identifier
SID that identifies a logon administrator session), ensure that if the event source is a
domain member, the domain controller must also be added as an event source. For
more information refer to Creating a new event source group.
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Screenshot 138: Select event occurrence and importance

7. Specify the time when the rule is applicable. Example: anytime, during working hours or outside
working hours. Working and non-working hours are based on the operational time parameters
configured for your event sources. For more information refer to Configuring event source
operational time.

8. Select the classification (critical, high, medium, low or noise) that will be assigned to events that
satisfy the conditions in this rule. Click Next.
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Screenshot 139: Select the triggered action

9. Specify which actions are triggered by this rule and click Next. Available actions are:

Action Description

Ignore the event Select this option so that GFI EventsManager will ignore the event and not trigger any actions or
notifications.

Use the default clas-
sification actions

Select this option to use the pre-configured Default Classification Actions.

Table 66: Configuring new events processing rules: Actions
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Action Description

Use the following
actions profile

The Archive All profile is added by default. To create a new profile:
1. From the drop-down menu, select <New actions profile...>. This launches the New actions
profile... dialog.
2. Specify a name for the new profile in the Action Profile Name text box.
3. Select the actions that you want the profile to perform. The following actions are available:

Archive the event

Send email alerts to

Send network message to

Send SMS message to

Run file

Send SNMP Message

Scan computer

Run checks on computer.

Note
If Run checks on computer is selected, ensure that the computer has monitoring checks
processing enabled. For more information refer to Configuring event source monitoring.

4. For each action you select, click Configure to set the parameters.

10. Click Apply and OK.

Note

Assign the new rule(s) to your event sources. For information about how to collect event
logs and process them using the specified events processing rules, refer to Collecting
Event Logs.

9.4 Creating new rules from existing events

GFI EventsManager enables you to create new rules based on the information of existing events.

To create a new rule from an existing event:

1. From Events Browser, locate the event log that you want to base the rule upon.
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Screenshot 140: Creating a rule from an existing event

2. Right-click the event and select Create rule from event.
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Screenshot 141: New rule from event - General settings

3. Specify a unique name and an optional description for the new rule.

4. From The rule applies if the event happens drop-down menu, select the time when the rule is
applicable. Select from:

At any time of the day

During Normal Operational Time

Outside the Normal Operational Time.

Note

For more information refer to Configuring event source operational time.

5. From the Classify the event as drop-down menu, select the classification level you want to assign
to the event when it is generated.
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Screenshot 142: New rule from event - Select logs to collect

6. From the Event Logs tab, select the logs you want to collect. To add custom logs, click Add custom
log..., specify the custom log name and click OK.

Note

For more information refer to Collecting custom logs.
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Screenshot 143: New rule from event - Add conditions

7. Click the Conditions tab.Click Add to select a field on which to base the query condition. For the
selected field, specify the Field Operator and Field Value. Click OK.

Note

Repeat this step until all the required fields are selected. For more information refer to
Building query restrictions.

8. Click Actions tab and select what action is performed when the rule is triggered. Available options
are described below:

Option Description

Ignore the event Ignores the event until a new instance of the event is generated.

Use the default clas-
sification actions

Use the actions configured in Default Classification Actions. For more information refer to
Configuring Default Classification Actions.

Use the following actions
profile

From the drop-down menu, select a profile or <New action profile...> and click Edit to con-
figure the action profile.

Table 67: Available event processing rule actions

9. Click Threshold tab and configure the event threshold value. I.e. the number of times that an
event must be detected prior to triggering alerts and remedial actions. This helps reducing false
positives triggered by noise (repeated events) in your event logs.

10. Click Apply and OK.
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9.5 Advanced event filtering parameters

GFI EventsManager allows systems administrators to set up advanced event filtering parameters.
These options are available only for Windows® Event Logs and Syslogs. Refer to the following sections
for information about:

Windows® event filtering parameters

Syslog filtering parameters

9.5.1 Windows® event filtering parameters

The Event IDs: field allows systems administrators to setup parameters described in the table below:

Parameter Description

Single events

List of events

Range of events

Combination of events

Table 68: Windows® event filtering parameters: Event ID field

The Source, Category and User fields allow systems administrators to setup parameters described in
the table below:

Parameter Description

Single source name

List of sources

Wildcards (% and *)

Table 69: Windows® event filtering parameters: Source, Category and User fields

9.5.2 Syslog filtering parameters

The Message and Process fields allow systems administrators to setup parameters described in the
table below:

Parameters Description

Single message

List of messages

Wildcards (% and *)

Table 70: Syslog filtering parameters: Message and Process fields
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9.6 Prioritizing events processing rules

Events Processing Rules are executed in order of priority. To change the order of execution:

1. From Configuration tab > Events Processing Rules > Rule Folders, expand a rule-set folder.

2. From the right pane, right-click a rule and select Increase priority or Decrease priority
accordingly. Alternatively, select a rule and press Ctrl+Up to increase or Ctrl+Down to decrease
priority.
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10 Active Monitoring

Event logs are useful to track different operational aspects of devices, computers and servers, but in
many cases users need more than logs to inspect this activity in further detail. To mitigate this
problem, GFI EventsManager uses Active Monitoring Checks. Monitoring checks help you detect
failures or irregularities automatically, so you can identify and proactively fix unexpected problems
before they happen.

GFI EventsManager ships with a set of predefined checks, specifically designed to cater for Windows®

operating systems, Linux/Unix operating systems, SNMP devices and Network/Internet protocols and
services.

This chapter provides you with information about managing, creating and using Active Monitoring
Checks.

Topics in this chapter:

10.1 About Active Monitoring Checks 190

10.2 Creating and configuring a root folder 192

10.3 Adding sub-folders to a root folder 196

10.4 Creating and configuring active monitoring checks 201

10.5 Applying active monitoring checks 206

10.6 Deleting folders and monitoring checks 207

10.1 About Active Monitoring Checks

A monitoring check is a pre-configured rule, bound to a system's component or activity operation,
such as CPU Usage or Ping Requests, that are used to check system availability. Active monitoring
checks continuously scan event sources to determine if the configured parameter conditions are being
met.

Whether a monitoring check fails or succeeds, it generates an event log from the computer that it
scanned. GFI EventsManager assigns a severity rating to the generated event log.

An event processing rule can be created from the generated event log. Events processing rules can
automatically trigger alerts, run additional checks and run scripts/applications to fix the problem
that generated the log.
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Screenshot 144: How Active Monitoring Checks work

Example

You configure a monitoring check to generate an event log when a computer's free hard disk spaces
reaches a pre-configured limit. To achieve this:
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1. When the limit is reached and the monitoring check generates an event, locate it in Events Browser
and create an event processing rule based on it. For more information refer to Creating new rules
from existing events.

2. Configure the new events processing rule conditions to ignore non-matching events. For more
information refer to Creating new events processing rules.

3. Configure the new rule to trigger an alert or action, to resolve the problem. For more information
refer to Configuring Default Classification Actions.

Screenshot 145: Root folder and sub-folder structure

Checks are organized in Root Folders and Sub-Folders. Objects inherit settings from their parent
folder. This enables you to configure a number of monitoring checks simultaneously.

10.2 Creating and configuring a root folder

A root folder is a parent folder that can contain a set of sub-folders and Active Monitoring. Every child
object of a root folder inherits the same settings. This enables swift configuration of multiple
monitoring checks and sub-folder.

To create a new root folder:

1. From Configuration tab > Active Monitoring > Common Tasks, click Create root folder. This opens
the Folder properties dialog.
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Screenshot 146: Folder properties - General tab

2. Specify a unique name and an optional description in the Name and Description fields.

Screenshot 147: Folder properties - Target computer tab
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3. Click Target computers tab and select the event sources. Active Monitoring added to this new
folder are applied to the selected event sources.

Screenshot 148: Folder properties - Schedule tab

4. From the Schedule tab, set the time interval when GFI EventsManager runs the monitoring check
(s) on the selected event sources. By default, a monitoring check interval is set to 5 seconds.
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Screenshot 149: Folder properties - Action events tab

Note

Regardless of whether Active Monitoring fails or succeeds, the computer that it checks
generates an event log. This event log can be processed by events processing rules
which can trigger alerts or run scripts/applications for remedial operations. For more
information refer to Creating new rules from existing events.

5. From the Action events tab, configure when event logs are generated and how GFI EventsManager
classifies the generated events.
Available options are described in the following table:

Option Description

Generate an audit event from this
machine/device when the check

GFI EventsManager enables you to generate event logs after the event source is
checked for irregularities. From the drop-down menu, select:

Fails - generate an event log when the conditions of the check fails

Succeeds - generate an event log when the conditions of the check suc-
ceeds

Fails or Succeeds - generates an event log every time the check is run on
the specified event source(s).

Continuous Generates an event log every time the check fails/succeeds/both.

Only once Generates an event log the first time the check fails/succeeds/both.

Once every {X} minutes Generates an event log once every number of minutes you specify.

Table 71: Monitoring checks - Action events
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Option Description

Once every {X} messages Generates an event log once every number of messages you specify. Example: if
you key in 10, only one event log is generated for every 10 times the check
fails/succeeds/both.

When the check switch state, gen-
erate an audit event from this
machine/device

Generate an event log when the check changes state from Fail to Succeed or
vice versa.

Failed severity Select the severity rating that GFI EventsManager assigns to the event log of a
failed system check.

Success severity Select the severity rating that GFI EventsManager assigns to the event log of a
successful system check.

6. Click OK.

10.3 Adding sub-folders to a root folder

Sub-folders are used to sub-divide a group of monitoring checks that share some common properties,
but may (for example) be targeted towards different types of event sources.

To add a new sub-folder:

1. From Configuration > Active Monitoring > Monitoring checks, right-click a root folder/sub-folder
and select Create new folder.

Screenshot 150: Folder properties - General tab

2. From the General tab, key in a name for the new folder and an optional description.
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Screenshot 151: Folder properties - Target computer tab

Note

Select Inherit from parent to use the same settings as the parent folder.

3. Click the Target computers tab and select the event sources. Active Monitoring that are added to
this new folder are applied to the selected event sources.
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Screenshot 152: Folder properties - Schedule tab

Note

Select Inherit from parent to use the same settings as the parent folder.

4. From the Schedule tab, set the interval when GFI EventsManager runs the monitoring check(s) on
the selected event sources. By default, a monitoring check interval is set to 5 seconds.



GFI EventsManager 10 ActiveMonitoring | 199

Screenshot 153: Folder properties - Action events tab

Note

Regardless of whether Active Monitoring fails or succeeds, the computer that it checks
generates an event log. This event log can be processed by events processing rules
which can trigger alerts or run scripts/applications for remedial operations. For more
information refer to Creating new rules from existing events.

Note

Select Inherit from parent to use the same settings as the parent folder.

5. From the Action events tab, configure when event logs are generated and how GFI EventsManager
classifies the generated events.
Available options are described in the following table:
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Option Description

Generate an audit event from this
machine/device when the check

GFI EventsManager enables you to generate event logs after the event source is
checked for irregularities. From the drop-down menu, select:

Fails - generate an event log when the conditions of the check fails

Succeeds - generate an event log when the conditions of the check suc-
ceeds

Fails or Succeeds - generates an event log every time the check is run on
the specified event source(s).

Continuous Generates an event log every time the check fails/succeeds/both.

Only once Generates an event log the first time the check fails/succeeds/both.

Once every {X} minutes Generates an event log once every number of minutes you specify.

Once every {X} messages Generates an event log once every number of messages you specify. Example: if
you key in 10, only one event log is generated for every 10 times the check
fails/succeeds/both.

When the check switch state, gen-
erate an audit event from this
machine/device

Generate an event log when the check changes state from Fail to Succeed or
vice versa.

Failed severity Select the severity rating that GFI EventsManager assigns to the event log of a
failed system check.

Success severity Select the severity rating that GFI EventsManager assigns to the event log of a
successful system check.

Table 72: Monitoring checks - Action events

6. Click OK.
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10.4 Creating and configuring active monitoring checks

To create a new active monitoring check:

Screenshot 154: Creating a new active monitoring check

1. Click Configuration > Active Monitoring.

2. Right-click the root/sub-folder where you want the new monitoring check to be saved and select
Create new check.
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Screenshot 155: Select check type

3. Select the check type and click Next.

Screenshot 156: Configure general check properties

4. Specify a unique name and an optional description in the Name and Description fields.

5. In Consider this monitoring check as fail after {X} errors text box specify the number of errors
that must occur, before the new checks is classified as Failed.

6. Select/unselect Enable/disable this check, to turn on/off the new monitoring check. Click Next.
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Screenshot 157: Configure monitoring check parameters

7. Configure the parameters that have to be checked and click Next.

Note

This step is different for each different type of check you select in step 3.

Screenshot 158: Select the effected sources
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Note

Select Inherit from parent to use the same settings as the parent folder.

8. From the list of event sources, select the computers to monitor by this new check. Click Next.

Screenshot 159: Set the scan time interval

Note

Select Inherit from parent to use the same settings as the parent folder.

9. Configure the scan interval schedule for the new check. By default, the check scans the selected
source(s) once every 5 seconds.
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Screenshot 160: Configure event log actions

Note

Select Inherit from parent to use the same settings as the parent folder.

10. A monitoring check generates an event log regardless of whether it fails or succeeds. From Action
events, when event logs are generated and how GFI EventsManager classifies the generated logs.
Available options are described in the following table:

Option Description

Generate an audit event from this
machine/device when the check

GFI EventsManager enables you to generate event logs after the event source is
checked for irregularities. From the drop-down menu, select:

Fails - generate an event log when the conditions of the check fails

Succeeds - generate an event log when the conditions of the check suc-
ceeds

Fails or Succeeds - generates an event log every time the check is run on
the specified event source(s).

Continuous Generates an event log every time the check fails/succeeds/both.

Only once Generates an event log the first time the check fails/succeeds/both.

Once every {X} minutes Generates an event log once every number of minutes you specify.

Once every {X} messages Generates an event log once every number of messages you specify. Example: if
you key in 10, only one event log is generated for every 10 times the check
fails/succeeds/both.

When the check switch state, gen-
erate an audit event from this
machine/device

Generate an event log when the check changes state from Fail to Succeed or
vice versa.

Failed severity Select the severity rating that GFI EventsManager assigns to the event log of a
failed system check.

Table 73: Monitoring checks - Action events
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Option Description

Success severity Select the severity rating that GFI EventsManager assigns to the event log of a
successful system check.

11. Click Finish.

10.5 Applying active monitoring checks

Active Monitoring can be applied to single event sources or groups of event sources. Event sources can
be selected on a check-by-check basis or at root folder level. Configuring settings at folder level
enables the pertaining checks to inherit the same event source settings.

To assign a pre-configured monitoring check:

1. Go to Configuration > Active Monitoring.

2. Right-click on the monitoring check/folder that you want to assign to your event sources and select
Properties.

Screenshot 161: Target computers tab

3. From the Target computers tab, select the event source or group of event sources.

4. Click OK.

Note

Select Inherit from parent to use the same settings as the parent folder.
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10.6 Deleting folders and monitoring checks

To delete a folder/monitoring check:

1. Go to Configuration > Active Monitoring.

Screenshot 162: Deleting folders and monitoring checks

2. From the Monitoring checks section, right-click the folder/monitoring check to delete and select
Delete.

Important

Deleting a root folder (parent folder), deletes all the contents as well. Make sure that
you delete unwanted items only.



GFI EventsManager 11 Alerts and Default Actions | 208

11 Alerts and Default Actions

This chapter provides you with information about the available alerting methods and how to
configure each according to your requirements. During event processing, GFI EventsManager
automatically executes actions and triggers alerts whenever particular events are encountered.

Topics in this chapter:

11.1 Configuring Default Classification Actions 208

11.2 Configuring Alerting Options 210

11.1 Configuring Default Classification Actions

Through the configuration parameters provided in the default classification actions, you can trigger
alerts and actions based only on event classification. Example: default classification parameters can
be configured to trigger email alerts for all classified events (critical, high, medium and low) but
archive only critical events.

Screenshot 163: Configuring default classification actions

To configure Default Classification Actions:

1. From Configuration tab > Options, right-click Default Classification Actions node and Edit
defaults…
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Screenshot 164: Default Classification Actions dialog

2. From the drop-down menu, select the event classification to be configured.

3. From Action list, select actions to be triggered and click Configure. The available actions are:

Action Description

Archive the
event

Archives events without further processing.

Send email
alerts to

Click Configure and select the recipients.

NOTE
Ensure that users have a valid email address configured. For more information refer to Managing
user accounts.

Send net-
work mes-
sages to

Click Configure and select the recipients.

NOTE
Ensure that users have a valid computer name/IP configured. For more information refer to
Managing user accounts.

Send SMS
message to

Click Configure and select the recipients.

NOTE
Ensure that users have a valid mobile number configured. For more information refer to Managing
user accounts.

Table 74: Default Classification Actions
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Action Description

Run file Click Configure and select the file to execute and specify any command-line parameters you want to
pass to the file. Supported files include:

VB Scripts - *.VBS

Batch Files - *.BAT

Executables - *.EXE

Send SNMP
Message

Click Configure and select the recipients.

Scan com-
puter

GFI EventsManager re-audits the computer.

Run checks
on computer

Click Configure, select the monitoring checks you want to run when the action is triggered.

Note
Active Monitoring is applied to the corresponding event sources, selected from the Target
computers tab. For more information refer to Creating and configuring Active Monitoring checks.

Note
Ensure that Monitoring Checks processing is enabled or the checks will be discarded. For more
information refer to Configuring event source monitoring.

4. Click Apply and OK.

Note

Running default actions on events classified as Low, may cause a lot of network traffic
when email, SMS, network or SNMP alerts are enabled. This may also be problematic
when archiving is enabled on Low importance events.

11.2 Configuring Alerting Options

Alerting options enable you to configure what alerts are triggered when particular event(s) are
encountered. For example, you can configure GFI EventsManager to send an email and SMS alert to
one or more recipients when a Critical event is processed.

This section contains information about:

Configuring email alerts

Configuring network alerts

Configuring SMS alerts

Configuring SNMP Traps alerts

Configuring general settings
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To configure Alerting Options:

Screenshot 165: Configuring Alerting Options

1. Click Configuration tab > Options, right-click Alerting Options and select Edit alerting options...

Note

Select Edit alert recipients to configure the contact details of the alerting recipients
and to manage user accounts. For more information refer to Managing user accounts.

2. Configure the alerting method of your choice. The following sections describe how to configure:
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11.2.1 Email alerts

Screenshot 166: Configuring Email options

To configure email alerts:

1. From the Alerting Options dialog, click Email tab.

2. Configure the options described below:

Option Description

Add/Remove/Edit Click Add… to specify the mail server details including the server name /IP, logon credentials and
recipient email address. Use the Remove or Edit button to remove a selected server or edit
details.

Up/Down arrow
buttons

Use the arrow buttons to change the position of the selected mail server. GFI EventsManager
attempts to deliver email alerts via the first mail server. If unsuccessful, it recursively checks the
following mail servers.

Send email alerts
as Unicode text

Select this option to send emails as Unicode text as opposed to HTML or RTF format.

Format Email
Message

Optionally, from the Format Email Message drop-down menu, select the log type (Windows®, Text
Logs, Syslog) and customize the email content.

Table 75: Alerting Options dialog - Email alerts

3. Click Apply and OK.
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11.2.2 Network alerts

Screenshot 167: Configuring Network options

To configure network alerts:

1. From the Alerting Options dialog, click Network tab.

2. From Format network message… drop-down menu, select the log type and customize the format
of the message.

Screenshot 168: Configuring Network alerts: Format message

3. Click Insert tag to select from a list of tags to include in the message.

4. Click Save and OK.
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11.2.3 SMS alerts

Screenshot 169: Configuring SMS options

To configure SMS alerts:

1. From the Alerting Options dialog, click SMS tab.

2. Configure the options described below:

Option Description

Select SMS Select the SMS service used to send SMS alerts. Available services include:
In-built GSM SMS Server

FaxMaker SMS service provider template

Clickatell Email2SMS Service

Generic SMS service provider template.

Set properties for the
selected SMS system

Configure the properties for the selected SMS service type. Amongst others, property
settings include:

Service center number

COM Port

Baud Rate

SMTP Server

SMTP Port.

Click Edit… to configure the selected property.

Format SMS message Optionally, from the Format Email Message drop-down menu, select the log type (Win-
dows®, Text Logs, Syslog) and customize the email content.

Table 76: Alerting Options dialog: SMS
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3. Click Apply and OK.

11.2.4 SNMP alerts

To configure SNMP alerts:

Screenshot 170: Configuring SNMP alerts

1. From the Alerting Options dialog, click SNMP tab.

2. Configure the options described below:

Option Description

Specify the IP address where the
SNMP alerts will be sent

Enter the IP address of the recipient.

Specify the port(s) which will be
used to send SNMP alerts

Specify TCP/UDP communication port. By default, the assigned port is 162.

Format SNMP message Optionally, from the Format Email Message drop-down menu, select the log type
(Windows®, Text Logs, Syslog) and customize the email content.

Table 77: Alerting Options: SNMP Traps

3. Click Apply and OK.

11.2.5 General settings

To configure general alerts settings:

1. From the Alerting Options dialog, click General tab.

2. Configure the options described below and click OK:
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Option Description

Send email alerts on
database errors

Email alerts are sent upon database errors such as backup failure, data corruption, size
exceeds maximum size specified and other database operation errors.

Table 78: Alerting Options: General settings
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12 User Groups

This chapter provides you with information related to creating and managing users and groups.
Through the Users and Groups node, users and groups can be created and specific alerts, working
hours and other properties can be assigned to each user and group; while different console access
rights can be assigned to each user from the Console Security and Audit Options node.

Topics in this chapter:

12.1 Configuring the administrator account 217

12.2 Managing user accounts 223

12.3 Managing user groups 230

12.1 Configuring the administrator account

GFI EventsManager automatically creates an EventsManagerAdministrator account. However, you
must still configure some properties such as the notification addresses and account security.

Note

GFI EventsManager requires a valid administrator email address in order to distribute
automatic alerts when particular events are discovered.

To configure the GFI EventsManagerAdministrator account:

1. From Configuration tab > Options, expand Users and Groups > Users.
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Screenshot 171: Configuring EventsManagerAdministrator account

2. From the right pane, right-click EventsManagerAdministrator and click Properties.

Screenshot 172: EventsManagerAdministrator properties
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3. From the General tab specify:

A username for GFI EventsManager administrator account

(Optional) A description for the account

A valid email address for email alerts distribution

A valid mobile number for SMS alerts distribution

Valid computer names/IPs for network alerts distribution.

Screenshot 173: Configuring user typical working hours

4. Click Working Hours tab and specify the typical working hours of the administrator. Marked time
intervals are considered as working hours.
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Screenshot 174: Configure alerts outside working hours

5. Click Alerts tab and select the alerts sent during and outside working hours. Optionally, select Send
daily report via email at and specify the time to send an email containing daily activity.
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Screenshot 175: Select the group which the user account is a member of

6. Click Member Of tab and select the notification groups to which the user belongs. By default the
administrator is a member of the EventsManagerAdministrators notification group.
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Screenshot 176: Configuring user account privileges

7. Click Privileges tab to edit the user privileges. By default the EventsManagerAdministrator account
has full privileges and cannot be modified.
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Screenshot 177: User account filtering

8. Click Filter tab to edit what the administrator can see in the management console. By default, this
tab is disabled for the EventManagerAdministartor account.

9. Click Apply and OK.

12.2 Managing user accounts

GFI EventsManager allows you to create a custom list of users which you can organize into groups to
speed up administrative tasks.

This section contains information about:

Creating a new user account

Changing user account properties

Deleting a user account

12.2.1 Creating a new user account

To create a new user:

1. From Configuration tab > Options, expand the Users and Groups node.
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Screenshot 178: Creating a new user

2. Right-click Users sub-node and select Create user…

Screenshot 179: Creating a new user - General properties
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3. From the General tab specify:

A username for the user account

(Optional) A description for the account

A valid email address for email alerts distribution

A valid mobile number for SMS alerts distribution

Valid computer names/IPs for network alerts distribution.

Screenshot 180: Creating a new user - Working hours

4. Click Working Hours tab and specify the typical working hours of the new user. Marked time
intervals are considered as working hours.
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Screenshot 181: Creating a new user - Alerting options

5. Click Alerts tab and select the alerts sent during and outside working hours. Optionally, select Send
daily report via email at and specify the time to send an email containing daily activity. For more
information, refer to Alerts and Default Actions (page 208).



GFI EventsManager 12 User Groups | 227

Screenshot 182: Creating a new user - Select notification group(s)

6. Click Member Of tab and click Add. Select the notification groups to which the user belongs and
click OK.
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Screenshot 183: Creating a new user - Privileges

7. Click Privileges tab to configure user privileges. By default, new user accounts have read only
privileges.
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Screenshot 184: User filtering options

8. Click Filter tab to configure what the new user is allowed to display in the management console.
The following table describes the available options:

Option Description

Event
Sources

GFI EventsManager provides you with a set of pre-configured conditions for filtering event sources. Select
the event sources that you want to be visible for this user.

Total priv-
ileges

Click Advanced... to launch the Advanced Filtering dialog. This dialog enables you to build your own
conditions for granular filtering, allowing you to filter events containing specific attributes.
To add a condition:
1. From the Advanced Filtering dialog, click Add and select a field from the list. Example: Date,
Importance, Log format.
2. For the selected field, select an operator from the Field operator drop-down menu. Example: Equal to,
Less than, Greater than.
3. Specify a value for the operator in the Field value text box.
4. Click OK.
5. Repeat steps 1 to 4 to add more than one field name.

Note
For more information refer to Defining query restrictions.

Table 79: User filtering options

9. Click Apply and OK.

12.2.2 Changing user account properties

To edit user properties:

1. From Configuration tab > Options, expand the Users and Groups node.

2. From Users sub-node, right-click a user and select Properties.
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3. Make the required changes in the tabs available and click OK.

12.2.3 Deleting a user account

To delete a user:

1. From Configuration tab > Options, expand the Users and Groups node and select Users.

2. From right pane, right-click a user and select Delete.

12.3 Managing user groups

GFI EventsManager enables you to assign users to a group. Once the group properties have been
configured, every member of the group inherits the same settings.

This section contains information about:

Creating a new group

Changing group properties

Deleting a group

12.3.1 Creating a new group

To create a new user group:

1. From Configuration tab > Options, expand Users and Groups node.

Screenshot 185: Creating a new user group

2. Right-click Groups sub-node and select Create group…
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Screenshot 186: Creating a new user group - General properties

3. Specify the name and an optional description for the new group.

4. Click Add to add users to the group.
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Screenshot 187: Creating a new user group - General properties

5. From the Privileges tab, select if the group has Full or Read Only permissions.

6. Click Apply and OK.

12.3.2 Changing group properties

To edit the settings of a user group:

1. From Configuration tab > Options, expand Users and Groups node.

2. From the right pane, right-click on the group to be configured and select Properties.

3. Perform the required changes in the tabs available and click OK.

12.3.3 Deleting a group

To delete a user group:

1. From Configuration tab > Options, expand Users and Groups node.

2. Right-click on the group to be deleted and select Delete.
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13 Console Security and Audit Options

Console security and audit options enable you to protect GFI EventsManager from unauthorized
access and malicious intent. The provided audit options enable you to accurately monitor GFI
EventsManager activity.

Topics in this chapter:

13.1 Enabling login system 233

13.2 Anonymization 236

13.3 Auditing console activity 239

13.4 Auto-discovery credentials 240

13.1 Enabling login system

When the login system is enabled all users will be asked to specify their credentials every time they
launch the GFI EventsManager management console.

Note

Before you enable the login system, you must configure your mail server settings. For
more information refer to Configuring Alerting Options.

To enable the log-in system:

1. From Configuration tab > Options expand Console Security and Audit Options node.
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Screenshot 188: Editing console security options

2. Expand Console Security and Audit Options node, right-click Security Options node and select
Edit security options….
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Screenshot 189: Enabling EventsManager login system

3. Select Enable EventsManager login system to enable login.

4. Click Apply and OK.

Note

To configure or edit user passwords go to Configuration tab > Users and Groups >
Users, right-click the user account and select Change Password.

Important

Once the login system is enabled, users must login to the console by specifying their
username and password and must have a valid email configured to be able to retrieve
lost passwords. For more information refer to Managing user accounts.

13.1.1 Password recovery

When GFI EventsManager login system is enabled, all users are requested to enter a valid user name
and password to access the management console.
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Screenshot 190: Login credentials prompt

If a password is forgotten or lost:

1. Key in your username.

2. Click Forgot your password? link. GFI EventsManager will send an email containing your login
password on the email address supplied during the user account setup.

13.2 Anonymization

In some countries privacy laws state that it is against the law not to encrypt personal information
retrieved by monitoring applications for privacy protection. GFI EventsManager enables you to
encrypt personal information when exporting and/or viewing event logs.

Enable anonymization to encrypt all personal information. The Events Browser and Dashboard can
recognize such information and do not display it. Instead, they display <encrypted> or Anonymized
data messages instead.

To configure anonymization:
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Screenshot 191: Enable console anonymization

1. From Configuration tab > Options, expand Console Security and Audit Options node, right-click
Anonymization and click Edit anonymization options…
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Screenshot 192: Anonymization options

2. Select Enable Anonymization and enter the encryption password.

3. (Optional) Select Use a secondary protection key to use two passwords for event log encryption.
Event logs can only be decrypted by providing two decryption passwords.

4. Click Apply and OK.

Note

Once anonymization is enabled, personal data is hidden in:

Any of the Status views (General, Job Activity and Statistics)

Events Browser

Reports

Exported/archived event logs (you can remove anonymization when importing the
exported logs).
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13.3 Auditing console activity

GFI EventsManager can save console activity to external logs. To configure console activity auditing:

Screenshot 193: Enabling console user activity auditing

1. From Configuration tab > Options, expand Console Security and Audit Options node.

2. Right-click Audit Options and select Edit audit options….
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Screenshot 194: Audit Options dialog

3. Select Audit all the actions done by users option and specify the location where the output log file
will be saved.

4. Click Apply and OK.

13.4 Auto-discovery credentials

Auto-discovery credentials are used by GFI EventsManager to login target machines and collect
information when performing an automatic search for event sources. To configure the auto-discovery
credentials:
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Screenshot 195: Configuring Auto-Discovery Credentials

1. From Configuration tab > Options, expand Console Security and Audit Options node.

2. Right-click Auto-discovery credentials and select Edit auto-discovery credentials.
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Screenshot 196: Specify Auto-discovery credentials

3. Key in a valid username and password.

4. Click Apply and OK.
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14 Database Maintenance

This chapter provides information about the storage system that GFI EventsManager uses to store
processed events. This system allows great scalability with its fast read/write capabilities; even when
processing high volumes of data. To help you maintain your database backend, GFI EventsManager
provides you with dedicated maintenance job options.

Database maintenance jobs provide advanced functionality to administrators, allowing them to:

Centralize events collected by other remote GFI EventsManager instances into one database
backend

Optimize GFI EventsManager performance by actively controlling database backend growth hence
keeping it in good shape

Import and export data to and from older versions of GFI EventsManager without data incon-
sistencies.

Import and export events to and from a storage folder minimizing data loads from the database.

Topics in this chapter:

14.1 Managing the database backend 243

14.2 Creating maintenance jobs 253

14.3 Editing maintenance jobs 282

14.1 Managing the database backend

This section describes how you can easily manage your backend database through GFI EventsManager
Management Console.

This section contains information about:

Creating a new database

Protecting your database

Enabling database record hashing

Switching databases

Configuring database rotation options

14.1.1 Creating a new database

GFI EventsManager enables you to have multiple databases to store processed event logs. Through
the Events Browser, Reporting tab and other locations, you can easily switch from one database to
another, allowing you to view events or generate reports from multiple databases. Databases can be
further secured by encrypting them with a password.

To create a new database:

1. From Configuration tab > Options > Configurations, right-click File Storage and select Configure
file storage….
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Screenshot 197: File storage system dialog

2. Click New and key in the new database name. Click OK to close the Create new database dialog.

3. Click Browse to select a location other than the default database store.

4. (Optional) Select Encrypt data using the following password and specify the encryption password
used to secure information in the new database.

Note

Indicates that the specified passwords do not match.

5. Click Apply and OK.

14.1.2 Protecting your database

GFI EventsManager enables you protect your database with an encryption key. Encrypting the
database will prevent unauthorized personnel from viewing or accessing event logs.

Important

Encrypting the database will cause the Status Monitor and Events Browser to stop
viewing sensitive information.
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To encrypt the database backend:

Screenshot 198: Editing file storage settings

1. Click Configuration tab > Options, right-click File Storage and select Configure file storage....
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Screenshot 199: Enabling encryption

2. From General tab, select Encrypt data using the following password to enable encryption.

3. Specify the password and confirmation password.

Note

Indicates that the specified passwords do not match.

4. Click Apply and OK.

Note

The live database (the database you are currently using) cannot be encrypted from this
dialog. Only new or offline databases can be encrypted from here. To encrypt the live
database, use the provided CMD tool: esmdlibm.exe. For more information refer to
Using Esmdlibm.exe.

14.1.3 Database record hashing

To further protect your data, GFI EventsManager provides you with record hashing capabilities.
Hashing new records is a method used to ensure that data in your databases remains unmodified.
When record hashing is enabled, a hash is created for every collected log, at collection time. The hash
is built based on the data contained in the event log itself and created as soon as the event log is
collected to ensure that it is the original version. When data of a hashed record is modified (even a
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character from a word), the hash value changes, indicating that someone could be tampering with
stored records.

Important

Hashing will fail if anonymization is enabled.

To configure hashing:

Screenshot 200: Enabling / disabling record hashing

1. From Configuration tab > Options > Configurations, click File Storage > Configure hashing....
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Screenshot 201: Record hashing dialog

2. Select/unselect Enable record hashing to turn on/off hashing features.

3. Click Check records hashes to run hash checks on the selected database. Select a database from
the list and click OK to start the check.

4. Click Apply and OK.

14.1.4 Switching between file storage databases

GFI EventsManager enables you to use multiple databases, stored in different locations on the same
computer or on any remote computer within your LAN.

To switch between databases:

1. Click Configuration tab > Options.
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Screenshot 202: Options tab

2. From the left pane, right-click File Storage and select Configure file storage...
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3. From the Configure file storage dialog, click Switch server. This opens the Switch Database Server
dialog.

4. In the Server hostname text box, key in the Computer Name or IP address of the database
machine. Click OK.

5. Click Apply and OK.

Switching databases from the dashboard

The General dashboard view enables you to switch to a different database without having to access
the configuration tab. This is useful when comparing event logs or assessing the overall status of
events management within your environment.

To switch to a different database from the dashboard:

1. Click Status > General.

Screenshot 203: Switch between databases from the dashboard

2. From the GFI EventsManager Service Status section, click Database server is running.

3. From the Configure file storage dialog, click Switch server and key in the database server Name or
IP address. Click OK.
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4. Click Apply and OK.

14.1.5 Configuring database rotation options

When processing events from a large number of event sources, it is important to configure database
rotation options. These options instruct GFI EventsManager to automatically switch to a new
database when a certain condition is met. Doing so helps you maintain a pool of fixed size databases
which enable GFI EventsManager to perform better.

When a database becomes too large in size, queries take longer to complete so therefore, GFI
EventsManager performance is affected negatively.

For example, if your event sources normally generate a lot of small sized event logs, enable database
rotation for when a maximum number of records is reached. On the other hand, if the size of event
logs that your event sources are generating is large, configure database rotation for when the
database reaches the size limit.

To configure database rotation options:

1. Click Configuration tab > Options.

2. From Configurations, click File storage > Configure file storage…

Screenshot 204: Configuring database rotation options

3. Click Enable database rotation.

4. Configure the options described below:
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Option Description

Rotate when database
reaches {X} Records

Specify the number of records that the database has to contain before rotating to a
new one.

Note
Minimum value = 1,000, 000 records.

Rotate when database
reaches {X} GB

Rotate to a new database when the current one reaches the specified size in Giga
Bytes (GB)

Note
Minimum value = 1GB.

Rotate when database
is {X} weeks old

Rotate database when the current one is older than the specified number of weeks.

Note
Minimum value = 1 week.

Rotate database on 1st
of each {X} months

Select this option to rotate databases on the 1st of each number of specified
months. Example, rotate database on the 1st of every month, 1st of every two
months or 1st of every six months.

Number of databases
to create

Specify the maximum number of databases that GFI EventsManager is able to cre-
ate. Leave the value at 0 so that an unlimited number of databases can be created.

Delete database as
needed

Select this option so that when the maximum number of databases is reached, GFI
EventsManager automatically deletes the oldest database to free space for new
ones.

Each day (every 24hrs
from the service start-
ing time)

Select this option to create and use a new database every 24 hours. 24 hours are
calculated from the time the GFI EventsManager service starts.

Only after database
maintenance is per-
formed

Create and use a new database, after an existing database performs maintenance
operations.

Table 80: Database rotation options

5. Click Apply and OK.

14.1.6 Configuring Database Operations

To configure Database Operations:

1. Click Configuration tab > Options.

2. From Configurations, right-click Database Operations and select Properties.
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Screenshot 205: Database Operations Options dialog

3. Configure the options from the tabs described below:

Tab Description

General Specify the unique identifier by which this instance of GFI EventsManager will be identified on the network.
This identifier is used as part of the export file-name during Export to file operations.

Schedule Through the Schedule tab, specify:
Hours of the day during which maintenance jobs can be executed

The interval in hours/days with which maintenance jobs will be executed

The scheduled date/time when maintenance jobs will start being executed.

Table 81: Configuring database operations

4. Click Apply and OK.

Note

Schedule options can also be modified from Configuration tab > Options > Actions and
click Edit schedule options....

14.2 Creating maintenance jobs

With GFI EventsManager you can schedule maintenance jobs to be executed on a specific day, at a
specific time and at specific intervals. Database maintenance operations may require high utilization
of resources. This can degrade server and GFI EventsManager performance. Schedule maintenance
jobs to be executed after office hours to maximize the availability of your system resources and avoid
any possible disruptions to workflow.
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GFI EventsManager supports two types of maintenance jobs as described below:

Job type Description

Import\Export
Job

Import/export data from/to other instances of GFI EventsManager. Export data and import them in
other instances as part of the data centralization process.

Legacy Import
Job

Import data from older versions of the product. Import data from Microsoft® SQL Server® databases, leg-
acy files and legacy file storage. The import jobs supported by this job type are all based on the data-
base backend types of older versions of GFI EventsManager.

Table 82: Maintenance jobs types

Read the following sections for information about creating the following maintenance jobs:

Import from file

Export to file

Export to SQL

Copy data

Commit deletions

Import from SQL Server® databases

Import from legacy files

Import from legacy file storage

14.2.1 Import from file

Import from file job enables you to import data that was previously exported to a configuration file.

To create an Import from file job:

1. Click Configuration tab and select Options.

2. From Configurations, right-click Database Operations node and select Create new job…

3. Click Next at the wizard welcome screen.
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Screenshot 206: Creating Import\Export jobs

4. Select Import/Export Job and click Next.

Screenshot 207: Import from file

5. Select Import from file and click Next.
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Screenshot 208: Import from file - Specify import file path

6. Specify the path to the configuration file that contains data you want to import. Optionally, click
Browse to look for the location. Click Next.

Screenshot 209: Decrypt secure import files

7. (Optional) If the file you are importing is encrypted, select Decrypt the files using the following
password and specify the password used to encrypt the file. Click Next.
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Screenshot 210: Add filtering conditions

8. Add advanced filtering parameters to import specific data only. Leave blank to import all the event
logs from the file.

Note

For more information refer to Building Query Restrictions.
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Screenshot 211: Execute job options

9. Select when the job is executed and click Finish:

Options Description

Schedule job The job will be saved and executed according to the database operations schedule.

Run the job now Job is executed immediately. Unscheduled jobs only run once and cannot be reused.

Table 83: Creating maintenance jobs - Schedule options

14.2.2 Export to file

Export to file enables you to export selected settings to a configuration file that can be imported by
another instance or version of GFI EventsManager.

To create an export to file job:

1. Click Configuration tab and select Options.

2. From Configurations, right-click Database Operations node and select Create new job…

3. Click Next at the wizard welcome screen.
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Screenshot 212: Creating Import\Export jobs

4. Select Import/Export Job and click Next.

Screenshot 213: Export to file

5. Select Export to file and click Next.
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Screenshot 214:

6. Key in the path to the folder where exported files are saved to. Alternatively, click Browse to look
for the location. Click Next.

Screenshot 215: Decrypt/Encrypt data

7. If the source database (esmstg) is encrypted, select Decrypt data using the following password
and key in the decryption key in the Password field.
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8. To encrypt export data, select Encrypt exported data using the following password and key in an
encryption key in the Password and Confirm password fields. Click Next.

Screenshot 216: Filtering export data

9. Configure the following filtering options and click Next:

Option Description

Export all
events

Export all events from the database.

Events
older than

Only export events older than the specified number of days/weeks/months.

Events in
the last

Only export events that occurred in the last specified number of days/weeks/months.

Mark
events as
deleted

Hide events from the source database after they are exported. To completely remove these events from
the database, you must run a Commit Deletions job. For more information refer to Commit deletions.

Advanced... Click Advanced... to launch the Advanced Filtering dialog. This enables you to configure granular filtering
parameters to export specific events only. For more information refer to Building query restrictions.

Table 84: Filtering export data
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Screenshot 217: Execute job options

10. Select when the job is executed and click Finish:

Options Description

Schedule job The job will be saved and executed according to the database operations schedule.

Run the job now Job is executed immediately. Unscheduled jobs only run once and cannot be reused.

Table 85: Creating maintenance jobs - Schedule options

Export filename

The convention used by GFI EventsManager to name the export file is shown and described below:

[ESM ID]_[Job ID]_[Date From]_[Date To].EXP

Name Section Description

ESM ID Refers to the unique identifier given to each GFI EventsManager instance running in the organization.

Job ID Refers to the unique identifier given to each maintenance job created.

Date From Refers to the date of the earliest event exported.

Date To Refers to the date of the latest event exported.

.EXP This is the file extension given to all export files.

Table 86: Database operations: Export file name structure

14.2.3 Export to SQL

Export to SQL enables you to export items directly to an SQL Server instance that is reachable by the
GFI EventsManager host.

To create an export to SQL job:

1. Click Configuration tab and select Options.

2. From Configurations, right-click Database Operations node and select Create new job…
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3. Click Next at the wizard welcome screen.

Screenshot 218: Creating Import\Export jobs

4. Select Import/Export Job and click Next.

Screenshot 219: Export to SQL

5. Select Export to SQL and click Next.
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Screenshot 220: Specifying SQL Server details

6. Configure the following server options and click Next:

Option Description

Server Key in the name of the machine that is running SQL Server.

Database Key in the name of the destination database.

Note
If the specified database does not exist, GFI EventsManager creates it for you.

Table Key in the name of the destination table.

Note
If the specified table does not exist, GFI EventsManager creates it for you.

Use Windows
authentication

Use the same logon credentials used to log on to Windows®. The SQL Server® must support this type
of authentication mode to be able to connect and copy information to the server.

Use SQL Server
authentication

Use the logon credentials configured in your SQL Server®. Key in the username in the User field and
the password in the Password field.

Test connection Click Test Connection to attempt to connect to the SQL Server® using the specified settings.

Note
GFI EventsManager tests the connection automatically after you click Next.

Table 87: Export to SQL - Server options



GFI EventsManager 14 DatabaseMaintenance | 265

Screenshot 221: Select columns to export

7. Select the columns you want to export and click Next.

Note

To export all columns, select Export all columns.
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Screenshot 222: Filtering export data

8. Configure the following filtering options and click Next:

Option Description

Export all
events

Export all events from the database.

Events
older than

Only export events older than the specified number of days/weeks/months.

Events in
the last

Only export events that occurred in the last specified number of days/weeks/months.

Mark
events as
deleted

Hide events from the source database after they are exported. To completely remove these events from
the database, you must run a Commit Deletions job. For more information refer to Commit deletions.

Advanced... Click Advanced... to launch the Advanced Filtering dialog. This enables you to configure granular filtering
parameters to export specific events only. For more information refer to Building query restrictions.

Table 88: Filtering export data
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Screenshot 223: Execute job options

9. Select when the job is executed and click Finish:

Options Description

Schedule job The job will be saved and executed according to the database operations schedule.

Run the job now Job is executed immediately. Unscheduled jobs only run once and cannot be reused.

Table 89: Creating maintenance jobs - Schedule options

14.2.4 Copy data

To create Copy data jobs:

1. Click Configuration tab and select Options.

2. From Configurations, right-click Database Operations node and select Create new job…

3. Click Next at the wizard welcome screen.
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Screenshot 224: Creating Import\Export jobs

4. Select Import/Export Job and click Next.

Screenshot 225: Select Copy data job

5. Select Copy data and click Next.
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Screenshot 226: Specify source and destination databases

6. Select the source and destination databases. Click Next.

Screenshot 227: Decrypt source and encrypt destination databases

7. If the source database is encrypted, select Decrypt data using the following password and specify
the password used to encrypt the database.
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8. If you want to encrypt the source data, select Encrypt exported data using the following
password. Specify the encryption password and click Next.

Screenshot 228: Filtering export data

9. Configure the following filtering options and click Next:

Option Description

Export all
events

Export all events from the database.

Events
older than

Only export events older than the specified number of days/weeks/months.

Events in
the last

Only export events that occurred in the last specified number of days/weeks/months.

Mark
events as
deleted

Hide events from the source database after they are exported. To completely remove these events from
the database, you must run a Commit Deletions job. For more information refer to Commit deletions.

Advanced... Click Advanced... to launch the Advanced Filtering dialog. This enables you to configure granular filtering
parameters to export specific events only. For more information refer to Building query restrictions.

Table 90: Filtering export data

10. Select when the job is executed and click Finish:

Options Description

Schedule job The job will be saved and executed according to the database operations schedule.

Run the job now Job is executed immediately. Unscheduled jobs only run once and cannot be reused.

Table 91: Creating maintenance jobs - Schedule options

14.2.5 Commit deletions

To create Commit deletions jobs:

1. Click Configuration tab and select Options.

2. From Configurations, right-click Database Operations node and select Create new job…
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3. Click Next at the wizard welcome screen.

Screenshot 229: Creating Import\Export jobs

4. Select Import/Export Job and click Next.

Screenshot 230: Create commit deletion jobs

5. Select Commit deletions and click Next.
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Screenshot 231: Select database to delete records from

6. Select the database to delete records from. Click Next.

7. Select when the job is executed and click Finish:

Options Description

Schedule job The job will be saved and executed according to the database operations schedule.

Run the job now Job is executed immediately. Unscheduled jobs only run once and cannot be reused.

Table 92: Creating maintenance jobs - Schedule options

14.2.6 Import from SQL Server® Database

1. Click Configuration tab and select Options.

2. From Configurations, right-click Database Operations node and select Create new job…

3. Click Next at the wizard welcome screen.
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Screenshot 232: Creating Import\Export jobs

4. Select Legacy Import Job and click Next.

Screenshot 233: Select Import from SQL Server Database

5. Select Import from SQL Server® database and click Next.
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Screenshot 234: Specify SQL Server address and login details

6. Configure the following server options and click Next:

Option Description

Server Key in the name of the machine that is running SQL Server.

Database Key in the name of the source database.

Use Windows
authentication

Use the same logon credentials used to log on to Windows®. The SQL Server® must support this type
of authentication mode to be able to connect and copy information from the server.

Use SQL Server
authentication

Use the logon credentials configured in your SQL Server®. Key in the username in the User field and
the password in the Password field.

Table 93: Export to SQL - Server options
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Screenshot 235: Decrypt anonymized databases

7. (Optional) If the SQL Server® database is anonymized, select Enable decryption and specify the
password used to anonymize the database.

8. (Optional) If the SQL Server database was anonymized using two password, select Use secondary
decryption key and specify the second security password used to anonymize the database. Click
Next.

Screenshot 236: Add filtering conditions to filter unwanted data
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9. Add advanced filtering parameters to import specific data only. Leave blank to import all the event
logs.

Note

For more information refer to Building Query Restrictions.

Screenshot 237: Specify when the maintenance job is executed

Select Run the job now and click Finish.

14.2.7 Import from legacy files

To create Import from legacy files jobs:

1. Click Configuration tab and select Options.

2. From Configurations, right-click Database Operations node and select Create new job…

3. Click Next at the wizard welcome screen.
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Screenshot 238: Creating Import\Export jobs

4. Select Legacy Import Job and click Next.

Screenshot 239: Import from legacy files

5. Select Import from legacy files and click Next.
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Screenshot 240: Specify import file location

6. Specify the path to the configuration file that contains data you want to import. Optionally, click
Browse to look for the location. Click Next.

Screenshot 241: Decrypt the information in the import file

7. (Optional) If the file was encrypted, select Decrypt the files using the following password and
specify the password used to encrypt the file. Click Next.



GFI EventsManager 14 DatabaseMaintenance | 279

Screenshot 242: Remove anonymization

8. (Optional) If the file is anonymized, select Enable decryption and specify the password used to
anonymize the data.

9. (Optional) If the file was anonymized using two passwords, select Use secondary decryption key
and specify the second key used to anonymize the data within the file. Click Next.

Screenshot 243: Filter unwanted events through filtering conditions
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10. Add advanced filtering parameters to import specific data only. Leave blank to import all the
event logs.

Note

For more information refer to Building Query Restrictions.

Screenshot 244: Specify when the maintenance job is executed

Select Run the job now and click Finish.

14.2.8 Import from legacy file storage

To create Import from legacy files jobs:

1. Click Configuration tab and select Options.

2. From Configurations, right-click Database Operations node and select Create new job…

3. Click Next at the wizard welcome screen.
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Screenshot 245: Creating Import\Export jobs

4. Select Legacy Import Job and click Next.

Screenshot 246: Import legacy file storage data

5. Select Import from legacy file storage and click Next.

6. Specify the path to where the import file is located. Alternatively, click Browse and look for the
location.
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7. (Optional) If the data is anonymized, select Enable decryption and specify the password used to
encrypt the data.

8. (Optional) If the data is encrypted by two passwords, select Use secondary decryption key and key
in the secondary password. Click Next.

9. (Optional) Specify filtering conditions to filter out unwanted data. Leave it blank to export all the
data in the database. For more information, refer to Defining Restrictions. Click Next.

Screenshot 247: Specify when the maintenance job is executed

Select Run the job now and click Finish.

14.3 Editing maintenance jobs

This section contains information about:

Viewing scheduled maintenance jobs

Editing maintenance job properties

Changing maintenance jobs priority

Deleting a maintenance job

14.3.1 Viewing scheduled maintenance jobs

To view the progress of scheduled maintenance jobs:
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Screenshot 248: Maintenance job activity

Click Status tab > Job Activity. The status of all maintenance jobs will be displayed in the Queued
Jobs section.

To view created maintenance jobs:

Screenshot 249: Viewing scheduled maintenance jobs

1. Click Configuration tab and select Options.

2. From Configurations, select the Database Operations node. Scheduled maintenance jobs are
displayed in the right pane.

14.3.2 Editing maintenance job properties

To edit maintenance jobs properties:

1. From Configuration tab > Options > Configurations, click Database Operations.

2. From the right pane, right-click on a maintenance job and select Properties.
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Screenshot 250: Maintenance job properties dialog

3. From the Job Properties dialog, you can modify the settings you configured while creating the job;
such as:

Encryption/decryption passwords

Database names and addresses

Source/destination paths

General job details.

4. Click Apply and OK.

Note

For more information refer to Creating maintenance jobs.
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14.3.3 Changing maintenance jobs priority

Screenshot 251: Maintenance job priorities

By default maintenance jobs are executed according to the sequence with which the jobs are created
(First-in-First-out). Thus the priority of maintenance jobs is determined by the sequence in which jobs
are executed.

To increase or decrease the priority of a maintenance job:

1. Click Configuration tab and select Options.

2. From Configurations, select Database Operations node.

3. From the right pane, right-click the maintenance job and select Increase Priority or Decrease
Priority accordingly.

14.3.4 Deleting a maintenance job

To delete maintenance jobs:

1. Click Configuration tab and select Options.

2. From Configurations, select Database Operations node.

3. From the right pane, right-click on the maintenance job to delete and select Delete.

Note

Before deleting maintenance jobs ensure that all data is backed up.
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15 Configuring the Management Console

This chapter provides you with information about configuring general settings of GFI EventsManager,
such as product licensing, performance options and product updates.

Topics in this chapter:

15.1 Performance options 286

15.2 Product updates 287

15.3 Product licensing 294

15.4 Product version information 295

15.5 Importing and Exporting settings 296

15.6 Building query restrictions 303

15.1 Performance options

GFI EventsManager provides you with options which enable you to set the performance level of the
GFI EventsManager service.

To configure the performance level:

Screenshot 252: GFI EventsManager Performance Options

1. From Configuration tab > Options > Configurations, right-click Performance Options and select
Edit Performance Options.
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Screenshot 253: Performance Options dialog

2. Select/Unselect Enable EventsManager service performance to enable/disable service
performance options.

3. Move the slider left (low) to right (high) until you reach the required performance level.

4. Click Apply and OK.

Note

Setting the performance level on low is estimated to process 50 events per second per
event source, while setting the bar on high processes 1,000 - 2,000 events per second
per event source.

15.2 Product updates

Periodically, GFI releases product updates to improve or add functionality to GFI EventsManager.
Product updates are important to download and install because they fix issues with underlying
technologies as well as increase compatibility with different technologies and devices.

When the GFI EventsManager host is connected to the Internet, products updates can be downloaded
directly from the Management Console. Where Internet access is limited or there is none at all,
product updates can be downloaded from an alternate location and then placed in the updates
repository manually. Refer to the following sections for information about:

Downloading updates directly

Downloading updates from an alternate location (offline)
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15.2.1 Downloading updates directly

GFI EventsManager enables users to configure how to automatically check for, download and install
product updates.

To configure Auto Update options:

1. From Configuration tab > Options > Configurations, right-click Auto Update Options and select
Edit updater options...

Screenshot 254: Configure auto update options

2. Configure the options described below:

Options Description

Check for updates auto-
matically

If selected, GFI EventsManager will check for updates automatically on a daily or
weekly basis.

Update Now If Check for updates automatically is not selected, use this option to manually check
for updates and install missing updates.

Install updates automatically Installs downloaded updates automatically.

Only notify me when updates
are available

Available updates are shown in the Missing Updates section but are not installed.

Show messages in the applic-
ation

Shows a message at the bottom of the application page. Click on the displayed
message to action the updates.

Send alerts on GFI Event-
sManager Administrator user

Sends an email alert on the configured GFI EventsManagerAdministrator account. For
more information refer to Configuring the administrator account.

Table 94: Auto update options

3. If product updates must be downloaded through a proxy server, click the Proxy Server tab.
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Screenshot 255: Configuring proxy settings to download product updates

4. Select Use a proxy server and key in the proxy server address and listening port in the Address and
Port fields.

5. (Optional) If the proxy server requires authentication, select Enable Authentication and key in the
proxy logon credentials.

6. Click Apply and OK.

15.2.2 Downloading updates from an alternate location (offline)

To download product updates, GFI EventsManager connects to GFI's updates server. If the GFI
EventsManager host is in a secure environment, not connected to the Internet, updates can be
downloaded from an alternate location.

From a computer with Internet access, download the updates package and transfer it to the GFI
EventsManager host. Use CMD to manually launch an update session, using the updater tool provided
in the install directory.

You will need a username and password to log into the GFI updates server. To obtain your login
credentials, contact one of our support representatives. For more information, refer to Requesting
Technical Support.

Note

This procedure assumes that the product is installed in the default location: C:\Program
Files (x86)\GFI\EventsManager2012.
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To download updates from an alternate location:

1. On a computer with Internet access, go to http://update.gfi.com/esm.

2. Key in your username and password. This opens the GFI EventsManager updates directory on the
updates server.

Screenshot 256: GFI EventsManager updates

3. Click ESMUpdateInfo.xml.gz and save it to a location of your choice.

http://update.gfi.com/esm
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Note

Transfer the downloaded updates package from the computer with Internet access to
the GFI EventsManager host.

Screenshot 257: GFI EventsManager updates repository

4. On the GFI EventsManager machine, copy the updates package to the following repository:
C:\Program Files\GFI\EventsManager2012\Data\AutoUpdate.
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Screenshot 258: Open CMD in administrator mode

5. Open CMD in elevated privileges mode, and key in:

64-bit systems - CD C:\Program Files (x86)\GFI\EventsManager2012

32-bit systems - CD C:\Program Files\GFI\EventsManager2012

Press Enter.
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Screenshot 259: Change path to GFI EventsManager install directory

Note

The path changes according to the directory you specify.

Screenshot 260: Manually launch an update session

6. Key in:

updater.exe /InstallNow

Press Enter.
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To ensure that all updates are installed, run updater.exe /InstallNow, until you get a message
indicating that 0 missing updates were found.

Screenshot 261: Updates status

15.3 Product licensing

GFI EventsManager is licensed by event source/computer. All devices that generate a log are
considered to be an event source. Refer to the sections below for more information about GFI
EventsManager licensing options.

The following sections contain information about:

Updating license key

Obtaining a free 30-day trial license key

Viewing license details

Purchasing a license key

15.3.1 Updating license key

To update your current license key:

1. From General tab > General, right-click Licensing and select Update key...

Screenshot 262: Update license key dialog
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3. Specify your license key and click OK.

15.3.2 Obtaining a free 30-day trial license key

GFI EventsManager allows you to register your version of the product and receive a free 30-day trial.
Once the trial period is expired, all event log monitoring and management services are disabled and a
full license key is required.

To register and receive a 30-day trial license key:

1. From General tab > General, click Licensing.

2. Click the provided link. This will take you to GFI website where you are able to enter you details
and receive the license key by email. The email address you provide in the registration form is where
your free 30-day trial key will be sent. If you have a spam filtering system, make sure the email is not
blocked as spam.

15.3.3 Viewing license details

License details provide you with license distribution details. To view licensing details:

1. From General tab > General, click Licensing.

2. From the right pane, click Show details to expand the details section. This will show the number of
event sources configured and respective license type (such as Workstation or Server).

15.3.4 Purchasing a license key

To purchase a license key:

1. From General tab > General, click Licensing.

Screenshot 263: Buy now! Button

2. From the right pane, click Buy now!. This takes you to GFI website where you can view further
information about licensing and purchase a valid key.

Note

For more information, refer to:

Licensing Information - http://www.gfi.com/page/13789/products/gfi-events-
manager/pricing/licensing/licensing

Pricing Information - http://www.gfi.com/products/gfi-eventsmanager/pricing

15.4 Product version information

GFI recommends that you keep GFI EventsManager up-to-date and use the latest product version for
full feature support and device compatibility. Version information can also be useful to troubleshoot
functionality errors with a technical support representative. Refer to the following sections for
information about:

15.4.1 Checking your GFI EventsManager version

To check your version information details:

1. From General tab > General, click Version Information.

http://www.gfi.com/page/13789/products/gfi-eventsmanager/pricing/licensing/licensing
http://www.gfi.com/products/gfi-eventsmanager/pricing
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Screenshot 264: Version Information screen

2. View version information details from the right pane.

3. (Optional) Click Click here to obtain the version number of the latest release to get the latest
version information from GFI servers.

15.4.2 Checking for newer versions

To check for newer builds of GFI EventsManager:

1. From General tab > General, right-click Version Information and select Check for newer builds...

2. (Optional) From the right pane, select/unselect Automatically check for a newer version at
startup to check for new versions automatically. By default, this option is enabled.

15.5 Importing and Exporting settings

The provided import and export tool, enables you to seamlessly move configurations from one
instance of GFI EventsManager to another. This can also be done as part of a disaster recovery plan,
to avoid having to reconfigure GFI EventsManager in case of a disaster. The following settings can be
imported/exported using GFI EventsManager:

Event Sources

Event Processing Rules

Events Browser Filters

Options (including Default Classification Actions, Alerting Options, Database operations and
more).

This section contains information about:
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Exporting configurations to a file

Importing configurations from a file

Importing configurations from another instance

15.5.1 Exporting configurations to a file

To export you GFI EventsManager configurations:

1. Click File > Import and Export Configurations....

Screenshot 265: Export configurations to a file

2. Select Export the desired configurations to a file and click Next.
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Screenshot 266: Specify export destination

3. Specify the location where the exported file will be saved or click Browse... to look for the
location. Click Next.

Screenshot 267: Select export configurations

4. Select the configurations you want to export and click Next.



GFI EventsManager 15 Configuring theManagement Console | 299

5. Wait for GFI EventsManager to export the configuration and click OK.

15.5.2 Importing configurations from a file

To import configurations from a file:

1. Click File > Import and Export Configurations....

Screenshot 268: Import configurations from a file

2. Select Import the desired configurations from a file and click Next.
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Screenshot 269: Specify configuration file location

3. Specify the path where the import file is stored or click Browse... to look for it. Click Next.

]
Screenshot 270: Select configurations to import

4. Select the configurations you want to import and click Next.

5. Wait for GFI EventsManager to import the configurations and click OK.
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Note

If GFI EventsManager detects other configurations, it will ask you if you want to override
or merge both configurations.

15.5.3 Importing configurations from another instance

To import configurations from another instance of GFI EventsManager:

1. Click File > Import and Export Configurations...

Screenshot 271: Import configurations from another instance of GFI EventsManager

2. Select Import the configurations from another instance and click Next.
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Screenshot 272: Specify instance location

3. Specify the installation folder path of the instance you want to import configurations from.
Alternatively, click Browse... to look for it. Click Next.

Screenshot 273: Select configurations to import from another instance of GFI EventsManager

4. Select the configurations you want to import and click Next.
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5. Wait for the configurations to import and click OK.

Note

If GFI EventsManager detects other configurations, it will ask you if you want to override
or merge both configurations.

15.6 Building query restrictions

GFI EventsManager enables you to build custom queries, using the Edit Query Restriction dialog.
Queries are instructions GFI EventsManager sends to the database backend when storing and
retrieving data. They are also used to configure rules to trigger actions and alerts when certain
attribute values are detected.

The following scenarios use the Edit Query Restriction dialog for granular configuration:

Use Description

Configuring
reports

Build queries to filter report information and generate reports pertaining to specific attributes.

Configuring
user
accounts

Prevent GFI EventsManager Management Console users from displaying unauthorized information about
other users, event logs or network activity.

Configuring
events pro-
cessing rules

Scan collected event logs for attributes that match values configured in events processing queries. This
enables you to inspect network activity in granular detail, which helps you to proactively resolve net-
work issues before evolving into serious problems.

Table 95: Uses of query restrictions
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Screenshot 274: Users, Events processing rules and Report queries

15.6.1 Using the Edit Query Restriction dialog

To edit query restrictions for granular filtering and configuration:

1. The following table describes how to launch the Edit Query Restriction dialog for users, reports and
processing rules:

Configure... Procedure

Users To launch the query restrictions dialog:
1. Click Configuration tab > Options > Users and Groups > Users.
2. From the right-pane, right-click the user to edit and select Properties.
3. From the User Properties dialog, click Filter tab > Advanced...
4. From the Advanced filtering dialog, click Add.

Reports To launch the query restrictions dialog:
1. Click Reporting tab.
2. From the Reports list, right-click the report to edit and select Properties.
3. From the General tab, click Add.

Events processing
rules

To launch the query restrictions dialog:
1. Click Configuration tab > Events Processing Rules.
2. From the Rule Folders list, right-click the events processing rule to edit and select
Properties.
3. From the processing rule properties dialog, click Conditions tab > Add.

Table 96: Launching the Edit Query Restrictions dialog
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Screenshot 275: Defining restrictions: Editing a query restriction

2. From the list of available fields, select a field. Optionally, key in the name in Field Name text box
to search for the required field.

3. Specify a Field Operator for the selected field. Available operators include:

Field Operator Description

Equal To When the event field is equal to the value configured.

Less than When the event field is has a smaller value than the value configured.

Greater than When the event field is has a larger value than the value configured.

Occurred (Related to date/time fields) When the event field date occurred before the value date.

Like When the event field has similar text as the value text.

Contains When the event field contains the value text.

Value in List When the event field is equal to one of the values in a list.

Table 97: Defining restrictions: Field Operators

4. Specify a Field Value for the selected field and operator. Some fields have predefined values;
others require you to specify a value.

5. Click OK.

Note

Repeat steps 1 to 4 to add all the fields you want to include in the query.
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Note

You can copy report restrictions from existing reports. From Reporting tab > Reports,
right-click a report and select Copy Report Restrictions.

Screenshot 276: Defining restrictions: Customizing the condition

6. Once all the restrictions are defined, use the options described below to customize the query
conditions:

Options Description

AND Select the condition to configure and select AND. The selected condition AND the following condition(s) must
be met for the query to be valid.

OR Select the condition to configure and select OR. The selected condition OR the following condition(s) must be
met for the query to be valid.

AND
NOT

Select the condition to configure and select AND NOT. This means that the selected condition has to match
the restriction parameters but the following conditions must not.

OR NOT Select the condition to configure and select OR NOT. This means that the selected condition has to match the
restriction parameters OR the following conditions must not.

+ ( Click ‘+ (‘ to add an opening bracket to the selected condition. Conditions enclosed in brackets are processed
first.

Table 98: Defining restrictions: Query Condition tools
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Options Description

+ ) Click ‘+ )’ to add a closing bracket to the selected condition. Conditions enclosed in brackets are processed
first.

- ( Click ‘- (‘ to remove an opening bracket from the selected condition.

- ) Click ‘- )’ to remove a closing bracket from the selected condition.

Add Click Add to launch the restrictions dialog and add more fields to the condition.

Edit Click Edit to access the restrictions dialog and customize the selected condition.

Delete Click Delete to delete a condition.

Clear The Clear button deletes all the query conditions.

Up
arrow

Use the Up arrow key to move the selected condition up in the list.

Down
arrow

Use the Down arrow key to move the selected condition down in the list.

7. Click Apply and OK.
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16 Command Line Tools

GFI EventsManager provides you with command line tools through which you can perform various
functions without accessing the Management Console. The available CMD tools are located in the GFI
EventsManager install folder.

Topics in this chapter:

16.1 Using ESMCmdConfig.exe 308

16.2 Using EsmDlibM.exe 311

16.3 Using DLibAdm.exe 319

16.4 Using EsmReport.exe 321

16.1 Using ESMCmdConfig.exe

ESMCmdConfig.exe enables you to configure general settings for GFI EventsManager; such as:

GFI EventsManager logon credentials

License key

Mail server settings

Administrator account

Create/Remove Group shortcuts

Get computer names.

To use ESMCmdConfig.exe:

1. Click Start > Run and key in CMD.

2. Click Ctrl + Shift + Enter to run CMD with elevated privileges.

3. Change the directory to the GFI EventsManager install directory. Example:

CD <C:\Program Files\GFI\EventsManager>

4. Key in ESMCmdConfig.exe followed by the functions described below:

/op:registerService

/op:enable

/op:disable

/op:SetLicense

/op:configureAlerting

/op:setAdminEmail

/op:createProgramGroupShortcuts

/op:removeProgramGroupShortcuts

/op:getComputers
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16.1.1 /op:registerService

This function enables you to register GFI EventsManager services, using an administrator account. The
following parameters are supported:

Parameter Description

/username:<username> Specify the username of an administrator account.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/pass:<password> Specify the password for the account specified in the /username parameter.

Table 99: /op:registerService Parameters

Example

ESMCmdConfig.exe /op:registerService /username:Domain\Administrator
/pass:p@ss

16.1.2 /op:enable

This function enables you to turn on events management features and does not support additional
parameters.

Example

ESMCmdConfig.exe /op:enable

16.1.3 /op:disable

This function enables you to turn off events management features and prompts the user with a
custom message. The following parameter is supported:

Parameter Description

/message:<mes-
sage>

Specify a custom message that is shown to the user before events management features are
disabled.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

Table 100: /op:disable Parameter

Example

ESMCmdConfig.exe /op:disable /message:"Events Management Disabled!"

16.1.4 /op:SetLicense

This function enables you to enter the product license key. The following parameter is supported:

Parameter Description

/licenseKey:<key> Specify the product license key.

Table 101: /op:SetLicense Parameters
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Example

ESMCmdConfig.exe /op:SetLicense /licenseKey:*********

16.1.5 /op:configureAlerting

This function enables you to turn on and configure email alerting options. The following parameters
are supported:

Parameter Description

/Server:<server> Specify the mail server IP address or fully qualified domain name (FQDN).

/SenderEmail:<email> Specify the sender email address. Notifications appear to have been sent from the
specified address.

/Port:<port> Specify the TCP port used to send emails.

/RequiresAuthentication:
<true|false>

Specify if the mail server requires authentication. Supported values are:
True

False.

/User:<username> Specify the username of the email address specified in the /SenderEmail
parameter.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/Pass:<password> Specify the password for the username specified in the /User parameter.

Table 102: /op:configureAlerting Parameters

Example

ESMCmdConfig.exe /op:configureAlerting /Server:192.168.11.11
/SenderEmail:jsmith@domain.com /Port:25 /RequiresAuthentication:True
/User:jsmith /Pass:p@ss

16.1.6 /op:setAdminEmail

This function enables you to configure the EventsManagerAdministrator email address. The following
parameter is supported:

Parameter Description

/email:<email> Specify the EventsManagerAdministrator email address.

Table 103: /op:setAdminEmail Parameter

Example

ESMCmdConfig.exe /op:setAdminEmail /email:esmadmin@domain.com

16.1.7 /op:createProgramGroupShortcuts

This function enables you to create group shortcuts and has no additional parameters.
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Example

ESMCmdConfig.exe /op:createProgramGroupShortcuts

16.1.8 /op:removeProgramGroupShortcuts

This function enables you to remove group shortcuts and has no additional parameters.

Example

ESMCmdConfig.exe /op:removeProgramGroupShortcuts

16.1.9 /op:getComputers

This function enables you to retrieve a text file containing the names of event sources managed by
GFI EventsManager. The following parameter is supported:

Parameter Description

/filename:<fileName> Specify the full path where the text file is exported to including the name of the text file.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

Table 104: /op:getComputers Parameter

Example

ESMCmdConfig.exe /op:getComputers /filename:C:\ComputerNames.txt

16.2 Using EsmDlibM.exe

EsmDlibM.exe enables you to run operations against the file storage system where processed events
are stored (database backend). Such operations include Importing or Exporting data.

To use EsmDlibM.exe:

1. Click Start > Run and key in CMD.

2. Click Ctrl + Shift + Enter to run CMD with elevated privileges.

3. Change the directory to the GFI EventsManager install directory. Example:

CD <C:\Program Files\GFI\EventsManager>

4. Key in EsmDlibM.exe followed by the functions described below:

/importFromSQL

/importFromDlib

/copyData

/importFromLegacyFile

/exportToFile

/importFromFile
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/commitDeletedRecords

/exportToSQL

16.2.1 /importFromSQL

This function enables you to import data from an SQL Server® database. The data must be exported
from an older version of GFI EventsManager. The following parameters are supported:

Parameter Description

/server:<serverName> Specify the SQL Server® IP address or machine name.

/database:<(maindb)|
(backupdb)|databaseName>

Specify the type and name of the source database to import data from .

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/dbauth:<SQL|WIN> Specify the authentication mode configured in the source SQL Server®. Supported
values include:

SQL: to use SQL Server® authentication

WIN: to use Windows® authentication.

/username:<username> Specify a username that has access to the database from which you want to import
data.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/password:<password> Specify the password for the username specified in the /username parameter.

/anonpass1:<password> (Optional) If the source database is anonymized, key in the primary anonymization pass-
word to decrypt import data.

/anonpass2:<password> (Optional) If the source database is anonymized, using two anonymization keys, key in
the secondary anonymization password to decrypt import data.

Table 105: /importFromSQL Parameters

Example

EsmDlibM.exe /importFromSQL /server:192.168.11.11
/database:EventsDatabase /dbauth:SQL /username:sa /password:p@ss
/anonpass1:p@ss

16.2.2 /importFromDlib

This function enables you to import data that was exported from a database server (DLIB) of an older
version of GFI EventsManager. The following parameters are supported:

Parameter Description

/path:<path> Specify the path to the DLib database server.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/name:<name> Specify the name of the DLib database you want to import.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/anonpass1:<
password>

(Optional) If the source database is anonymized, key in the primary anonymization password to
decrypt import data.

Table 106: /importFromDlib Parameters
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Parameter Description

/anonpass2:<
password>

(Optional) If the source database is anonymized, using two anonymization keys, key in the secondary
anonymization password to decrypt import data.

Example

EsmDlibM.exe /importFromDlib /path:C:\DLibServer /name:EventsData
/anonpass1:p@ss

16.2.3 /copyData

This function enables you to copy data from one DLib database server to another. The following
parameters are supported:

Parameter Description

/destinationPath:<des-
tinationPath>

Specify the destination database server.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/destinationName:<
destinationName>

Specify the destination database name.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/destinationEncPass:<
password>

(Optional) Specify a password to encrypt data at the destination.

/sourcePath:<
sourcePath>

Specify the path to the source database server.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/sourceName:<
sourceName>

Specify the name of the source database.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/sourceEncPass:<pass-
word>

(Optional) Specify an encryption key to encrypt source data.

/anonpass1:<
password>

(Optional) Specify the primary anonymization password to anonymize source data.

/anonpass2:<
password>

(Optional) Specify a secondary anonymization password to anonymize source data using two
keys.

Table 107: /copyData Parameters
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Parameter Description

/period:<type><num-
ber><unit>

Enables you to filter by event date to get events from the last days/weeks/months or older
than days/weeks/months. For instance, to filter events that happened in the Last 24 Days,
the parameter value is: l24d. And to filter events Older than 3 Weeks, the parameter value is
O3W. Supported values include:

<type>:

o - older than

l - last

<number> - specify the number of days/weeks/months

<unit>:

d - days

w - weeks

m - months.

/markEventsAsDeleted (Optional) Mark copied events as deleted from the source database. These events will no
longer be visible in the management console but will still remain in the database. To com-
pletely remove them from the database, run Commit Deletions job.

/log_format:<value>
/machine:<value> /im-
portance:<value> /oc-
cured:<value>

These parameters provide the user a convenient way to filter events by the corresponding
columns. Any of these filters are optional. When used together, they are linked in an AND
condition on the source data. Except for machine, where the user may enter the targeted
machine name as displayed in events browser, the other parameters have predefined values
with obvious meaning, that are listed below. Supported values are:

log_format:

"windows

sql audit

oracle audit

text logs

syslog messages

snmp traps

monitoring

importance

Unclassified

Low

Medium

High

Critical

Noise

occurred

Today

Yesterday

Last 7 days

Last 30 days

This month

Last month.
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Example

EsmDlibM.exe /copyData /destinationPath:Z:\DestServ
/destinationName:DestData /sourcePath:C:\SourServ
/sourceName:SourData /sourceEncPass:p@ss /markEventsAsDeleted

16.2.4 /importFromLegacyFile

This function enables you to import data that was exported to files from an older version of GFI
EventsManager. The following parameters are supported:

Parameter Description

/path:<path> Specify the path to the import file.

Note
Parameters that contain spaces must be
enclosed in double quotes (“).

/logTypes:<application, custom, directory, security, dns,
filereplication, syslog, system, snmp, oracle, sql, text>

(Optional) Specify the log types you want to import.
Exclude parameter to import all log types.

/password:<password> (Optional) Specify a password to decrypt import
data.

/anonpass1:<password> (Optional) Specify the primary anonymization pass-
word to anonymize import data.

/anonpass2:<password> (Optional) Specify a secondary anonymization pass-
word to anonymize import data using two keys.

Table 108: /importFromLegacyFile Parameters

Example

EsmDlibM.exe /importFromLegacyFile
/path:C:\ImportData\Configuration.cfg /password:p@ss /anonpass1:p@ss

16.2.5 /exportToFile

This function enables you to export data from a DLib database server to another one as part of the
data centralization process. You can also use this function to backup your data for safekeeping. The
following parameters are supported:

Parameter Description

/path:<path> Specify the folder path where data is exported to.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/sourceEncPass:<pass-
word>

(Optional) Specify a password to encrypt source data.

/destinationEncPass:<
password>

(Optional) Specify a password to encrypt destination data.

/anonpass1:<
password>

(Optional) If the source database is anonymized, key in the primary anonymization password to
decrypt exported data.

/anonpass2:<
password>

(Optional) If the source database is anonymized using two anonymization keys, key in the sec-
ondary anonymization password to decrypt export data.

Table 109: /exportToFile



GFI EventsManager 16 Command Line Tools | 316

Parameter Description

/period:<type><num-
ber><unit>

Enables you to filter by event date to get events from the last days/weeks/months or older
than days/weeks/months. For instance, to filter events that happened in the Last 24 Days,
the parameter value is: l24d. And to filter events Older than 3 Weeks, the parameter value is
O3W. Supported values include:

<type>:

o - older than

l - last

<number> - specify the number of days/weeks/months

<unit>:

d - days

w - weeks

m - months.

/markEventsAsDeleted (Optional) Mark copied events as deleted from the source database. These events will no
longer be visible in the management console but will still remain in the database. To com-
pletely remove them from the database, run Commit Deletions job.

/log_format:<value>
/machine:<value> /im-
portance:<value> /oc-
cured:<value>

These parameters provide the user a convenient way to filter events by the corresponding
columns. Any of these filters are optional. When used together, they are linked in an AND
condition on the source data. Except for machine, where the user may enter the targeted
machine name as displayed in events browser, the other parameters have predefined values
with obvious meaning, that are listed below. Supported values are:

log_format:

"windows

sql audit

oracle audit

text logs

syslog messages

snmp traps

monitoring

importance

Unclassified

Low

Medium

High

Critical

Noise

occurred

Today

Yesterday

Last 7 days

Last 30 days

This month

Last month.
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Example

EsmDlibM.exe /exportToFile /path:C:\ExportedDataFolder
/sourceEncPass:p@ss /markEventsAsDeleted /importance:High

16.2.6 /importFromFile

This function enables you to import data from a file as part of the data centralization process. The
import file must be created from an Export to File job. The following parameters are supported:

Parameter Description

/path:<path> Specify the path to where the import file is saved.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/password:<pass-
word>

(Optional) If the import file is password protected, key in the password.

/log_
format:<value>
/machine:
<value> /im-
portance:
<value>
/occured:
<value>

These parameters provide the user a convenient way to filter events by the corresponding columns.
Any of these filters are optional. When used together, they are linked in an AND condition on the
source data. Except for machine, where the user may enter the targeted machine name as
displayed in events browser, the other parameters have predefined values with obvious meaning,
that are listed below. Supported values are:

log_format:

"windows

sql audit

oracle audit

text logs

syslog messages

snmp traps

monitoring

importance

Unclassified

Low

Medium

High

Critical

Noise

occurred

Today

Yesterday

Last 7 days

Last 30 days

This month

Last month.

Table 110: /importFromFile Parameters
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Example

EsmDlibM.exe /importFromFile /path:C:\ImportFolder\Import.cfg
/password:p@ss /machine:MS11.domain.com /occured:true

16.2.7 /commitDeletedRecords

This function enables you to delete events that are marked as deleted from the database. The
following parameters are supported:

Parameter Description

/dbPath:<dbPath> Specify the path to the database server which contains events marked as deleted.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/password:<password> (Optional) If the database is password protected, key in the password.

/anonpass1:<
password>

(Optional) If the database is anonymized, key in the password to remove anonymization.

/anonpass2:<
password>

(Optional) If the database is anonymized using two anonymization keys, key in the secondary
key.

Table 111: /commitDeletedRecords Parameters

Example

EsmDlibM.exe /commitDeletedRecords /dbpath:C:\DatabaseServerFolder
/password:p@ss /anonpass1:pa$$

16.2.8 /exoportToSQL

This function enables you to export specified event to SQL Server®. The following parameters are
supported:

Parameter Description

/server:<server-
Name>

Specify the IP address or computer name running SQL Server®.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/database:<maind-
b|backupdb>

Specify the name of the destination database.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/dbauth:<
SQL|WIN>

Specify the authentication mode configured in the source SQL Server®. Supported values include:
SQL: to use SQL Server® authentication

WIN: to use Windows® authentication.

/username:<user-
name

Specify a username that has access to the database from which you want to import data.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/password:<pass-
word>

Specify the password for the username specified in the /username parameter.

Table 112: /exportToSQL Parameters
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Parameter Description

/table:<table> Specify the name of the destination table.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/
period
:<
type
><number><unit>

Enables you to filter by event date to get events from the last days/weeks/months or older than
days/weeks/months. For instance, to filter events that happened in the Last 24 Days, the
parameter value is: l24d. And to filter events Older than 3 Weeks, the parameter value is O3W.
Supported values include:

<type>:

o - older than

l - last

<number> - specify the number of days/weeks/months

<unit>:

d - days

w - weeks

m - months.

/sourceEncPass:<
password>

(Optional) If the source data is encrypted, key in the password to decrypt exported data.

/anonpass1:<pass-
word

(Optional) If the source database is anonymized, key in the primary anonymization password to
decrypt exported data.

/anonpass2:<pass-
word>

(Optional) If the source database is anonymized using two anonymization keys, key in the sec-
ondary anonymization password to decrypt export data.

Example

EsmDlibM.exe /exportToSQL /server:192.168.11.11
/database:EventsDatabase /dbauth:SQL /username:sa /password:p@ss
/table:EventsTable /anonpass1:pa$$

16.3 Using DLibAdm.exe

DLibAdm.exe is used to run administrative operations on DLib Database Servers installed on the
network.

To use DLibAdm.exe:

1. Click Start > Run and key in CMD.

2. Click Ctrl + Shift + Enter to run CMD as an administrator.

3. Change the active directory to the install folder of DLib Database Server. Key in (example):

CD C:\Program Files\GFI\Database Server 2.0

Press Enter.

4. Key in DLibAdm.exe followed by the functions described below:

/decryptDatabase

/encryptDatabase

/displayAllDLib

/copyMoveDLib
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16.3.1 /decryptDatabase

This function enables you to decrypt an encrypted DLib database. The following parameters are
supported:

Parameter Description

/dbPath:<path> Specify the path to the database you want to decrypt.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/dbName:<name> Specify the name of the database you want to decrypt.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/password:<password> Specify the password used to decrypt the database.

Table 113: /decryptDatabase Parameters

Example

DLibAdm.exe /decryptDatabase /dbPath:"C:\Program Files\GFI\Database
Server 2.0" /dbName:EventsDatabase /password:p@ss

16.3.2 /encryptDatabase

This function enables you to encrypt a specified database. The following parameters are supported:

Parameter Description

/dbPath:<path> Specify the path to the database you want to encrypt.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/dbName:<name> Specify the name of the database you want to encrypt.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/password:<password> Specify the password used to encrypt the database.

Table 114: /encryptDatabase Parameters

Example

DLibAdm.exe /encryptDatabase /dbPath:"C:\Program Files\GFI\Database
Server 2.0" /dbName:EventsDatabase /password:p@ss

16.3.3 /displayAllDLib

This function enables you to list all the valid DLib Database Servers running in a specified folder. The
following parameter is supported:
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Parameter Description

/path:<path> Specify the folder path where you want to scan for valid DLib Database Servers.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

Table 115: /displayAllDLib Parameters

Example

DLibAdm.exe /displayAllDLib /path:"C:\Program Files\GFI\Database
Server 2.0"

16.3.4 /copyMoveDLib

This function enables you to copy or move a DLib database to a specified location. The following
parameters are supported:

Parameter Description

/sourcePath:<sourcePath> Specify the path to the source database (database you want to move or copy).

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/destinationPath:<destinationPath> Specify the path to the destination folder.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/copyMove:<copy|move> Specify the action to perform on the database. Supported values:
copy

move.

/dbName:<dbName> Specify the name of the database you want to copy or move.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

Table 116: /copyMoveDLib

Exmaple

DLibAdm.exe /copyMoveDLib /sourcePath:"C:\Program Files\GFI\Database
Server 2.0" /destinationPath:C:\EventsDatabases /copyMove:move
/dbName:EventsDatabase

16.4 Using EsmReport.exe

EsmReport.exe enables you to generate in-product reports such as configuration and job activity
reports.

To use EsmReport.exe:

1. Click Start > Run and key in CMD.

2. Click Ctrl + Shift + Enter to run CMD with elevated privileges.

3. Change the directory to the GFI EventsManager install directory. Example:
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CD <C:\Program Files\GFI\EventsManager>

4. Key in EsmReport.exe followed by any of the following functions:

Generate Configuration reports

Generate Status reports

Generate Events reports

16.4.1 Generate Configuration reports

This function enables you to generate Configuration reports about a single or group of event sources.
The following parameters are supported:

Parameter Description

/type:<con-
figuration|status|events>

Specify the type of report you want to generate. Supported values are:
configuration

status

events.

Key in /type:configuration to generate a configuration report.

/target:<path> Specify the folder path where the generated report is saved.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/format:<html|csv> Specify the format of the report. Supported values are:
html

csv.

/source:<name> Specify the event source name. Use this parameter to generate a configuration
report about a single event source.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/group:<name> Specify the event source group name. Use this parameter to generate a
configuration report about a group of event sources.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

Table 117: Configurations report parameters

Example

EsmReport.exe /type:configuration /target:C:\ReportsFolder
/format:html /group:"Domain Controllers"

16.4.2 Generate Status reports

This function enables you to generate GFI EventsManager Status reports. The following parameters
are supported:
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Parameter Description

/type:<con-
figuration|status|events>

Specify the type of report you want to generate. Supported values are:
configuration

status

events.

Key in /type:status to generate a status report.

/subtype:<messages|stats> Specify the type of status report you want to generate. Supported values are:
messages - when messages is specified, the following parameters can be used:

/period:<current|date> - key in current to generate a report containing
messages generated on the same day. Else key in a date to generate a
status report containing messages generated on the specified date.

stats - when stats is specified as a subtype, the following parameters can be
used:

/format:<html|csv> - specify the format of the report. Supported values
are HTML and CSV

/period:<"all time"|date> - specify the timeframe that the report is
based on. Supported values include "all time" or else a specific date

/options:<"error messages"|"only with issues"> - specify the type of
stats to generate. Supported values are "error messages" and "only with
issues"

/target:<path> - specify the folder path where the report is saved.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

Table 118: Status report parameters

Messages example

EsmReport.exe /type:status /subtype:messages /period:"current date"

Stats example

EsmReport.exe /type:status /subtype:stats /format:html
/period:20130111 /options:"error messages" /target:C:\StatsReports

16.4.3 Generate Events reports

This function enables you to generate Events reports. The following parameters are supported:

Parameter Description

/type:<con-
figuration|status|events>

Specify the type of report you want to generate. Supported values are:
configuration

status

events.

Key in /type:events to generate an events report.

Table 119: Events reports parameters
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Parameter Description

/repname:<fullReportName> Specify a name for the generated report.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/repid:<reportID> Specify a unique ID for the generated report.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/target<path> Specify the folder path where the report is saved.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/format:<html|csv> Specify the format of the report. Supported values are:
html

csv.

/datefrom:<startDate> Specify the start date of the timeframe to report on.

/dateto:<endDate> Specify the end date of the timeframe to report on.

/scheduled Specify this parameter to generate the report based on schedule settings con-
figured in the Management Console.

Example

EsmReport.exe /type:events /repname:"New Events Report" /repid:11
/target:C:\ReportsFolder /format:html /datefrom:20121201
/dateto:20130111

16.4.4 Using ImportSettings.exe

Importsettings.exe enables you to import configuration from a data folder or from a configuration file
that was exported from another instance of GFI EventsManager. Use this tool to backup configuration
settings of the Management Console.

To use ImportSettings.exe:

1. Click Start > Run and key in CMD.

2. Click Ctrl + Shift + Enter to run CMD with elevated privileges.

3. Change the directory to the GFI EventsManager install directory. Example:

CD <C:\Program Files\GFI\EventsManager>

4. Key in ImportSettings.exe followed by the parameters described below:

Parameter Description

/operation:
<operation>

Specify the operation to perform. Supported values are:
importFile

importFolder.

/destination:
<folder>

Specify the destination folder where configuration is imported.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

Table 120: CMD: ImportSettings.exe parameters
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Parameter Description

/sourceFile:<file-
name>

Specify the file name that contains exported configurations. Use this parameter to define the file
name when running an importFile operation.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/sourceFolder:
<folder name>

Specify the folder name that contains exported configurations. Use this parameter to define the
folder name when running an importFolder operation.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/id:<EsmIn-
stanceID>

This parameter can only be used when you want to change the instance ID of GFI EventsManager. If
no value is specified, the same ID is preserved. If you do not use this parameter, /operation, /des-
tination, /sourceFile or /sourceFolder parameters are mandatory.

Example

ImportSettings.exe /operation:importFile
/destination:C:\NewDestination /sourceFile:C:\ExportedSettings

OR

ImportSettings.exe /id:newInstanceID

16.4.5 Using ExportSettings.exe

ExportSettings.exe enables you to export configuration settings from GFI EventsManager to a
configuration file.

To use ExportSettings.exe:

1. Click Start > Run and key in CMD.

2. Click Ctrl + Shift + Enter to run CMD with elevated privileges.

3. Change the directory to the GFI EventsManager install directory. Example:

CD <C:\Program Files\GFI\EventsManager>

4. Key in ExportSettings.exe followed by the parameters described below:

Parameter Description

/destination:
<fileName>

Specify a valid folder path including file name where settings are exported to. Unless specified,
.esmbkp is appended as an extension to the file name.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

/folder:
<folder>

This parameter is used to instruct the tool to export settings from another location than the default
Data folder. Specify the folder path containing GFI EventsManager data settings to be exported.

Note
Parameters that contain spaces must be enclosed in double quotes (“).

Table 121: CMD: ExportSettings.exe parameters
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Example

ExportSettings.exe /destination:C:\NewDestination
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17 Miscellaneous

This chapter provides you with information related to configuring Third-Party components required
for GFI EventsManager auditing operations. Learn how to configure and run GFI EventsManager
actions through the provided command line tools.

Topics in this chapter:

17.1 Enabling event source permissions manually 327

17.2 Enabling event source permissions automatically 335

17.3 Disabling User Account Control (UAC) 340

17.1 Enabling event source permissions manually

This section describes how to configure permissions that are required by GFI EventsManager to audit
systems and process the necessary events. This process has to be done on each machine to scan.

This section contains information about:

Enabling permissions on Microsoft® Windows® XP

Enabling permissions on Microsoft® Windows® Vista

Enabling permissions on Microsoft® Windows® 7

Enabling permissions on Microsoft® Windows® Server 2003

Enabling permissions on Microsoft® Windows® Server 2008 (including R2)

Note

In an active directory environment, permissions can be set automatically via Group
Policy Object (GPO). For more information refer to Enabling event source permissions
automatically.

17.1.1 Enabling permissions on Microsoft® Windows® XP

To enable permissions Microsoft® Windows® event sources:

1. Click Start > Control Panel > Windows Firewall > Exceptions tab.
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Screenshot 277: Firewall rules on Microsoft® Windows® XP

2. From Programs and Services list, enable File and Printer Sharing.

3. Click OK.

17.1.2 Enabling permissions on Microsoft® Windows® Vista

To enable permissions on machines running Microsoft® Windows® Vista:

Step 1: Enable Firewall permissions

Step 2: Enable additional auditing features

Step 1: Enable Firewall permissions

1. Click Start > Control Panel > Security and click Allow a program through Windows Firewall from
the left panel.

2. Select Exceptions tab and from Allowed programs and features list, enable the following rules:

Remote Event Log Management

File and Printer Sharing

Network Discovery.

3. Click Apply.
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Step 2: Enable additional auditing features

1. Click Start > Run and key in secpol.msc. Press Enter.

2. From the Security Settings node, expand Local Policies > Audit Policy.

Screenshot 278: Local security policy window

3. From the right panel, double-click Audit object access.
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Screenshot 279: Audit object access properties

4. From the Audit object access Properties, select Success and Failure and click OK.

5. From the right panel, double-click Audit Process tracking.

6. From the Audit process tracking Properties, select Success and Failure and click OK.

7. From the right panel, double-click Audit account management.

8. From the Audit process tracking Properties, select Success and Failure and click OK.

9. From the right panel, double-click Audit system events.

10. From the Audit process tracking Properties, select Success and Failure and click OK.

11. Close the Local Security Policy window.
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17.1.3 Enabling permissions on Microsoft® Windows® 7

To enable permissions on machines running Microsoft® Windows® 7:

Step 1: Enable Firewall permissions

Step 2: Enable additional auditing features

Step 1: Enable Firewall permissions

To manually enable firewall rules on Microsoft® Windows® 7:

1. Click Start > Control Panel > System and Security and click Allow a program through Windows
Firewall, under Windows Firewall category.

Screenshot 280: Allowed programs in Microsoft® Windows® Vista or later

2. From Allowed programs and features list, enable the following rules:

Remote Event Log Management

File and Printer Sharing

Network Discovery.
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3. Select Domain, Private and Public for each rule mentioned above.

4. Click OK.

Step 2: Enable additional auditing features

1. Click Start > Run and key in secpol.msc. Press Enter.

2. From the Security Settings node, expand Local Policies > Audit Policy.

Screenshot 281: Local security policy window

3. From the right panel, double-click Audit object access.

4. From Audit object access Properties, select Success and Failure. Click OK.
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Screenshot 282: Audit object access Properties

5. From the right pane, double-click Audit Process tracking.

6. From Audit process tracking Properties, select Success and Failure. Click OK.

7. From Audit process tracking Properties, select Success and Failure. Click OK.

8. From the right panel, double-click Audit account management.

9. From Audit process tracking Properties, select Success and Failure. Click OK.

10. From the right panel, double-click Audit system events.

11. From Audit process tracking Properties, select Success and Failure. Click OK.

12. Close the local Security Policy window.

17.1.4 Enabling permissions on Microsoft® Windows® Server 2003

To manually enable firewall rules on Microsoft® Windows® Server 2003:

1. Click Start > Control Panel > Windows Firewall and select Exceptions tab.
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Screenshot 283: Enable firewall rules in Microsoft® Windows® Server 2003

2. From Programs and Services list, enable File and Printer Sharing.

3. Click OK.

17.1.5 Enabling permissions on Microsoft® Windows® Server 2008 (including R2)

1. Click Start > Control Panel > Security and click Allow a program through Windows Firewall under
Windows Firewall category.

2. In the list of programs, enable the following:

File and Printer Sharing

Network Discovery

Remote Event Log Management.
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Screenshot 284: Firewall rules on Microsoft® Windows® Server 2008

3. Click OK.

Note

In Windows® Server 2008 R2, ensure to select Domain, Private and Public for each rule
mentioned above.

17.2 Enabling event source permissions automatically

This section contains information about:

Enabling permissions on Windows® Server 2003 via GPO

Enabling permissions on Windows® Server 2008 via GPO

17.2.1 Enabling permissions on Windows® Server 2003 via GPO

To open enable permissions on all domain clients using Microsoft® Windows® Server 2003 domain
controller:
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1. Click Start > Run, key in mmc. Press Enter.

2. Click File > Add/Remove Snap-in and click Add.

3. Locate and select Group Policy Object Editor and click Add.

4. Click Browse, select Default Domain Policy and click OK.

5. Click Finish.

6. Select Group Policy Object Editor again and click Add.

7. Click Browse, double-click Domain Controllers folder and select Default Domain Controllers
Policy. Click OK.

8. Click Finish and Close.

9. From Console Root, expand Default Domain Policy > Administrative Templates > Network >
Network Connections > Windows Firewall > Domain Profile.

Screenshot 285: Domain Policy console in Microsoft® Windows® Server 2003

10. From Setting list, right-click Windows Firewall: Allow file and printer sharing exception and
select Properties.

11. From the Settings tab, select Enabled and click OK.

12. Repeat steps 9 to 11 for Default Domain Controllers Policy.

13. Click File > Save to save the management console. The group policy comes into effect the next
time each machine is restarted.

17.2.2 Enabling permissions on Windows® Server 2008 via GPO

To enable permissions on all domain clients:

1. Click Start > Administrative Tools > Group Policy Management.

2. Expand Group Policy Management > Forest > Domains > <Domain name> > Group Policy
Objects.
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Screenshot 286: Group Policy Management in Microsoft® Windows® Server 2008 R2

3. Right-click Default Domain Policy and select Edit.

4. Expand Computer Configuration > Policies > Windows Settings > Security Settings > Windows
Firewall with Advanced Security, right-click Inbound Rules and select New Rule…
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Screenshot 287: Group Policy Management Editor

5. In the New Inbound Rule Wizard, select Predefined and select File and Printer Sharing.
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Screenshot 288: Predefined rules

6. Click Next.

7. Select all rules and click Next.

8. Select Allow the connection and click Finish.

9. Repeat steps 5 to 8 for each of the following rules:

Remote Event Log Management

Network discovery.

10. From Group Policy Management Editor, expand Computer Configuration > Policies > Windows
Settings > Security Settings > Windows Firewall with Advanced Security, right click Outbound
Rules and select New Rule…

11. Repeat Steps 5 to 9 while at step 9 enable only Network Discovery.

12. Close Group Policy Management Editor.
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13. From Group Policy Management, expand Group Policy Management > Forest > Domains >
<Domain name> > Default Domain Controllers Policy.

14. Repeat steps 4 to 13.

15. Click File > Save to save the management console. The group policy comes into effect the next
time each machine is restarted.

17.3 Disabling User Account Control (UAC)

When GFI EventsManager is configured to collect events using a local account target machines must
have User Account Control (UAC) disabled. To disable UAC on Microsoft® Windows® Vista machines
or later:

1. Click Start > Run, key in secpol.msc and press Enter.

2. From Security Settings, expand Local Policies and click Security Options.

3. Right-click User Account Control: Run all administrators in Admin Approval Mode and select
Properties.

Screenshot 289: Disabling UAC

4. From the Local Security Settings tab, select Enabled and click OK.

5. Close the Local Security Policy window.
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18 Troubleshooting

Use the information in the following sections to resolve issues encountered in GFI EventsManager:

Documentation

GFI SkyNet

Request technical support

Web forum

Troubleshooter wizard

18.1 Documentation

If this manual does not satisfy your expectations, or if you think that this documentation can be
improved in any way, let us know via email on: documentation@gfi.com.

18.2 GFI SkyNet

GFI maintains a comprehensive knowledge base repository, which includes answers to the most
common problems. GFI SkyNet always has the most up-to-date listing of technical support questions
and patches. In case the information in this guide does not solve your problems, next refer to GFI
SkyNet by visiting: http://kb.gfi.com/.

18.3 Request technical support

If none of the resources listed above enable you to solve your issues, contact the GFI Technical
Support team by filling in an online support request form or by phone.

Online: Fill out the support request form and follow the instructions on this page closely to sub-
mit your support request on: http://support.gfi.com/supportrequestform.asp

Phone: To obtain the correct technical support phone number for your region visit:
http://www.gfi.com/company/contact.htm

Note

Before contacting Technical Support, have your Customer ID available. Your Customer
ID is the online account number that is assigned to you when first registering your
license keys in the GFI Customer Area at: http://customers.gfi.com.

We will answer your query within 24 hours or less, depending on your time zone.

18.4 Web forum

User to user technical support is available via the GFI web forum. Access the web forum by visiting:
http://forums.gfi.com

18.5 Troubleshooter wizard

To use the troubleshooting tool:

1. Go to the install folder of GFI EventsManager.

2. Locate and double-click Trouble.exe.

mailto:documentation@gfi.com
http://kb.gfi.com/
http://support.gfi.com/supportrequestform.asp
http://www.gfi.com/company/contact.htm
http://customers.gfi.com/
http://forums.gfi.com/
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3. Click Next at the wizard welcome screen.

Screenshot 290: Select information gathering mode

4. Select how the troubleshooter will collect information. Select from:

Automatically detect and fix known issues - Select this option to allow GFI EventsManager to
run a set of checks to determine what is wrong

Gather only application information and logs - Specify your contact details, issue description
and your system information to upload them to our support team. If you choose this option, skip
to step 9.
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Screenshot 291: Troubleshooter automatic checks

5. Wait for the troubleshooter to run the required checks and click Next.

Screenshot 292: Troubleshooter automatically fixing detected issues

6. Wait for the troubleshooter to apply fixes for issues detected during the check. If this solves your
problem, click Yes and Finish. If the problem remains, select No and click Next.
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Screenshot 293: If the problem persists, search for articles on our knowledge base

7. Search our knowledge base archive for articles related to your problem. Key in the error your are
encountering in the Enter search items text box and click Search. If this solves your problem, click
Yes and Finish. If the problem remains, select No and click Next.

Screenshot 294: Manually checking for issues

8. Click Next.
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Screenshot 295: Specify contact details

9. Key in your contact details so that our support team would be able to contact you for further
analysis information. Click Next.

Screenshot 296: Key in the problem description and other information

10. Specify the error you are getting and other information that would help our support team to
recreate this issue. Click Next.
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Screenshot 297: Gathering machine information

11. The troubleshooter scans your system to get hardware information. You can manually add more
information in the space provided or click Next.

Screenshot 298: Finalizing the troubleshooting process

12. At this stage, the troubleshooter creates a package with the information gathered from the
previous steps. Next, send this package to our support team so they can analyze and troubleshoot
your problem. Select from:



GFI EventsManager 18 Troubleshooting | 347

FTP Upload Instructions - Opens an article to give you instructions on how you can upload the
troubleshooter package to our FTP server

Open Containing Folder - Opens the folder containing the troubleshooter package so that you
can send it via email

Go to GFI Support - Opens the support page of GFI website.

13. Click Finish.
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19 Glossary

A

Actions
The activity that will be carried out as a result to events matching specific conditions. For
example you can trigger actions whenever an event is classified as critical. Actions supported
by GFI EventsManager include Email alerts, event archiving and execution of scripts.

Alerts
Notifications which inform recipients that a particular event has occurred. GFI EventsManager
can generate Email alerts, SMS alerts and Network alerts.

Archive
A collection of events stored in the SQL Server based database backed of GFI EventsManager.

Audit account management
Generates events when account management operations are done such as create/delete a
user account or group, enable/disable a user account and set/change a user password. For
more information, refer to http://technet.microsoft.com/en-us/library/cc737542
(WS.10).aspx

Audit process tracking
Generates events which track actions such as programs which are launched, closed, as well as
other indirect object access information which contain important security information. For
more information, refer to http://technet.microsoft.com/en-us/library/cc775520
(WS.10).aspx

Audit system events
Generates events when important system events happen such as user restarts or shuts down
the target computer or when an event occurs that affects the security log. For more inform-
ation, refer to http://technet.microsoft.com/en-us/library/cc782518(WS.10).aspx

C

COM+ Network Access
Enable this firewall permission to allow client machines to access applications or services that
resides on the server. This allows GFI EventsManager to access resource from all servers. For
more information about this permission, refer to http://technet.microsoft.com/en-us/lib-
rary/cc731967.aspx

E

Email alerts
Email notifications which inform recipients that a particular event has occurred. To enable
email alerts, you must have access to an active mail server.
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Event classification
The categorization of events as Critical, High Medium, Low or Noise.

Event logs
A collection of entries which describe events that occurred on the network or on a computer
system. GFI EventsManager supports different types of event logs including: Windows Event
Log, W3C Logs, Syslog, SNMP Traps and SQL Server audit events.

Event processing rules
A set of instructions which are applied against an event log.

F

File and Printer sharing
Enable this firewall permission to allow GFI EventsManager to access events definitions on tar-
get machines. For more information, refer to http://technet.microsoft.com/en-us/lib-
rary/cc779133(WS.10).aspx

I

Internet Protocol Security
A framework of open standards used to encrypt and authenticate network packets during a
communication session between computers. Using cryptography services, IPsec ensures data
integrity, authentication and confidentiality.

IPsec
Internet Protocol Security is a framework for a set of protocols for security at the network or
packet processing layer of network communication. Earlier security approaches have inserted
security at the Application layer of the communications model. IPsec is said to be especially
useful for implementing virtual private networks and for remote user access through dial-up
connection to private networks. A big advantage of IPsec is that security arrangements can be
handled without requiring changes to individual user computers.

M

Management Information Base
A MIB is the equivalent of a data dictionary or codebook. It associates object identifiers (OIDs)
with a readable label and various other parameters related to an active network object such
as a router. Its main function is to assemble and interpret SNMP messages transmitted from
SNMP-enabled network devices. The information stored in MIBs is organized hierarchically and
is normally accessible using a protocol such as SNMP.

N

Network alerts
Network messages (known as Netsend messages) which inform recipients that a particular
event has occurred. These messages are sent through an instant messenger system/protocol
and are shown as a popup in the system tray of the recipient’s desktop. To setup network
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alerts, you must specify the name or IP of the computers where the Netsend messages will be
sent.

Network discovery
Enable this firewall permission to allow GFI EventsManager to gather information about con-
nected machines on the network that can be scanned. For more information, refer to http://-
technet.microsoft.com/en-us/library/cc181373.aspx

Noise
Repeated log entries which report the same event.

O

Object auditing
Enable this auditing feature to audit events of users accessing objects (example, files, folder
and printer). For more information, refer to http://technet.microsoft.com/en-us/lib-
rary/cc976403.aspx

R

Remote Event Log Management
Required to allow GFI EventsManager to access and collect events from remote machines. For
more information, refer to http://technet.microsoft.com/en-us/library/cc766438.aspx

Rule-set folder
The folder which contains one or more rule-sets.

Rule-sets
A collection of event processing rules.

S

SMS alerts
SMS notifications which inform recipients that a particular event has occurred. In GFI Event-
sManager, SMS alerts can be sent through various sources including mobile phones with
modem capabilities and email-to-SMS web-based gateways.

SNMP Object Identifier (OID)
An SNMP object identifier is an address made up of a sequence of ‘dotted’ numbers (Example:
1.3.6.1.4.1.2682.1). These numbers uniquely identify and locate a specific device (Example:
hub) within the entire network. SNMP OIDs are a key component in the assembly of SNMP mes-
sages. In fact, an SNMP server cannot interpret or assemble messages which don’t have an
OID. Individual vendors often create their own MIBs that only include the OIDs associated spe-
cifically with their device.

SNMP Traps
Notifications/alerts generated and transmitted by active network components (Example:
hubs, routers and bridges) to SNMP server(s) whenever important events such as faults or
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security violations occur. Data contained in SNMP Traps may contain configuration, status as
well as statistical information such as number of device failures to date.

Syslog messages
Notifications/alerts most commonly generated and transmitted to a Syslog server by UNIX and
Linux-based systems whenever important events occur. Syslog messages can be generated by
workstations, servers as well as active network devices and appliances such as Cisco routers
and Cisco PIX firewalls to record failures and security violations amongst other activities.

U

Unclassified events
Events that did not satisfy any of the event processing conditions configured in the event pro-
cessing rules.

W

W3C logs
W3C is a common log format developed by the World Wide Web Consortium. W3C logs are
text-based flat files used mainly by web servers including Microsoft Internet Information
Server (IIS) to record web related events such as web logs.

Windows Event Logs
A collection of entries which describe events that occurred on a computer system running Win-
dows OS.
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